New install hass.io with RaspBee II failure

Hi

I am totally new to this. I just followed the guide: Raspberry Pi - Home Assistant including buying the hardware mentioned in the guide, as well as the RaspBee II from Dresden Elektronik along with two Aqara sensors, to start with.

My problem is that I cannot get it to work at all.
I have followed the guides to the letter, but to no avail. :frowning:
For troubleshooting I have gone through all the forum-articles I could find, changing one thing at a time (which is a pain being a mac-user (there should be an option to edit the config.txt directly from the webgui).
I think I might have the correct setting in config.txt now, although I cannot confirm it, as nothing works. I have a /dev/ttyAMA0 and a /dev/ttyS0 to choose from, as a result of these settings:

enable_uart=1
dtoverlay=pi3-miniuart-bt

I have the deCONZ addon installed but I cannot do anything in it. In the deCONZ vnc app, I can click the connect button, it fades gray for 3 seconds then comes back.
The PhosCon settings under advanced says:
Version: 2.11.05 / 5/9/2021
Firmware: Not connected
As for integrations I have tried both deCONZ and ZHA, with no luck at all.

  • deCONZ integration: It wants a host ip and port. I gave it none when installing the add-on, so is it just the ip of the host that the webgui of HA runs on or the IP the add-on reports in the top right corner?
    Either way, neither works when I am to “link with deCONZ”. It just ends with “Couldn’t get an API key” every time.
  • ZHA integration: This just ends in “Failed to connect” no matter which serial device I choose.

Can someone help me out?

Best regards
Ian

<‘frustration>
I thought this was going to fairly easy to get up and running, but having spent many hours painstakingly trying each suggestion I could find, one at a time, only to ram my head into the wall every time, I am not impressed at all. There is way too much fiddling around with text-files and modules/add-ons/integrations to be anything near smooth or easy.
I am about to give up on the whole thing and just throw it all in the trash!
<’/frustration>

How did you install the software for the stick?

I went into “Supervisor” → “Add-on Store” → Selected “deCONZ”

Oh, and it’s not a stick. Its this thing: RaspBee II Overview

deCONZ keeps stating firmware as “Not Connected”

I have tried different settings and combinations in the config.txt, including

dtoverlay=pi3-miniuart-bt

or

enable_uart=1
dtoverlay=pi3-disable-bt

or

dtoverlay=miniuart-bt

Or the current one which is:

enable_uart=1
dtoverlay=disable-bt

All this changes absolutely nothing with my current predicament. :weary:

I mean which kind of installation way have you followed, according to this:


https://phoscon.de/en/raspbee2/install

None
I have followed this: deCONZ - Home Assistant

I have not found a way to SSH into this fresh install of .hass.io, so I presumed that was not necessary for installing deCONZ module on .hass.io

.

Have a look at the section „Troubleshooting“:

If you are having issues and want to report a problem, always start with making sure that you’re on the latest deCONZ software version and latest firmware for hardware.

So without any Dresden Elektronik software you won’t be connected.

According to change log, I am on the latest of versions for deCONZ:

As for firmware, I don’t what to do, since it won’t connect.

Did I mention I am a total noob at this Home Assistant thing?

I can only speak for Conbee 2, but I‘m sure the forum has a description how to ssh into your Raspbi. Out of that, I’m using an app called WebSSH.

Did you read/do this;

Hi

After a long day of trial and error I managed to something working. This is what I did:

  • Took everything apart and started over completely
  • Default haos install, using a flashed SD card with haos_rpi4-64-6.2.img.xz on.
  • Corrected config.txt via ssh as described here: Debugging the Home Assistant Operating System | Home Assistant Developer Docs (because I am a Mac-user, so no Windows/linux available) Took quite a while to find/figure out.
    • I only added this to the config.txt: dtoverlay=disable-bt
  • Installed deCONZ add-on og set it to run on /dev/ttyAMA0
    • Is now able to update firmware in the Phoscon web-app
  • I am now able to discover my sensors in either deCONZ web-app or with ZHA integrations. I just don’t know which is best.
1 Like

Hi @nomad.dk, I am following your journey now logged on via ssh, port 22222. On my Raspberry Pi 4, there is no config.txt file in the root.

Any suggestion what my next steps could be?

!fixed

My raspbee II replace the Xiaomi GW and the Philips Hue, I am very pleased.

I beg the question though, why put a config.txt file in the root that cannot be reached by ssh or a samba share? I borrowed a PC to be able to reach the root directory.

Sorry for the late reply. I imagine its a security-issue to have that file exposed, is my guess. I’m glad you got it fixed.

For future people searching for the config.txt: If it is not in / you may find it in /boot/ or even in /mnt/boot. Hope this helped.

@nomad.dk I wanted to thank you for documenting your solution. You saved me a few good hours of work on this. My setup is the same as yours:

  • HA OS install on Raspberry Pi 4
  • RaspBee II / 2 physically on GPIO of RPi4
  • deCONZ setup on /dev/ttyAMA0, but Phoscon UI unable to see firmware in Gateway details, and unable to detect any devices

I have skipped the ssh path to edit the boot partition config.txt file and just pulled the SD card, and edited the config.txt file using Notepad++ in Windows. Added only one line: dtoverlay=disable-bt

Boot back up and everything works now. Only anomaly is, now there is a new hardware called /dev/ttyS0.

Best I can describe why this works, is I’ve seen some reference that pins 8 and 10 are used by Bluetooth. These are pins that the Raspbee 2 uses, among others.

1 Like

On my Raspberry Pi 4 running Home Assistant the only things I had to do were really

  • In config.txt have enable_uart=1
  • Use /dev/ttyS0 as the device for the integration. I have used ZHA and Zigbee2mqtt

There has not been any need to disable bluetooth and I’m using bluetooth based devices and integrations with Raspberry’s internal bluetooth. No issues there.

Once the installation is done make sure you are not causing any troubles with other devices you might be having. Due to radio interference it has been suggested to run any other wireless devices like mouse/keyboard receivers with some USB extension cord. Also, try to avoid overlap with WiFi channels ZigBee and Wi-Fi Coexistence | MetaGeek