New Install, New User, and personal introduction

I think it was a typo but HassOS is the image which can be loaded on a number of system types to run and Home Assistant.

HassOS: GitHub - home-assistant/operating-system: 🔰 Home Assistant Operating System
Stripped down operating system (linux based) to run and Home Assistant. GitHub - home-assistant/supervisor: 🏡 Home Assistant Supervisor
A set of docker containers (Supervisor and Home Assistant). The supervisor keeps things up and running and allows the use of add-ons (pre-built docker containers to add onto home assistant)

HA : GitHub - home-assistant/core: 🏡 Open source home automation that puts local control and privacy first.
Everyone runs this regardless of install method. This is the base code that runs the home automation system.

1 Like

Oh, from this I thought you had tried to pair and failed:

What else are you wanting to do before attempting to pair a device?

1 Like

I’m just wanting to make sure the z-wave component is reporting correctly. Currently it doesn’t show up on the side panel under “Configuration” like it should. So, I’m not sure what I’m doing wrong. I’ve added in the “dialup” group to the server and chowned the /dev/ttyACM0. So it should be reporting correctly. I’ll know if this worked when I get home later this evening.

# [ls -l /dev/ttyACM0]
crw-rw---- 1 root    dialout 166,  0 Apr  3 21:03 /dev/ttyACM0

what version of HA are you on?

It’s in the OP. I’ve added the user to the dialout group as well.

I wonder if my issue has anything to do with the the version I’m running. Keep in mind, this was a new install using pip. If this is the case, is there docs I can use to downgrade to 0.90.1?

I have been running zwave fine on 0.90.2

Try going under Configuration Integration and configuring zwave there. If it sees your yaml entries it will complain.

Good to know. I wonder if changing the group information from uucp to dialout is what will fix it. Again, I’ll know when I get home.

Yeah, sorry. I missed that.

If you originally tried to run it thru the integration then what is likely happening is that the path that was automatically configured is stuck in the device registry and is complaining that it can’t find that device because it’s really at ACM0 and not some other thing.

You can solve that in two ways. Either go into the device registry and manually edit the xml file there to change it to ACM0 or just delete the entry completely. Or better would be to update to v91 since with that new version the configuration.yaml usb path overrides that which is stored in the device registry so it won’t care what the value it has in there any more.

all of this is conjecture based on things I’ve seen helping others solve other zwave problems. So I’m confident that it’s at least a reasonable path to go down. But it’s still possible (maybe even likely…) that I’m completely wrong. :slightly_smiling_face:

1 Like

“Human after all” you might say… :crazy_face:


Personally, I would wait until the inevitable 0.91.1 I have learned the .0 is usually not worth the “pain”. I waited last time for the first patch & things went much smoother.

So here’s an update on the zwave front. There’s no change in the results of adding the integration in. Either manually or using the HA configuration menu. So I’m going to wait until 0.91.1 is released and work from there.

did you check the device registry to see if the path was wrong in there? I’m not suggesting you edit it if you’re not comfortable with that. but It would be interesting to see if that is where the potential problem is.

I think I’m missing something… where do I find the device registry?

It’s in the config directory in the .storage folder

This is what I’m seeing on this end. I checked through the core.config_entries (only file I found with zwave or ttyACM0 in it) but it looked correct.

            "connection_class": "local_push",
            "data": {
                "network_key": <Redacted>,
                "usb_path": "/dev/ttyACM0/"
            "domain": "zwave",
            "entry_id": "61705ec5230448f59c671ef58cf9b39f",
            "options": {},
            "source": "import",
            "title": "Z-Wave (import from configuration.yaml)",
            "version": 1

yes, that looks right in the config.

do you see anything in the configuration menu itself one level back from what the screen shot you posted? maybe you are just looking in the wrong spot?


1 Like

On a side note… I was able to get my Wink 2 authorization working correctly so I can see all of the zwave devices I have connected with Wink. Still no zwave through the server install though.

The pic from post 20 is the only location I can see any Z-Wave control.

that’s strange.

you should also have the entry that i showed above. I actually have zwave in both areas.

I have no idea why one would show up and not the other.

I’m out of ideas at this point.

You have 2 independent z-wave networks then?
1 controller in the wink hub & 1 controller for home assistant?