New install - Unable to install HACS

Just created brand new home assistant install and I am trying to get the HACS integration working. I have created the custom_components folder (via SAMBA and SSH) and then copied HACS folder over. Restarted HA (and even VM) but when trying to add the HACS integration after restart, it does still not appear in the search results.

Any ideas? Home Assistant 0.116.4 running on Virtualbox Ubuntu 64-bit

I’m having the exact same issue. I’m running Home Assistant 0.116.4 in Docker. I’ve been able to get all the other integrations that I have tried working without a problem, but I’ve spent the last two hours on this so far.
I can see that Home Assistant sees HACS from the log, since I get the following message every time Home Assistant starts:

Logger: homeassistant.loader
First occurred: 4:06:58 PM (1 occurrences)
Last logged: 4:06:58 PM
You are using a custom integration for hacs which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant. 

So far, HACS has not shown up in Integrations, even after clearing my browsers cache multiple times and restarting HA and the docker container. I am unable to get the point of adding my GitHub token. Any help would be greatly appreciated.

Hopefully you both are hitting the big “+” in the bottom right and searching there?

Yes. I already have 7 other integrations added and working great. However, as soon as I look for HACS, nothing shows up in the list.

I would look for other issues in the log and consider posting in the Discord server:

Well, the only thing in the log is the warning I posted here. I guess I’ll check the discord server later when I get back home.

Alright, I was able to get it to work after I manually configured it with YAML. For whatever reason, the non-legacy method never worked for my install. Up until this point, I have been able to use all of the standard methods of setting up Home Assistant so I don’t know what could be the cause of this. If there is anything that more experienced users would like to see to troubleshoot this further, please let me know. I’d be happy to help.

1 Like

I am seeing the same problem. Log shows “You are using a custom integration for hacs which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant”

Can you please share the relevant YAML entry.

I just followed the instructions at

After copying over all of the files and generating my GitHub token, I added the following to the bottom of configuration.yaml:

  sidepanel_title:  Community
  sidepanel_icon: "mdi:alpha-c-box"
  release_limit: 5

I just added my personal token from GitHub on the token line and then specified by country with its two-character code on the country line. After restarting Home Assistant, everything worked as it should.



I have a HA system running HASSOS on a Raspberry Pi.
Home Assistant 2023.6.2
Supervisor 2023.06.2
Operating System 10.2

I have been trying to install hacs for several days.

I have followed the instructions at .

I checked that the hacs directory was installed in the custom_components directory, and that the files were there and restarted using the RESTART Option under the Hardware menu/Restart HomeAssistant, but when trying to add the integration, hacs was not found.

I then deleted the directory and repeated the process, but this time I rebooted the Pi both after deleting the hcas directory and after readding it, but when it came back the hacs was still not found. I have reviewed the logs and there is no indication that the integration is seen.

I then ran the process by deleting the hacs directory again and using direct wget of the file from the ssh command and then unpacking to the directory, and deleting the zip file. This time i did a full shutdown of the Pi and rebooted from cold.

in all cases I have used a different browser, cleared the cache and the hacs is not found.

The most recent attempt I added the bit of code from general_tux in the configuration.yaml, and did a Restart from Developer Tools. but I received this message
“The system cannot restart because the configuration is not valid: Integration error: hacs - Integration ‘hacs’ not found”

I am using the standard SSH/Terminal Addon, but have gone through the proccess several times by using the SSH from my Mac with the same results.

I checked and the filetree looks like

Is there anything else I need to do? Any other fixes that may cause the hacs integration to be found?