Home Assistant Community

New integration: Energy monitoring device Circutor Wibeee

#21

Thank you very much Juan Sanz, I can confirm that the mirubee moti-1 monophasic version works perfectly with Oscar’s modification. You can make very interesting automations thanks to your work.

mirubee moti-1

<response>

<fase1_vrms>236.38</fase1_vrms>

<fase1_irms>1.94</fase1_irms>

<fase1_p_aparent>457.63</fase1_p_aparent>

<fase1_p_activa>294.40</fase1_p_activa>

<fase1_p_reactiva_ind>0.00</fase1_p_reactiva_ind>

<fase1_p_reactiva_cap>343.96</fase1_p_reactiva_cap>

<fase1_frecuencia>50.00</fase1_frecuencia>

<fase1_factor_potencia>0.643</fase1_factor_potencia>

<fase1_energia_activa>695852.02</fase1_energia_activa>

<fase1_energia_reactiva_ind>24519.91</fase1_energia_reactiva_ind>

<fase1_energia_reactiva_cap>559479.55</fase1_energia_reactiva_cap>

<fase2_vrms>0.00</fase2_vrms>

<fase2_irms>0.00</fase2_irms>

<fase2_p_aparent>0.00</fase2_p_aparent>

<fase2_p_activa>0.00</fase2_p_activa>

<fase2_p_reactiva_ind>0.00</fase2_p_reactiva_ind>

<fase2_p_reactiva_cap>0.00</fase2_p_reactiva_cap>

<fase2_frecuencia>0.00</fase2_frecuencia>

<fase2_factor_potencia>0.000</fase2_factor_potencia>

<fase2_energia_activa>0.00</fase2_energia_activa>

<fase2_energia_reactiva_ind>0.00</fase2_energia_reactiva_ind>

<fase2_energia_reactiva_cap>0.00</fase2_energia_reactiva_cap>

<fase3_vrms>0.00</fase3_vrms>

<fase3_irms>0.00</fase3_irms>

<fase3_p_aparent>0.00</fase3_p_aparent>

<fase3_p_activa>0.00</fase3_p_activa>

<fase3_p_reactiva_ind>0.00</fase3_p_reactiva_ind>

<fase3_p_reactiva_cap>0.00</fase3_p_reactiva_cap>

<fase3_frecuencia>0.00</fase3_frecuencia>

<fase3_factor_potencia>0.000</fase3_factor_potencia>

<fase3_energia_activa>0.00</fase3_energia_activa>

<fase3_energia_reactiva_ind>0.00</fase3_energia_reactiva_ind>

<fase3_energia_reactiva_cap>0.00</fase3_energia_reactiva_cap>

<fase4_vrms>0.00</fase4_vrms>

<fase4_irms>0.00</fase4_irms>

<fase4_p_aparent>0.00</fase4_p_aparent>

<fase4_p_activa>0.00</fase4_p_activa>

<fase4_p_reactiva_ind>0.00</fase4_p_reactiva_ind>

<fase4_p_reactiva_cap>0.00</fase4_p_reactiva_cap>

<fase4_frecuencia>0.00</fase4_frecuencia>

<fase4_factor_potencia>0.000</fase4_factor_potencia>

<fase4_energia_activa>0.00</fase4_energia_activa>

<fase4_energia_reactiva_ind>0.00</fase4_energia_reactiva_ind>

<fase4_energia_reactiva_cap>0.00</fase4_energia_reactiva_cap>

<coilStatus/>

<scale>65</scale>

</response>

#22

Error while setting up platform wibeee Traceback (most recent call last): File "/usr/local/lib/python3.7/site-packages/homeassistant/helpers/entity_platform.py", line 128, in _async_setup_platform SLOW_SETUP_MAX_WAIT, loop=hass.loop) File "/usr/local/lib/python3.7/asyncio/tasks.py", line 416, in wait_for return fut.result() File "/usr/local/lib/python3.7/concurrent/futures/thread.py", line 57, in run result = self.fn(*self.args, **self.kwargs) File "/config/custom_components/wibeee/sensor.py", line 77, in setup_platform sensor_phase,sensor_name = item.tag.split("_",1) ValueError: not enough values to unpack (expected 2, got 1)

#23

I recommend you to call directly REST API and check if response is similar to the one i posted. Also check csrp post, they have a different response format, and for that, they have done some modifications.

Or even better, compare your response with the ones I documented in github repo:

#24

Hola Juanjo
Would it be posible to adapt the Mirubee component to new HA custom components structure (HA 0.88+) ?

#25

Notable breaking change

We finished the great migration. All built-in platforms are now in their own folder. This means that if you had a custom component or platform that had the same name as a built-in one, you have to rename it. If you still have platforms in your custom_components/ directory in the old file format, sensor/my_platform.py , rename it to my_platform/sensor.py . It still works but it will not be supported in a future release.

#26

regarding the last two messages, thanks for the info. Unfortunately I have right now no time at all for those adaptions, just be patient or if anyone wants to do the work, all the code is accesible in github

1 Like
#27

as it was just a name/folder rename, I was able to do it and test it with my wibeee device (3 phases)

Please, check git repository.

1 Like
#28

Thanks @juanjoSanz , simply by renaming the component stops sending in message, everything continues to work as it should.

<hass_folder>/custom_components/wibeee/sensor.py
1 Like
#29

It seems that when updating to version 0.92.0b1 and 0.92.0b2, the component stops working tomorrow I will investigate the issue, to see what happens with the final version.

For now it is recommended to use the version: 0.91.4

Test version 0.92.0b3

Log Details (ERROR)

Tue Apr 23 2019 22:20:35 GMT+0200 (hora de verano de Europa central)

Integration not found: introduction Integration wibeee not found when trying to verify its sensor platform.

An option to start the component, creating a file if there is a record of failures.

File: manifest.json

{
  "domain": "wibeee",
  "name": "Wibeee",
  "documentation": "https://github.com/juanjoSanz/hass_wibeee",
  "dependencies": [],
  "codeowners": ["@juanjoSanz"],
  "requirements": []
}

Log Details (WARNING)

Tue Apr 23 2019 22:48:19 GMT+0200 (hora de verano de Europa central)

You are using a custom integration for wibeee which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you do experience issues with Home Assistant.

Log Details (WARNING)

Tue Apr 23 2019 22:48:24 GMT+0200 (hora de verano de Europa central)

Your configuration contains extra keys that the platform does not support. Please remove [name], [host], [phases].

Thanks to @juanjoSanz and @Oscar , for their great work.

#30

I already manage that the component is executed with the final version 0.92.0

hass_folder/custom_components/wibeee/

File: manifest.json

{
“domain”: “wibeee”,
“name”: “Wibeee”,
“documentation”: “https://github.com/juanjoSanz/hass_wibeee”,
“dependencies”: [],
“codeowners”: ["@juanjoSanz"],
“requirements”: []
}

File: > __init__.py

This file creates it blank.

Do not make any modification of the component code and everything seems to work correctly.

#31

thanks, I have added manifest file to github repo.

About:

File: > __init__.py

I understood, this file should contain now the initialization of the component.

I would need to rewrite the component, let’s see if I can get the time to do it.

1 Like
#32

@juanjoSanz Thanks, the important thing was found a simple way to solve the problems generated by the new version 0.92.0

I fully understand your situation and I deeply appreciate that you share your work with the community, I can not be of help in the part of the code, but for any test you have all my help.

I will continue researching the subject to try to provide data to this group and to be of help, to maintain and improve the component.

#33

@juanjoSanz I have a Mirubox voltimeter and i am trying to implement it into HA but i can´t, is there any tutorial from the beginning?
Thank you

#34

Hi,

Just check if your device expose the data as XML as wibeee does. In the GitHub repository I have uploaded one example of that XML format. If so, we may only need to adapt XML parsing to your format. Indeed we can define different parsing methods in this component to support all similar devices that exists.

Best regards,
Juanjo

2 Likes
#35

Thanks, I have managed to not fail me the configuration, but It still do not give the data, when I get home I will test with the xml.

#37

This is my XML, it seems the same as @dieandgo, I modified the code you told him but the sensors says “Desconocido”:

<response>

<model>WBB</model>

<webversion>4.4.104</webversion>

<time>1556786855</time>

<fase1_vrms>230.75</fase1_vrms>

<fase1_irms>3.95</fase1_irms>

<fase1_p_aparent>910.89</fase1_p_aparent>

<fase1_p_activa>879.08</fase1_p_activa>

<fase1_p_reactiva_ind>0.00</fase1_p_reactiva_ind>

<fase1_p_reactiva_cap>238.60</fase1_p_reactiva_cap>

<fase1_frecuencia>50.23</fase1_frecuencia>

<fase1_factor_potencia>-0.965</fase1_factor_potencia>

<fase1_energia_activa>64070</fase1_energia_activa>

<fase1_energia_reactiva_ind>5278</fase1_energia_reactiva_ind>

<fase1_energia_reactiva_cap>26887</fase1_energia_reactiva_cap>

<fase1_angle>0.00</fase1_angle>

<fase1_thd_total>16.00</fase1_thd_total>

<fase1_thd_fund>3.90</fase1_thd_fund>

<fase1_thd_ar3>0.60</fase1_thd_ar3>

<fase1_thd_ar5>0.00</fase1_thd_ar5>

<fase1_thd_ar7>0.20</fase1_thd_ar7>

<fase1_thd_ar9>0.00</fase1_thd_ar9>

<fase1_thd_tot_V>3.30</fase1_thd_tot_V>

<fase1_thd_fun_V>229.80</fase1_thd_fun_V>

<fase1_thd_ar3_V>0.00</fase1_thd_ar3_V>

<fase1_thd_ar5_V>4.70</fase1_thd_ar5_V>

<fase1_thd_ar7_V>0.00</fase1_thd_ar7_V>

<fase1_thd_ar9_V>0.00</fase1_thd_ar9_V>

<fase2_vrms>231.15</fase2_vrms>

<fase2_irms>0.00</fase2_irms>

<fase2_p_aparent>0.00</fase2_p_aparent>

<fase2_p_activa>0.00</fase2_p_activa>

<fase2_p_reactiva_ind>0.00</fase2_p_reactiva_ind>

<fase2_p_reactiva_cap>0.00</fase2_p_reactiva_cap>

<fase2_frecuencia>50.08</fase2_frecuencia>

<fase2_factor_potencia>0.000</fase2_factor_potencia>

<fase2_energia_activa>44</fase2_energia_activa>

<fase2_energia_reactiva_ind>32</fase2_energia_reactiva_ind>

<fase2_energia_reactiva_cap>2</fase2_energia_reactiva_cap>

<fase2_angle>0.00</fase2_angle>

<fase2_thd_total>0.00</fase2_thd_total>

<fase2_thd_fund>0.00</fase2_thd_fund>

<fase2_thd_ar3>0.00</fase2_thd_ar3>

<fase2_thd_ar5>0.00</fase2_thd_ar5>

<fase2_thd_ar7>0.00</fase2_thd_ar7>

<fase2_thd_ar9>0.00</fase2_thd_ar9>

<fase2_thd_tot_V>2.00</fase2_thd_tot_V>

<fase2_thd_fun_V>229.80</fase2_thd_fun_V>

<fase2_thd_ar3_V>0.00</fase2_thd_ar3_V>

<fase2_thd_ar5_V>4.70</fase2_thd_ar5_V>

<fase2_thd_ar7_V>0.00</fase2_thd_ar7_V>

<fase2_thd_ar9_V>0.00</fase2_thd_ar9_V>

<fase3_vrms>231.15</fase3_vrms>

<fase3_irms>0.23</fase3_irms>

<fase3_p_aparent>54.21</fase3_p_aparent>

<fase3_p_activa>5.54</fase3_p_activa>

<fase3_p_reactiva_ind>0.00</fase3_p_reactiva_ind>

<fase3_p_reactiva_cap>0.00</fase3_p_reactiva_cap>

<fase3_frecuencia>50.08</fase3_frecuencia>

<fase3_factor_potencia>0.102</fase3_factor_potencia>

<fase3_energia_activa>135</fase3_energia_activa>

<fase3_energia_reactiva_ind>93</fase3_energia_reactiva_ind>

<fase3_energia_reactiva_cap>10</fase3_energia_reactiva_cap>

<fase3_angle>0.00</fase3_angle>

<fase3_thd_total>0.00</fase3_thd_total>

<fase3_thd_fund>0.00</fase3_thd_fund>

<fase3_thd_ar3>0.00</fase3_thd_ar3>

<fase3_thd_ar5>0.00</fase3_thd_ar5>

<fase3_thd_ar7>0.00</fase3_thd_ar7>

<fase3_thd_ar9>0.00</fase3_thd_ar9>

<fase3_thd_tot_V>2.00</fase3_thd_tot_V>

<fase3_thd_fun_V>229.80</fase3_thd_fun_V>

<fase3_thd_ar3_V>0.00</fase3_thd_ar3_V>

<fase3_thd_ar5_V>4.70</fase3_thd_ar5_V>

<fase3_thd_ar7_V>0.00</fase3_thd_ar7_V>

<fase3_thd_ar9_V>0.00</fase3_thd_ar9_V>

<fase4_vrms>231.15</fase4_vrms>

<fase4_irms>4.17</fase4_irms>

<fase4_p_aparent>964.17</fase4_p_aparent>

<fase4_p_activa>873.09</fase4_p_activa>

<fase4_p_reactiva_ind>0.00</fase4_p_reactiva_ind>

<fase4_p_reactiva_cap>236.71</fase4_p_reactiva_cap>

<fase4_frecuencia>50.08</fase4_frecuencia>

<fase4_factor_potencia>-0.906</fase4_factor_potencia>

<fase4_energia_activa>64250</fase4_energia_activa>

<fase4_energia_reactiva_ind>5403</fase4_energia_reactiva_ind>

<fase4_energia_reactiva_cap>26900</fase4_energia_reactiva_cap>

<scale>100</scale>

<coilStatus>-</coilStatus>

<ground>0.00</ground>

</response>

When i add

- platform: wibeee
  name: "Wibeee"
  host: 192.168.1.34
  scan_interval: 5

to the configuration.yaml it says:

end of the stream or a document separator is expected at line 64, column 1:
    - platform: wibeee
    ^
#38

I am on a Raspberry with Hassio and getting the following message “[homeassistant.setup] Setup failed for wibeee: No setup function defined.”

#39

Finally i got it working, thanks for the info @juanjosanz