New integration: Energy monitoring device Circutor Wibeee

You may be already found it …

Just check in your home assistant web page where all the entities are listed: https://home-assitant-ip:8123/dev-state

If everything has worked as expected, you will see there sensors entities starting with sensor.wibeee (e.g., sensor.wibeee_phase1_active_energy)

1 Like

hey @juanjoSanz,

I was updating the component and found something weird there …

please check the code on https://github.com/juanjoSanz/hass_wibeee/blob/cded452dd419d5ac9d53669ab671dd8a00fe2728/custom_components/wibeee/sensor.py

any chance the custom component for pi-hole have mixed up with this one?

My mistake, I was trying to get references of new sensor format, as current implementation is not longer compatible with HASS at v0.95

I have moved all those changes into a new branch to do not affect old working version (hass <= 0.94)

BTW: right now I have not the time to adapt the sensor to hass 0.95, stay on version 0.94 if this component is important for you.

Hi Juanjo, I must say you that 0.95.4 works fine with Oscar’s code, january 2th, and with some tune, for example, move directory wibeee to /components , not place directory under custom_components. With your code was imposible. I’m developer ( but without free time ) and I would like study both codes. I want make a how to because it’s too hard begin from nothing.
Mirubee app is cool but they dont have notifications, and I want have alarms triggered by high use day for example. Also it’s great have data stored in sqlite, i’m looking for method to make graphic reports, home assistant component is very poor.
Regards.

Hello, I have my wibeee (three phase) configuration in hassio and also crashed.
Can anyone help?

I would need some time for adapting it to new version. (Some weeks as now I am kind of busy) Meanwhile, please rollback your home assistant to version 0.94 if you want it to work.

hey @juanjoSanz,

I have a monophasic wibeee ( Mirubee Moti-1) and to this day it works until version 0.96.0beta1 without problem.

Hi, can you share your config?

Can someone help? Now I have version 0.96.2.

hey guys,

I’m really looking forward to have this component back on track :slight_smile: but I understand we all are busy with other things so no intent to put pressure here.

In the meantime, as I really need this data because I’m trying to reduce costs at home, I did a small implementation with the Scrape sensor that I’m using to pull the data from the Wibee device. Here’s the code should anyone is interested on it:

This can be improved but it’s an starting point if you need it.

secrets.yaml

wibee.xml: "http://<IP of the Wibee Device>/en/status.xml"

configuration.yaml

sensor:
- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_vrms
  select: "fase1_vrms"
  unit_of_measurement: "V"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_irms
  select: "fase1_irms"
  unit_of_measurement: "A"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_p_aparent
  select: "fase1_p_aparent"
  unit_of_measurement: "VA"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_p_activa
  select: "fase1_p_activa"
  unit_of_measurement: "W"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_p_reactiva_ind
  select: "fase1_p_reactiva_ind"
  unit_of_measurement: "VArL"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_ffase1_p_reactiva_cap
  select: "fase1_p_reactiva_cap"
  unit_of_measurement: "VArc"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_frecuencia
  select: "fase1_frecuencia"
  unit_of_measurement: "Hz"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_factor_potencia
  select: "fase1_factor_potencia"
  unit_of_measurement: " "

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_energia_activa
  select: "fase1_energia_activa"
  unit_of_measurement: "Wh"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_energia_reactiva_ind
  select: "fase1_energia_reactiva_ind"
  unit_of_measurement: "VArLh"

- platform: scrape
  resource: !secret wibee.xml
  name: wibee_fase1_energia_reactiva_cap
  select: "fase1_energia_reactiva_cap"
  unit_of_measurement: "VArCh"
1 Like

It seems that the integration of Wibeee in HA has died.
I am thinking of selling my Wibeee and buying another energy meter.

1 Like

It is working for me in version 0.98.3

Mirubee devices are called wibeee.

An interesting option

Hi!,
what did you to make it work?, i’m using the “patch” that the good @davedan did, but i would like to have it more integrated and getting fastest responses

Can you please share your configuration?

I have done some modifications and it seems to be now working on version 0.99. Updated component is in github.

Note: I removed the “name” tag in configuration.yaml, and hardcoded it as “wibeee”, for now it is a workaround for avoiding issues with that tag.

I had this working on v0.94 but I updated to 0.99 and stopped working. I uploaded the component from github but it fails. The Verifier in Hassio shows:

Invalid config for [sensor.wibeee]: [host] is an invalid option for [sensor.wibeee]. Check: sensor.wibeee->host. (See ?, line ?).

I placed the files in \custom_components\wibeee\sensor.py, as it is in Git hub
It is something wrong ? How did you make it work?

My mistake! Latest code was not successfully updated on github repo. It is now fixed, please give it a try.

1 Like

Something went wrong… It is still showing the error

Invalid config for [sensor.wibeee]: [host] is an invalid option for [sensor.wibeee]. Check: sensor.wibeee->host. (See ?, line ?). Please check the docs at https://home-assistant.io/components/sensor.wibeee/

I tried using the ip address in Host parameter as string with quotation marks and without them. Any ideas?

1 Like

The component is working for me in the version, 0.100b0, remove the name, scan_interval and phases option, and it seems to work correctly.

sensor:
# Wibeee energia
  - platform: wibeee
#    name: Wibeee (removed)
    host: 192.168.xx.xx
#    scan_interval: 5 (removed)
#    phases: 1 (removed)