New Neato Integration Installation Guide (OAuth2 for HA version 2021.1)

Tags: #<Tag:0x00007f3281d89c70>

As I have had to update my Neato D7 Integration to work with the new OAuth2 Neato Integration I thought I would share a video on one method of doing it.

The previous Neato Integration is broken in the latest HA Update (Release 2021.1)

Hope it helps some other Neato HA users.

3 Likes

thanks!

if im using NabuCasa, would would the URL be? i tried this but got errors:

https://o4j59itxxxxxxxxxxxxxxxxr.ui.nabu.casa/auth/external/callback

Hey Jaime.

What error are you getting?

Your URL looks correct. If you are authorizing the integration make sure you are logged in via your nabu casa link. You should then be able to authorize. Once authorized you can use HA locally again and the Neato integration will work. Give me a shout if your still stuck :slight_smile:

1 Like

ah ha! thank you
i was connecting via my local IP, once i changed that to be the external URL, it worked great!

cheers :slight_smile:

2 Likes

Dear Mark,
I ran in the same trap. But my problem is, that I only use HA locallly without ssl and if I got it right, I have to enable SSL first.
If I enable SSL all of my addons (Tasmoadmin, Grafana, ESPHOME, …) are no longer accessible. Do you have an idea how to easily resolve that?
Sascha

try a reverse proxy like this user was able to do: Mobile App can't connect after enabling SSL

Glad I could help you :slight_smile:

What’s your Home Assistant setup?

HA Docker container on Synology NAS without any additional enhancements like supervisor… I have put frigate, esphome, tasmoadmin, grafana without ssl into the iframe on the left side. In addition to that I use the debug view of frigate…
All products are implemented using docker containers. Some are located on RASPI4 some on NAS. I don’t use any kind of proxy currently. Everything is locally.

So you have to expose your home assistant install to internet to get it to work? sorry but not going to happen.
So i will either have to stick to old version of home assistant or stop using the integration completely.

it doesnt have to be exposed externally…just needs HTTPS per Neato.

Please note that your instance must be accessible via HTTPS. However, your instance does not need to be exposed to the Internet.

And following from neatos site itself

  • Redirect URI : since users will be authenticated with OAuth, you need to provide a return URL to capture the auth token in your application and use it to authorize calls. This MUST be a secure URL (https://).
1 Like

I’ve been running into the same issue. Setting up HA with a selfsigned cert the callback url via homeassistant.lan seems to work (through https obviously), but still doesn’t work with Neato :frowning:

Hey :slight_smile:
Are you getting a specific error or anything?

hey :slight_smile:
Nothing really shows up, though I may not be looking at the right logs.
There’s nothing in the generic Home Assistant log. Do I need to enable the module specifically or something?

Does it accept the authorization when you re add the Neato integration?
Or is the Neato Developer site not accepting your URL?

The redirect uri included is not valid.

This was happening for me when I was adding the integration while browsing from a different url (my internal address) than I had in my callback url (my external address). Not sure if that helps.

2 Likes

Good idea, sadly didn’t help :confused:

I also don’t have any external IP.
It’s all internal, but I was browsing on 10.7.0.x and had homeassistan.lan in the neato config.

make sure the URL you are using to access HA matches the redirect URI that you used

1 Like

yeah did that, but no help for me :slight_smile: