Home Assistant Community

New platform for My Home bTicino

#42

I was thinking this: it’s called “BTicino Living Now with NETATMO”.
Maybe that means that the Netatmo HA component can control those devices. I’m unable to understand if this new BTicino series use Netatmo software, and that might mean that it is compatible with HA, or use a personal software DEVELOPED with Netatmo, but not compatible.
Does anyone has a BTicino Living Now system installed and want to try integration in HA with Netatmo component?

0 Likes

#43

Hi, I have Bticino living Now roller shutter controller, it should be works with Homekit and Google Assistant, but now doesn’t work. Is there a plugin for HA to integrate some roller shutter controllers in HA and consequently in HomeKit?
Thank you

0 Likes

#44

first of all, Happy new year.

@clau67, I have a problem, it seams your componente OpenWebNet trys to convert the password to an int, but unfortunally that is not an option for me:
image

My_home demands me to have at least one letter

And there for I have this error:

  File "/config/deps/lib/python3.6/site-packages/OpenWebNet.py", line 188, in cmd_session
    psw_open = '*#' + str(self.calculated_psw(answer)) + '##'
  File "/config/deps/lib/python3.6/site-packages/OpenWebNet.py", line 79, in calculated_psw
    self._psw = int(self._psw)
ValueError: invalid literal for int() with base 10: '111111111Ab'
0 Likes

#45

Hi all,
is there any plan to add also shutter support to this my_home bTicino home assistant plugin?

thanks
bye
Marco

0 Likes

#47

it works, but not so well … many errors and turn the lights on/off once in 10 !
Here my log:

normal_request 1 24 1
normal_request 1 24 1
normal_request 1 24 1
stato request 1 24 0
normal_request 1 24 1
normal_request 1 24 1
normal_request 1 24 1
normal_request 1 24 1
2019-01-28 21:58:43 ERROR (MainThread) [homeassistant.helpers.entity] Update for light.test fails
Traceback (most recent call last):
  File "C:\Program Files\Python\Python37\lib\site-packages\homeassistant\helpers\entity.py", line 221, in async_update_ha_state
    await self.async_device_update()
  File "C:\Program Files\Python\Python37\lib\site-packages\homeassistant\helpers\entity.py", line 349, in async_device_update
    await self.hass.async_add_executor_job(self.update)
  File "C:\Program Files\Python\Python37\lib\concurrent\futures\thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "C:\Users\Giancarlo\AppData\Roaming\.homeassistant\custom_components\light\my_home.py", line 99, in update
    self._gate.ask_stato_luce(self._indirizzo)
  File "C:\Program Files\Python\Python37\lib\site-packages\OpenWebNet.py", line 426, in ask_stato_luce
    self.stato_request('1',where,'0')
  File "C:\Program Files\Python\Python37\lib\site-packages\OpenWebNet.py", line 344, in stato_request
    self.stato_request(who,where)
TypeError: stato_request() missing 1 required positional argument: 'what'
2019-01-28 21:58:43 ERROR (SyncWorker_10) [OpenWebNet] Non posso inizializzare la comunicazione con il gateway
NoneType: None
2019-01-28 21:58:43 ERROR (SyncWorker_0) [OpenWebNet] Password errata
NoneType: None
2019-01-28 21:58:43 ERROR (SyncWorker_10) [OpenWebNet] Il gateway rifiuta la sessione comandi
    NoneType: None
    stato request 1 24 0
    normal_request 1 24 1
    normal_request 1 24 1
    2019-01-28 21:58:53 WARNING (MainThread) [homeassistant.helpers.entity] Update of light.test is taking over 10 seconds
    normal_request 1 24 1
light_risposta {'24': '1'}
stato request 1 24 0
2019-01-28 22:01:15 ERROR (MainThread) [homeassistant.helpers.entity] Update for light.test fails
Traceback (most recent call last):
  File "C:\Program Files\Python\Python37\lib\site-packages\homeassistant\helpers\entity.py", line 221, in async_update_ha_state
    await self.async_device_update()
  File "C:\Program Files\Python\Python37\lib\site-packages\homeassistant\helpers\entity.py", line 349, in async_device_update
    await self.hass.async_add_executor_job(self.update)
  File "C:\Program Files\Python\Python37\lib\concurrent\futures\thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "C:\Users\Giancarlo\AppData\Roaming\.homeassistant\custom_components\light\my_home.py", line 99, in update
    self._gate.ask_stato_luce(self._indirizzo)
  File "C:\Program Files\Python\Python37\lib\site-packages\OpenWebNet.py", line 426, in ask_stato_luce
    self.stato_request('1',where,'0')
  File "C:\Program Files\Python\Python37\lib\site-packages\OpenWebNet.py", line 363, in stato_request
    self.extractor(check_message)
  File "C:\Program Files\Python\Python37\lib\site-packages\OpenWebNet.py", line 205, in extractor
    if answer[1] == '1':
IndexError: string index out of range
0 Likes

#48

I am facing the same issue with this @clau67 please help how to get rid of it

0 Likes

#49

Well, I invite everyone to try this addon.
[BTicino/Legrand] Sdomotica Gateway Hass.io addon

0 Likes

#50

@clau67 thx for the component! Can toggle my lights with Home Assistant now, awesome :slight_smile:

0 Likes

#51

Hi @clau67, I have some problem setting up your component.

No matter what address (“indirizzo”) I put in the config.yaml, I always get the following error:

 stato request 1 5 0
2019-04-06 06:05:25 ERROR (MainThread) [homeassistant.helpers.entity] Update for light.tavolo fails
Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/entity.py", line 221, in async_update_ha_state
    await self.async_device_update()
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/entity.py", line 349, in async_device_update
    await self.hass.async_add_executor_job(self.update)
  File "/usr/lib/python3.5/asyncio/futures.py", line 380, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/tasks.py", line 304, in _wakeup
    future.result()
  File "/usr/lib/python3.5/asyncio/futures.py", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/home/homeassistant/.homeassistant/custom_components/light/my_home.py", line 100, in update
    self._state=self._gate.answ_stato_luce(self._indirizzo)
  File "/srv/homeassistant/lib/python3.5/site-packages/OpenWebNet.py", line 448, in answ_stato_luce
    stato = self.stato_answer('1',where,'1')
  File "/srv/homeassistant/lib/python3.5/site-packages/OpenWebNet.py", line 407, in stato_answer
    return self.light_risposta[where]
KeyError: '5'

Note that the gateway (MH201) correctly works with JS homebridge plugin.

Any idea?

This is my config.yaml:

#MyHome bTicino
my_home:
  host: 192.168.0.136
  port: '20000'
  password: '12345'

light:
  - platform: my_home
    scan_interval: 5
    devices:
       - name: 'Tavolo'
         indirizzo: 5

Thanks

0 Likes

#52

Hi teejay-87,
I have the same errors in my log, but the system works without any problems, so if it doesn’t work there must be some other problem.
Are you sure about the address ?
In my installation all the addresses have two digits 11, 12, 13, 21, 22, 51, 61 etc
Another thing remember to change the custom_components/light/my_home.py in custom_components/my_home/light.py as reported in the update information of the latest version of HA

0 Likes

#53

Honestly I don’t understand the syntax of your library addresses.

This is my configuration for HomeBridge JS plugin, as you can see the address syntax is quite different and I’m experiencing difficulties in translating them for your library:

Also what do you mean by updating the .py?
Why don’t you release it on GitHub?
Anyway I’m currently not on the latest version of HomeAssistant (0.84 I think).

0 Likes

#54

try ‘scala1P’ indirizzo 19
‘Ext bagno pt’ indirizzo 110
‘Ext giardino’ indirizzo 111 etc…

check in this site

0 Likes

#55

Hi clau… sorry for the delay.

I managed to switch on a light, Scala1P, using address 19.

But the problem is that Hass cannot retrieve the state correctly, as it states in the error log:

File “/home/homeassistant/.homeassistant/custom_components/light/my_home.py”, line 100, in update
self._state=self._gate.answ_stato_luce(self._indirizzo)
File “/srv/homeassistant/lib/python3.5/site-packages/OpenWebNet.py”, line 448, in answ_stato_luce
stato = self.stato_answer(‘1’,where,‘1’)
File “/srv/homeassistant/lib/python3.5/site-packages/OpenWebNet.py”, line 407, in stato_answer
return self.light_risposta[where]
KeyError: ‘19’

So the light actually switched on, but than the toggle in Hass interface go back to OFF in some seconds, and I cannot switch off the light.

0 Likes