New Router Now Connection Refused

Hi all,

I just moved to a new TP-Link Deco router from Google Wifi. Sadly, I went too quick and wiped the old router and just plugged in the new one. Everything worked great, except home assistant. I suspect it’s due to the new IP? That’s all I can think! I can get to the observer via port 4357, but otherwise it pings, but refuses connection.

I’m on a new ISP (doesn’t seem relevant, but sharing in case). It’s running on a Raspberry Pi 4b. I also can’t get an HDMI signal from it for some reason.

I have backup files, I have the disk (but I can’t read it!), I can’t find the original Ip anywhere, and I’m not 100% sure it’s this that is the issue.

Please say there’s a simple fix…help! Thanks in advance

You didn’t say what device you have HA on but you may want to see if you can connect an external monitor to the device to see if it reveals any information from the device.

1 Like

Hey thanks, it’s on a Raspberry Pi 4b, I tried the HDMI, connected, reboot, and can’t get a signal for some reason

– update! I just got into the CLI with a different monitor

1 Like

I do not use an RPI for HA but will try to assist with some troubleshooting anyway. The RPI 4 has 2 hdmi ports, be sure you have tried them both. What is your boot media? Make sure this media is working, if it is an sd card, it could be corrupted, if it is an external drive make sure you are using external power for this device and not relying on the RPI power for this. Also RPI units can be finicky with power supplies so if you have another one it might be worth the try. Are you getting any lights on the RPI unit once it is powered on?

1 Like

Thanks, I just got the HDMI working. The boot media is ok just now (it’s on a temporary sd card, I know that’s not best), but it’s still running, all my automations are working great, and notifications etc.

I can see the CLI now though and it’s showing the right IP

So are you able to connect to the device at the ip you see?

No, if I specify port 8123 I get no data back, if I don’t specify a port I get refused, but I can get in on the observer port oddly

Is it possible that the device was originally configured with a static IP address that is not a part of the range that the new router is permitting? Example orginal: and the new: Are you able to ping the device from another computer on the network? ping -4 replace the x’s with the ip address from the cli you have.

  1. You see in the cli which ip HA now has, got from your Router, if you not have configured “static” in HA
  2. Do you have any idea whether your new Router has/using the same “subnet” As you had before ?, i.e 10.X…X.X or 192.168.X.X
  3. EVERY Device you have configured with an IP. In HA, has to be either wiped/reinstall, as im sure it’s cumbersome to even try to change IP on them all in HA
  4. Which is/could be another reason why HA is not “feeling well”, to much in the logfiles at early startup

So before You go any further, check your Router, yes everything is working !, i know, Because all the dumb-smart-IP device, uses DHCP, and they don’t care which IP nor which Subnet, as long as the get a responce upon their IP-Request

And in HA’s cli type

ha net info

Ohhh, and when you are done, and got everything up and running, then export your Router-Settings ( and ofcause store it a place you remember )


New router IP range matches the first three segments. I at least remembered this, just not the final section. I’ve assigned a static IP on the router, I’ve tried a few different ones, but it currently matches the IP showing in CLI.

I ran ha net info, but don’t know what I’m looking for here.

I do wonder about the IP range thing, as the new router has a more limited range set just now, so maybe if I expand that it’ll help?

Tried pinging from another device, responding fine

1 Like

the net info, is just to check everything looks ok

If the 3 first xxx segments is ok, it should be ok there also

Did you have “reserved IP” in the DHCP scope, on your other IP devices ?
If not, they most likely have a “random” , within the last segment, … Which most likely dont match the IP settings in your HA integrations for the various devices … So

If you are familiar with the CLI ( or not, type --help ) , you can also find your configuration.yaml

type login (enter )
cd /mnt/data/supervisor/homeassistant

type ls -la

type more .home-assistant.log

scroll read, see if it make any sense

If you can , you can create a “fault” in your configuration.yaml , i.e add wrong indent / whitespase , early in the file , after the “default” is loaded … then hopefully HA will abandon the config-file and start in safe-mode

1 Like

That’s a really nice idea, and I got right down to the log, but when I tried to open it CLI seems to have stopped working. Going to need to pull the plug and go again. Will try the config option too, that’s smart

IF you mean the DHCP Scope, check the old Routers default-setting ( if you had it on default, that is )

Yeah I’ve extended the DHCP range now and it’s not helping :frowning: I know the range it’s in

You could also try to unplug HA’s TP-cable, it should be able to start without connection , atleast then it dont get confused by it’s “new” environment
But make sure you remove the ip it has, if the settings in net-info is not auto

Just broke config.yaml and it still refused connection sadly

If I remove the ethernet cable, I don’t have any way to access the GUI. The WiFi is annoyingly disabled

yeah most likely the logfile is already huge, could take “time” to load, reboot clean it thou

I just noticed under ipv4 ready: false. is this a concern?

depends upon which nic/interface, if it’s the one you use, yes, if it’s wifi or an additional , no

It’s the one I use. Is this a clue as to the issue? It has an IP, why wouldn’t it be “ready”?