New Tuya integration (2021.11) unable to log in

Hi - I see there are a lot of posts about the new Tuya integration, but I can’t find anyone who has experienced this problem yet. A few posts are similar though (with region issues) so sorry if I’ve missed a solution somewhere

I followed the instructions at and managed to register with the IoT platform, find my correct data centre (Central Europe), link my Tuya Smart app, see my devices, and extract an access ID/key.

When I try to set up the Tuya integration in Home Assistant, using my Tuya Smart app login, the IoT access ID and key, and UK as country, it gives me an immediate “login error 1106 permission deny”

I looked through the app and noticed that the Region shows as “Isle of Man/United Kingdom”. Under Country in the integration setup, there is both UK and Isle of Man as separate entries. If I select Isle of Man, it sits there thinking for a while, then gives me “login error 2406 skill ID invalid”

Under the integration setup instructions, it gives two points to troubleshoot this error, both of which I think I’m already doing correctly:

  • Make sure you use the Tuya Smart or SmartLife app account to log in. Also, choose the right data center endpoint related to your country region. For more details, please check Country Regions and Data Center.
  • Your cloud project on the Tuya IoT Development Platform should be created after May 25, 2021. Otherwise, you need to create a new project.

What else can I do to try and get this working?

I’m having the same problem.
Was working fine until I updated this morning. Now can’t login. :frowning:

Glad to see I am not the only one

I just updated to 2021.11 and saw that the integration failed. So I decided to delete it and reinstall it and now I get that same error as you

login error 1106 permission deny

Exactly same issue on my end. Permission deny since last upgrade. i even recreate a brand new Cloud project via Tuya IOT platform, but still not working. Same “permission deny” issue.

Yup, same as that.

The Isle of Man option returns the “login error 2406 skill ID invalid” as mentioned by OP. Not had to use that before though, so no idea what’s happening.
Clearly above my pay grade! :stuck_out_tongue:

Same here… I was excited yesterday (my door sensor were finally able to be recognized), woke up this morning, its all broke. Hopefully a solution will be found soon.

same here,

Same story here as well…
[updated] Restored the Core-2021.10.7 and had same issue ( 1106 error)… Will check with other backups as well…

Same here and no backup is working.

Tuya login error response: {‘code’: 1106, ‘msg’: ‘permission deny’, ‘success’: False, ‘t’: 1636032697717}

same here.

Same issue here. My country is Belgium. I was still using the Tuya V2 beta which was working fine until this morning. Decided to upgrade to 2021.11 and give the official Tuya integration a go. Got stuck at the above error also. I am sure my credentials are correct (and I am not mixing the smartlife app with the IOT developer account credentials) as well as the region setting in the Smartlife app and in the iot developer account. Data center is set to Central EU (which is the one to be used for Belgium according to Mappings Between OEM App Accounts and Data Centers-Documentation-Tuya Developer )

I guess I’ll wait and monitor this thread to see how the situation evolves.

Same promblem here. I checked the integration setup in


and all the parameters were correctly defined. What’s really odd is the key reported in the logs does not match the one defined in the setup file. I would think this is the root cause of the issue…

Had to restart home assistant earlier and now getting the same issue.

Removed the intergration and tried re-adding but getting “Login error (1106): permission deny”

1 Like

If we’re all having the same problem, it’s probably a server side issue.

1 Like

Since I got the 1106 error also, I restored my backup (core 2021.10.6) where I was running the Tuya V2 beta which was working fine this morning. That now also gives this error. Not sure what is going on now. Maybe the issue is with Tuya?

The same problem, I have updated to 20211.11 and 1106 error. Returm to The backup in core_2021.10.7 and 1106 error.

Same problem too. Cant login although all my credientials are correct. I will try the backup

No use to revert a backup. The error is on Tuya’s side.

1 Like

Yes, I think this.