No bootable medium found! System halted

Trying to create a VirtualBox VM from the HassOS 1.8 VMDK. Whether I add the VMDK as a disk or convert it to VDI and then add, I always get the error “No bootable medium found! System halted.”.
How can I get past this and run a VirtualBox HassOS vm?

I just tried it and get the same result.

Aha, it pays to read the instructions!

In particular “UEFI boot” - in virtualbox Settings|System|Motherboard Tab, make sure “select EFI” is ticked.


Another hint, set your network device in virtualbox to Intel PRO/1000 MT Desktop. Mine didn’t get on the network until I did that.

1 Like

Thanks - now I get “Shell” but Hassio never starts. Any thoughts?

There is a login prompt. username is root, no password.

Then you are in the hassio environment, prompt is


From there you can type


for a shell.

I think mine did take a while for home assistant to start the first time.

I recreated the vm (linux ubuntu 64 bit) and now its working.

Actually, I’m only getting to the HassOS Boot menu and can’t figure out how to get passed it

Deleted the CDrom drive and chose option 2 in the HassOS boot menu - now I got to the hassio prompt

1 Like


So does the server restart function from the configuration page work for you guys? I have HassOS up and running but when I try to do a restart with that feature, it tells me the service failed.

So even though it says it fails, it appears that it is indeed restarting.

That is known and expected behaviour.


Have similar issues, but cant find solution.
Virtualbox is Version 6.0.0 r127566 (Qt5.6.2)
Intel NUC running Windows 10 with latest updates.

Tried both .VDI and .VMDK files from

Without EFI option it says No bootable medium.
When i click EFI it says nothing, blank screen with machine running.
Cant get to any boot menu screen or see login prompt.
Full blank… no change even after half an hour.
Disk, display and USB icons on Virtualbox somethimes flash red/green but that is all.

I juste realised, there was great network activity, download, and .VDI image grew to about 2GB.
But still cant get any info on screen…

Is HA running? Go to ipaddrr:8123

Have HA on Rpi and it Is logging as hell when loading, expect same From VM ? Or i should not?

I don’t know what you are asking, but can you do as I suggested?

Just managed to get the screen working. In VirtualBox use the VBoxVGA graphics controller and i enable 3D acceleration. For the rest use the settings metioned by nickrout, .

Now it stops on start eudev-3.2.5… Just letting it rest for a moment.