No color picker with tuya bulbs

You can also do this in the configuration.yaml directly.

homeassistant:
 customize:
    light.NumbersAndLettersHere: #entity name
      supported_features: 63
9 Likes

Thank you so much!

do you have a step by step guide for me? I do not understand where I have to enter what.

You open the configuration.yaml file and first search for “customize:”.
If you can find that tag then add the entity name below and the supported_feature.

If you don’t find the customize tag then you have not made any customizations before so just add all of the text in the code block to your configuration.yaml just make sure to edit the light.NumbersAndLettersHere to the entity name of the light bulb.

1 Like

Thank you. For my lightbulbs it works. Unfortunately not for my LED stripe. The RGB controller is displayed, but you cannot select a color. Can this have anything to do with 64 features?

Don’t know.
If it has more features then I assume you should add 128, meaning 63+128 = 191 as the value.
But that is a pure guess.

Same issue, left a reply here also: https://github.com/home-assistant/core/issues/30362

Is this fix still valid for HA 0.110 / 0.111?

Did you try the methods posted above here?


or in configuration

@Hellis81 That unfortunately didn’t work for me. After updating the supported features to something that includes SUPPORT_COLOR, when I actually go to change the color I get the following error on the Frontend:

Failed to call service light/turn_on. int() argument must be a string, a bytes-like object or a number, not ‘NoneType’

Can’t help you with that. Sorry

Thank you! The number 191 worked for me. Unfortunately I could not flash Tasmota on this kind of lights: Globe Recessed lights (RGB), I tried Tuya convert, as usual, but it did not work this time. So for now these are the only Tuya lights that I have, I wish I could flash them!

1 Like

Is there a way to get the icons to show the current color? The “63” fix worked for me, but just need to fix the icons, like my “LED STRIP”

image

1 Like

Works a treat thanks - had to use 191 on my 12 new tuya bulbs that cant be tasmtised… yet

Unfortunately my RGB SmartLife bulb gets added to HA as a switch. Therefore I can’t just update the supported features number and right now, all I can do is turn it on or off. Does anyone know about this problem or has an idea how to solve it?

191 worked perfectly!! Thanks :smiley:

I have the same problem as you, I bought some Teckin SB50 and they apprear as switches in HA.

I only have control for on/off

1 Like

How can I update the tuya integration. I have tuya light working but cannot adjust color temparature. I read a lot about upgrade the tuya integration but how do I do a upgrade. I use a raspberry pi.

I have a Tuya based LED Strip lights which worked using offical Tuya intergration for only ON/OFF but not for color change.

I installed https://github.com/ollo69/ha_tuya_custom in HACS and now ON/OF, brightness and color change works except color temperature which I’m okay with it for now.

Yes, it seems the 63 fix worked, but icons don’t change with the light color. It seems like about 6 months ago it all worked color picker and icon changing with the color, but now none of this works and the fix only takes care of the color wheel. It would be nice to get all of it working again!

This worked for me as well