No color picker with tuya bulbs

Hello, same problem here. With upcoming Tuya - IFTTT split it can be expected that many people will migrate from IFTTT to Home-Assistant to control their Tuya devices. They will be disappointed to se it does not have enough functionality they had before.

Had this problem myself and looked through all the posts on this subject.

In the end I found a really straight forward solution (at least it worked for me)

Most of my bulbs are RGBWW so I did the following;

  1. Go to configuration > customisations
  2. Find the light you want to amend
  3. Check the Supported_features setting (it’s probably 2)
  4. For my bulbs to support all features I updated to 63

To figure this number out, look at the features list below and add up the numbers for the features you have,


It doesn’t resolve the issue of the current status being reported but at least I can control all the features.

Now if only I could get HomeKit to play nicely with this setting (it refuses to send the correct white value and just mixes RGB) I would be home free.


Saxo, this customization worked for me with SAUDIO LED RGB Color Changing Bulbs E26. Instead of overriding the Support_features setting (in my case it was 3) to 63 I used 191 to include SUPPORT_WHITE_VALUES. It added another adjustable control which doesn’t seem to do much for me, but it might for you. In my case, selecting the very center of the color wheel puts it in white mode and the temp adjustment then works. (note: Adjusting the warmth also puts it into the white mode.) Thank you so much for this. How did you find it?

1 Like

I found that some thing, 63 removed the extra slider but still allows me to control the white value.

It was just an observation that the supported features where being incorrectly identified. From there I started to investigate what values should be used.

Would be nice to get the status working too but does what I think what most of us need for now.

Glad it worked for you

@Saxo thank you for this quick fix!!! its working for me with my Teckin RGB lights!!

the only problem that I see is that I can’t select Red… because it goes to purple!!! but beside that it works!! thanks!

This worked for me!!!

Had to create a customize.yaml and add a

!include customize.yaml

in configuration.yaml

You can also do this in the configuration.yaml directly.

    light.NumbersAndLettersHere: #entity name
      supported_features: 63

Thank you so much!

do you have a step by step guide for me? I do not understand where I have to enter what.

You open the configuration.yaml file and first search for “customize:”.
If you can find that tag then add the entity name below and the supported_feature.

If you don’t find the customize tag then you have not made any customizations before so just add all of the text in the code block to your configuration.yaml just make sure to edit the light.NumbersAndLettersHere to the entity name of the light bulb.

1 Like

Thank you. For my lightbulbs it works. Unfortunately not for my LED stripe. The RGB controller is displayed, but you cannot select a color. Can this have anything to do with 64 features?

Don’t know.
If it has more features then I assume you should add 128, meaning 63+128 = 191 as the value.
But that is a pure guess.

Same issue, left a reply here also:

Is this fix still valid for HA 0.110 / 0.111?

Did you try the methods posted above here?

or in configuration

@Hellis81 That unfortunately didn’t work for me. After updating the supported features to something that includes SUPPORT_COLOR, when I actually go to change the color I get the following error on the Frontend:

Failed to call service light/turn_on. int() argument must be a string, a bytes-like object or a number, not ‘NoneType’

Can’t help you with that. Sorry

Thank you! The number 191 worked for me. Unfortunately I could not flash Tasmota on this kind of lights: Globe Recessed lights (RGB), I tried Tuya convert, as usual, but it did not work this time. So for now these are the only Tuya lights that I have, I wish I could flash them!

1 Like

Is there a way to get the icons to show the current color? The “63” fix worked for me, but just need to fix the icons, like my “LED STRIP”


1 Like

Works a treat thanks - had to use 191 on my 12 new tuya bulbs that cant be tasmtised… yet

Unfortunately my RGB SmartLife bulb gets added to HA as a switch. Therefore I can’t just update the supported features number and right now, all I can do is turn it on or off. Does anyone know about this problem or has an idea how to solve it?