No ethernet found after booting 64 bit Pi 3 B+ image

I’m getting this after inserting SD-card into my new raspberry pi 3 B+ (64 bit, 2018-2019 version) with a freshly baked image using Balena Etcher: hassos_rpi3-64-2.10.img.gz

The Pi is connected directly to my router with an ethernet cable. Anything else connected to the same ethernet cable works fine.

Inmediately after boot this shows up on my screen:

Net: No ethernet found.
starting USB…
USB0: scanning bus 0 for devices… 6 USB Device(s) found
Hit any key to stop autoboot: 0
HassOS>

Nothing happens after this.
there’s no flashing cursor after the prompt.

Tried:

  • Both 32 bit and 64 bit versions
  • Different SD-cards (older, newer ones, different speeds. ‘Standard’ one is a 64gb class 10 Kingston, and it’s working perfectly with any other image).
  • 2 Different power sources (seemed to work for someone else, but not for me… I’ve got the official 2,5A rasp. pi foundation power source)
  • Installing any other image on the same SD-card (like hassbian). Works fine. Ethernet works as well.

Last point proves (at least to me) that SD-card and the Pi itself are fine, and the ethernet link is fine as well.
I don’t have any special network settings. The ethernet cable is plugged directly into the router.
Can’t help but think there’s something wrong with the image itself.

Any ideas on what’s wrong?

1 Like

By the way, the Pi has the “RemotePi” - board installed. After turning on the device by pushing the power button, the message ‘No ethernet found’ (and the rest) appears inmediately. I would think that maybe the software is setting up the ethernet connection too fast? (Just an idea… )

Did you ever figure this out?
Having the same issue, 2 different RPI and 4 different microSD cards. Same results, did a network reset and unplugged every single device out of my network. Assigning IP at router, in the resin-sample file, or leaving it to the DHCP didn’t help. I can see the device connected to the network and I can ping it but Hassio refuses to work. Internet is working fine, I even tried a spare router with OOBE with internet working just to see if it was my router or network. This happens regardless if if my Ethernet cable is plugged in or not, and regardless if I set Hassio to use wifi instead.

It sucks spending so much effort on Hassio for over a year to end this way. My only route is now Homeassistant on my RPI but bye bye add-ons. Hassio on docker didn’t work as expected as well, it doesn’t like ARM installs and there’s a few issues open. I should have cloned that damn microSD card, they will fail sooner or later, and when you replace you might run into this issue and you might have to start from scratch.

UPDATE: downloaded an old hassio image OLD-resinos-hassio-1.2-raspberrypi3.img.bz2 from over a year ago… hallelujah! it is booting up… same microSD, same Raspberry Pi 3 B in which I have tried over 12 times to get it working. I have been up the whole night, it’s nearly 3 AM and I was already looking into OpenHab… I wanted to sleep, get to the office and to not come back to my home without Homeassistant in it…

Let’s see if it installs correctly, I will try to update it to the latest Hassio and then move on… if it works, then I am gonna buy another microSD in the same place, same model and clone them.

If you are doing this on a RPI, which only has 1Gb of RAM, 64 bit OS buys you nothing other than it being unsupported. I highly recommend sticking with 32 bit and eliminate that unsupport thingie from the mix.

Forgot to add, it is an RPI 3B and an RPI 3B+. Both of them same issue.

Sorry to say, I never figured it out. I installed it manually on top of raspbian lite. But that was hass.io I think… it’s been a while. :wink: I never got around to actually start using it.

Same issue here. But with an additional error: card did not respond to voltage select.
Fresh bought model 3 B +. With different SD: 32GB SDHC (Kingston) and 64GB SDXC (Samsung EVO Plus). With different power adapters: Original power source and other apple + miniUsb wire. I have tried 32 and 64bits images 3-2.12. I’ve tried a couple of sd to USB adapters. I have tried with or without ethernet wire and same results.
What’s going on? Is this happening to everybody?

But! Eureka! I had tried with different SDCARDS, USB adapters, power adapters including original,32vs64bits version. Different SDCard formatting tools… BUT,the rule was to read instructions with careful. I didn’t know rPi3b+ had sd card slot. Is under the board!! So when I readed instructions of suggested hardware, between things you need to have your Hass.io host, there was an sd card to usb stick.

SUGGESTED HARDWARE

We will need a few things to get started with installing Home Assistant. The latest Raspberry Pi model makes a good and affordable starting point for your home automation journey. Links below are linking to Amazon US. If you’re not in the US, you should be able to find these items in web stores in your country.

Ok ok, Sd Card reader to format it in your PC, not to connect it to rPI. Could you specify in other way to avoid confusion?