No firmware update sensors created

Hi!

I have a problem I have tried to troubleshoot a while but I can’t find what is causing it. Perhaps someone know?
My esphome update entities are not created. First they were all unavailable but after removing esphome completely and only importing my yaml files they are all gone.
When esphome 2023.2.0 was released I could update my esphome devices from HA but not anymore. The updates does not show up at all in HA even if I see updates available in esphome.
Does anyone know what could cause this?
I have “ota:” in my yaml files and I have tried to reinstall esphome. Can’t find anything related to this in my logs.
Running latest stable HA and esphome.

BR/Nicklas

Am I the only one with this problem?
My esphome sensors work well. I only miss the ability to install OTA updates in parallel from HA.

Please share your yaml and log file for one of the involved devices.

I had the same problem a while back, and found the solution in this forum post:
Esphome devices not showing up on dashboard but are working

I don’t have update sensors there, and I am not sure if I ever did.

Are you sure you aren’t thinking of the esphome addon interface?

Here is my yaml and log for one of my sensors.

esphome:
  name: rad
  platform: ESP8266
  board: d1_mini

wifi:
  ssid: "******"
  password: "***********"
  domain: ".***********"
  power_save_mode: none
  fast_connect: false

  # Enable fallback hotspot (captive portal) in case wifi connection fails
  ap:
    ssid: "rad Fallback Hotspot"
    password: "********"
    ap_timeout: 5min

captive_portal:


# Enable logging
logger:

# Enable Home Assistant API
api:

ota:
  password: **********

dallas:
  - pin: D4
    update_interval: 20s

sensor:
  - platform: dallas
    address: 0xF3041661D0D1FF28
    name: "Framledning"
  - platform: dallas
    address: 0x030316622997FF28
    name: "Retur"

# Wifi signal sensor
  - platform: wifi_signal
    name: "rad_wifi_signal"
    update_interval: 30s
    
# Extra sensor to keep track of plug uptime
  - platform: uptime
    name: rad_Uptime Sensor
    icon: mdi:clock-outline

button:
  - platform: restart
    name: "rad Restart"


INFO Reading configuration /config/esphome/rad.yaml...
INFO Starting log output from rad.********** using esphome API
INFO Successfully connected to rad.**********
[14:26:35][I][app:102]: ESPHome version 2023.5.3 compiled on May 23 2023, 10:58:54
[14:26:35][C][wifi:505]: WiFi:
[14:26:35][C][wifi:363]:   Local MAC: 5C:CF:7F:D7:1D:C9
[14:26:35][C][wifi:364]:   SSID: [redacted]
[14:26:35][C][wifi:365]:   IP Address: 10.10.10.150
[14:26:35][C][wifi:366]:   BSSID: [redacted]
[14:26:35][C][wifi:368]:   Hostname: 'rad'
[14:26:35][C][wifi:370]:   Signal strength: -52 dB ▂▄▆█
[14:26:35][C][wifi:374]:   Channel: 6
[14:26:35][C][wifi:375]:   Subnet: 255.255.255.0
[14:26:35][C][wifi:376]:   Gateway: 10.10.10.254
[14:26:35][C][wifi:377]:   DNS1: 10.10.10.254
[14:26:35][C][wifi:378]:   DNS2: 0.0.0.0
[14:26:35][C][logger:301]: Logger:
[14:26:35][C][logger:302]:   Level: DEBUG
[14:26:35][C][logger:303]:   Log Baud Rate: 115200
[14:26:35][C][logger:305]:   Hardware UART: UART0
[14:26:35][C][uptime.sensor:031]: Uptime Sensor 'rad_Uptime Sensor'
[14:26:35][C][uptime.sensor:031]:   Device Class: 'duration'
[14:26:35][C][uptime.sensor:031]:   State Class: 'total_increasing'
[14:26:35][C][uptime.sensor:031]:   Unit of Measurement: 's'
[14:26:35][C][uptime.sensor:031]:   Accuracy Decimals: 0
[14:26:35][C][uptime.sensor:031]:   Icon: 'mdi:clock-outline'
[14:26:35][C][dallas.sensor:075]: DallasComponent:
[14:26:35][C][dallas.sensor:076]:   Pin: GPIO2
[14:26:35][C][dallas.sensor:077]:   Update Interval: 20.0s
[14:26:35][D][dallas.sensor:082]:   Found sensors:
[14:26:35][D][dallas.sensor:084]:     0xf3041661d0d1ff28
[14:26:35][D][dallas.sensor:084]:     0x030316622997ff28
[14:26:35][C][dallas.sensor:089]:   Device 'Framledning'
[14:26:35][C][dallas.sensor:089]:     Device Class: 'temperature'
[14:26:35][C][dallas.sensor:089]:     State Class: 'measurement'
[14:26:35][C][dallas.sensor:089]:     Unit of Measurement: '°C'
[14:26:35][C][dallas.sensor:089]:     Accuracy Decimals: 1
[14:26:35][C][dallas.sensor:097]:     Address: 0xf3041661d0d1ff28
[14:26:35][C][dallas.sensor:098]:     Resolution: 12
[14:26:35][C][dallas.sensor:089]:   Device 'Retur'
[14:26:35][C][dallas.sensor:089]:     Device Class: 'temperature'
[14:26:35][C][dallas.sensor:089]:     State Class: 'measurement'
[14:26:35][C][dallas.sensor:089]:     Unit of Measurement: '°C'
[14:26:35][C][dallas.sensor:089]:     Accuracy Decimals: 1
[14:26:35][C][dallas.sensor:097]:     Address: 0x030316622997ff28
[14:26:35][C][dallas.sensor:098]:     Resolution: 12
[14:26:35][C][restart.button:017]: Restart Button 'rad Restart'
[14:26:35][C][captive_portal:088]: Captive Portal:
[14:26:35][C][mdns:108]: mDNS:
[14:26:35][C][mdns:109]:   Hostname: rad
[14:26:36][C][ota:093]: Over-The-Air Updates:
[14:26:36][C][ota:094]:   Address: rad.**********:8266
[14:26:36][C][ota:097]:   Using Password.
[14:26:36][C][api:138]: API Server:
[14:26:36][C][api:139]:   Address: rad.**********:6053
[14:26:36][C][api:143]:   Using noise encryption: NO
[14:26:36][C][wifi_signal.sensor:009]: WiFi Signal 'rad_wifi_signal'
[14:26:36][C][wifi_signal.sensor:009]:   Device Class: 'signal_strength'
[14:26:36][C][wifi_signal.sensor:009]:   State Class: 'measurement'
[14:26:36][C][wifi_signal.sensor:009]:   Unit of Measurement: 'dBm'
[14:26:36][C][wifi_signal.sensor:009]:   Accuracy Decimals: 0
[14:26:38][D][sensor:093]: 'rad_wifi_signal': Sending state -57.00000 dBm with 0 decimals of accuracy
[14:26:51][D][dallas.sensor:143]: 'Framledning': Got Temperature=23.3°C
[14:26:51][D][sensor:093]: 'Framledning': Sending state 23.31250 °C with 1 decimals of accuracy
[14:26:51][D][dallas.sensor:143]: 'Retur': Got Temperature=23.1°C
[14:26:51][D][sensor:093]: 'Retur': Sending state 23.06250 °C with 1 decimals of accuracy
[14:27:08][D][sensor:093]: 'rad_wifi_signal': Sending state -57.00000 dBm with 0 decimals of accuracy
[14:27:08][D][sensor:093]: 'rad_Uptime Sensor': Sending state 185202.01562 s with 0 decimals of accuracy
[14:27:11][D][dallas.sensor:143]: 'Framledning': Got Temperature=23.2°C
[14:27:11][D][sensor:093]: 'Framledning': Sending state 23.25000 °C with 1 decimals of accuracy

Seems like a totally different problem?

Here is a screenshot showing what I mean. It is from a friends HA.
There you see the “firmware” sensor that I don’t have.

Yes but you did say that you were referring to an update entity. Update - Home Assistant

Could you have a look at your api, I remember this was talked about and may not help but is an idea.

# Enable Home Assistant API
api:
  encryption:
    key: !secret encryption_key

EDIT: More information here

I did change from password to encryption key long time ago.

Strange is that the sensors now have been created and seems to work.
I added this to only one of my sensors:

text_sensor:
  # Expose ESPHome version as sensor.
  - platform: version
    name: ${device_name} ESPHome Version

After installing (compiling) the firmware update sensor was created for all esphome devices.
But, I also got a new esphome version that I installed at the same time so I’m not sure what solved the problem…