No internet after upgrading RPI4 bookworm HA supervised

Thanks for the reply.
That’s the guide I used and followed every step of the way :frowning:

Is IPv6 disabled with Settings → System → Network → IPv6: Disabled ? (should be set to “Disabled”)

thank you again. i believe we’re onto something here

so i discovered that with default settings (i.e. IPv6 enabled) i could actually ping (hadn’t noticed this before):

pi@rpi:~ $ ping
PING (2a00:1450:4001:82a::2004)) 56 data bytes
64 bytes from (2a00:1450:4001:82a::2004): icmp_seq=1 ttl=114 time=23.9 ms

once i disabled ipv6 in settings i get the same output as with any other server i tried:

pi@rpi:~ $ ping
PING ( 56(84) bytes of data.
From rpi.local ( icmp_seq=1 Destination Host Unreachable

so it seems it is a problem with IPv4 being blocked exclusively by the supervisor

also, when i change the DNS manually in IPv4 to or i get

pi@rpi:~ $ ping
ping: Temporary failure in name resolution

What is the CLI-command:

ha dns info


pi@rpi:~ $ ha dns info
fallback: true
llmnr: false
- dns://
mdns: false
servers: []
update_available: false
version: 2023.06.2
version_latest: 2023.06.2

( being the router. RPI connected via eth0 cable)

What is

ha resolution info


pi@rpi:~ $ ha resolution info
- enabled: true
  slug: supervisor_trust
- enabled: true
  slug: dns_server_ipv6
- enabled: true
  slug: addon_pwned
- enabled: true
  slug: docker_config
- enabled: true
  slug: multiple_data_disks
- enabled: true
  slug: dns_server
- enabled: true
  slug: core_security
- enabled: true
  slug: network_interface_ipv4
- enabled: true
  slug: free_space
- enabled: true
  slug: backups
- context: system
  reference: null
  type: no_current_backup
  uuid: 7e30591a715e477d9e6cd028e84dbe85
- auto: false
  context: system
  reference: null
  type: create_full_backup
  uuid: 58151e94d2b7467996338efc3e2b79d8
unhealthy: []
- os

btw tyvm for your support !!

You’re welcome. But the issue is not solved yet.

What makes me wonder:

- os

Go to Settings → System → Repairs → Hamburger Menu (3 vertical dots upper right) → System Information and look for “Supported” below “Home Assistant Supervisor”. Does it tell “Unsupported”?

In case you are seeing the status “Unsupported” and/or “Unhealthy” re-run the “supervised-installer”:

cd /usr/local/src
sudo rm -f homeassistant-supervised.deb
sudo wget
sudo dpkg -i homeassistant-supervised.deb

Note: You may be prompted to choose a machine type during the installation process. If so, choose raspberrypi4-64 if you do the upgrade on a RPI4 64bit.

Now reboot the host.

:warning: Note above’s:

sudo rm -f homeassistant-supervised.deb

I just added this command to the upgrade guide today!

In case you have an older version of “homeassistant-supervised.deb” laying around within /usr/local/src the newly downloaded version is saved as “homeassistant-supervised.deb1”, "homeassistant-supervised.deb2 " and so on.


sudo dpkg -i homeassistant-supervised.deb 

will always install the oldest ever downloaded version instead of the latest.

Thus doing:

sudo rm -f homeassistant-supervised.deb

before downloading the latest “homeassistant-supervised.deb” will make sure you are really installing the latest downloaded version.

okay just did. this was the output (i am doing all this on cli of host machine). rebooted after it all finished

pi@rpi:/usr/local/src $ sudo dpkg -i homeassistant-supervised.deb
(Reading database ... 167408 files and directories currently installed.)
Preparing to unpack homeassistant-supervised.deb ...
[warn] If you want more control over your own system, run
[warn] Home Assistant as a VM or run Home Assistant Core
[warn] via a Docker container.
[error] Raspbian GNU/Linux 12 (bookworm) is not supported!
dpkg: error processing archive homeassistant-supervised.deb (--install):
 new homeassistant-supervised package pre-installation script subprocess returned error exit status 1
[info] Restarting NetworkManager
[info] Restarting docker service
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=58 time=14.0 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 14.018/14.018/14.018/0.000 ms
Device "" does not exist.
[info] Install supervisor startup scripts
[info] Install AppArmor scripts
[info] Start Home Assistant Supervised
[info] Installing the 'ha' cli
[warn] Could not find /etc/default/grub or /boot/firmware/cmdline.txt failed to switch to cgroup v1
[info] Within a few minutes you will be able to reach Home Assistant at:
[info] http://homeassistant.local:8123 or using the IP address of your
[info] machine: http://:8123
Errors were encountered while processing:

but this apparently broke things. i cannot connect to home assistant at all anymore :frowning:
i get
when trying to access it from browser

when i stop hassio-supervisor.service i can connect to HA but now i get this in reparis:

You have still SSH access to the system, do you?

Just run from CLI:

sudo sed -i.bak 's/$/ systemd.unified_cgroup_hierarchy=0/' /boot/firmware/cmdline.txt

and reboot the host.

check the edited above post

and i believe i already appended the cmdline.txt for cgroup purposes on the previous install. will check though. thanks

pi@rpi:~ $ sudo sed -i.bak 's/$/ systemd.unified_cgroup_hierarchy=0/' /boot/firmware/cmdline.txt
sed: can't read /boot/firmware/cmdline.txt: No such file or directory

there is a /boot/cmdline.txt though? and the line “systemd.unified_cgroup_hierarchy=0” is already there

:warning: BTW: The Supervisor will refuse to install on any other OS than the “pure” Debian 12*. Raspian GNU/Linux 12 (bookworm) is based on Debian 12 but it is a Debian derivative only.

“A Debian derivative is a distribution that is based on the work done in Debian but has its own identity, goals and audience and is created by an entity that is independent from Debian. Derivatives modify Debian to achieve the goals they set for themselves.” (Source: Debian -- Debian derivatives).

*For more information about the latter please see HERE.

yeah i don’t know what’s going on there. i just followed your upgrade guide step by step there were no errors :confused:

There was a change back in December 2022 actively blocking any attempt at installation on an OS that is not supported, such as Raspberry Pi OS or Ubuntu.

It looks like you have upgraded Debian 11 to Debian 12 on RaspberryOS but not on pure Debian 12.

There is little you can do except backing up your Home Assistant, reformat your SDCard/SSD and start all over using Debian 12 (but no derivative!) and restore your HA backup afterwards. I know, this sucks … :sweat:

wait what?

my rpi is running a lot of other services/servers besides home asisstant :open_mouth:

so let me get this straight: i updated to raspbian-bullseye back in 2022 and everything went peachy with home assistant. but now raspbian-bookworm is no longer supported resulting in the situation we’re in. and there is no way to solve this but starting from scratch entirely ??

if this is the case i’d rather roll back to bullseye (flash backup .img) or stay on bookworm and just ditch the supervisor (although that will probably mean no updates?)

thanks again for your help but this really sucks

just a quick update.

i copied the /boot/cmdline.txt to /boot/firmware/cmdline.txt
after reboot home assistant is available again (with supervisor active). still says unsupported system.

now i couldn’t care less about that message tbh.

however there is still no internet connectivity over IPv4 as long as supervisor is running. IPv6 ping works just fine (if the interface is enabled).

is there really no way to force the supervisor to accept IPv4? this seems like a small thing /fix somehow… :confused: again , i don’t really care about the “unsupported system” message

Certainly. It is all over the place and also pointed out with the installation guides for Supervised on amd64, RPI and NUC. I.e.:

This is most probably because Supervisor can not be installed correctly.

1 Like

so after working through the respective stages of grief i decided to start from scratch with a rpi400 i had lying around…

and to my surprise it wasn’t as bad as i had feared and i learned a lot linux-wise on the way. even importing the HA backup from the other machine went more or less w/o problems.
anyway, now on debian12 native (i wasn’t even aware that the RPI-Debian is not that) and home assistant supervised seems to be working just fine altogether (not to jinx it…)

just came here to express my gratitude once again @Tamsy .while setting everything up again i came across a lot of your posts on this forum which were immensely helpful. so thanks again for providing such an excellent support.

1 Like

I’m sorry to reopen this thread, but I think I have a somehow related problem: I described it here: HA Supervised - No Network Interfaces
I think it is related because it appeared when I updated to debian 12.

Would anyone give a look and help me if possible? Thank you!!