No longer a stable connection via duckdns domain

Since October 1st my connection with my HA machine using my duckdns-URL is really unstable, most of the times I get an error message (see examples below). In the last months I have seen this before but only for 1 or 2 hours, now it has been bugging me for almost an entire day. If I use my local IP I can still reach my machine.

Scenario #1 - DuckDNS iOS app - NOT OK

  • action: on iPhone I open the iOS companion app using my DuckDNS URL (https://MYSUBDOMAIN.duckdns.org:8123) via my home network (wifi)
  • result: most of the times error message “a server with the specified hostname could not be found (NSURLErrorDomain - 1003)”

Scenario #2 DuckDNS Windows - NOT OK

  • action: on Windows desktop PC I enter the DuckDNS URL (https://MYSUBDOMAIN.duckdns.org:8123) in chrome via my home network (wifi)
  • result: most of the times error message “unable to connect to Home Assistant retrying in XX seconds”

Scenario #3 local IP iPhone - OK

  • action: on iPhone in Safari I enter the local URL (192.168.0.XXX:8123) in via my home network (wifi)
  • result: always a connection.

Scenario #4 local IP Windows - OK

  • action: on Windows desktop PC in Google Chrome I enter the local URL (192.168.0.XXX:8123) in via my home network (wifi)
  • result: always a connection.

Some background information on my setup:

  • Running Home Assistant on an RPI4 with the following software
    • Home Assistant 2022.8.7
    • Supervisor 2022.09.1
    • Operating System 7.6
    • Frontend-versie: 20220802.0 - latest
  • I am running the latest version of duckDNS.
  • i have enabled port forwarding in my router for service port 8123 to internal port 8123
  • I have the following in my configuration.yaml
homeassistant: 
  external_url: https://MYSUBDOMAIN.duckdns.org
  internal_url: http://192.168.0.XXX:8123

http:
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
  ip_ban_enabled: true
  login_attempts_threshold: 5

Troubleshooting DuckDNS connection
I have taken the following steps to try and fix the DuckDNS remote connection.

You can use the website https://www.digwebinterface.com/ for this:

  • enter the URL without http and without the port (e.g. yoursubdomain.duckdns.org)
  • tick the box next to ‘trace’
  • click on the button ‘dig’
  • after waiting a second (maybe seconds) the last block should show the IP address issued by your ISP. You can also review the delays along the route (see the last line of every block, it will show for example ‘8.8.4.4#53(8.8.4.4) in 38 ms)
  • resetted router & modem and rebooted the HA host machine
  • checked if IP registered at DuckDNS and the IP provided by my ISP is still a match (it is)
  • checked if port 8123 is still reachable using https://canyouseeme.org/ (it is reachable)
  • checked if the URL is still correct in the companion app (it is)
  • in the configuration of the DuckDNS addon I have added the Duckdns URL in the IPv4 section (did not help)
  • Checked HA logs and there is no relevant error message
  • cleared the cache in Google Chrome on my Windows machine (did not help)
  • checked (I think) all the posts on this forum which are related to this issue

Any help is appreciated!

15 Likes

I have been dealing with it too. I believe it is an issue with their servers. It happens every 6 months or so.

2 Likes

all day same problem :neutral_face:

5 Likes

Had similar frustrations and determined it was duckdns by trying to access my URL in a fresh incognito tab and it says {my-host}.duckdns.org’s server IP address could not be found. :frowning:

I can access duckdns.org myself but some of the “is it down” sites think it’s down https://isitdownorjust.me/duckdns-org/ I cannot access duckdns.org at the moment.

1 Like

Anyone suggest other free dynamic IP services with an HA add-on?

1 Like

same problem

2 Likes

https://www.noip.com/

Every month you need to validated that you are using the DNS, beside that is free and work well.

2 Likes

Same problem here. Let‘s see how fast it is resolved.

1 Like

I’ve never had problems before, but since yesterday (about 15 hours ago) i’m no longer able to log in.
I suspected Duckdns to start with and this thread confirmes my suspicion.
Is this something that will resolve itself (aka duckdns servers getting back online)?

I am able to get in sometimes (about 1 in a 100 tries). When i’m in I can acces everthing just fine, but only for a minute or so.

2 Likes

Same problem. Although my symptoms are a bit different:

  • Reloading the HA website takes a long time
  • The app on Android complains about the same. Once connectivity is achieved, it works pretty smooth
  • Google Home can no longer connect in a stable manner

I don’t distinguish between a local and external URL, because to my perception, once you have ssl enabled, HA will no longer expose unencrypted traffic to the internal network (source). Would be keen to understand how you achieved that, but that’s a different subject.

I am on a Docker system, running on a RPI4. All to the latest versions in my attempt to solve the connectivity issues. Running a Mikrotik router that takes care of the DuckDNS updating, because the router is where my public IP terminates.

1 Like

OK, so it isn’t just me. Clearly related to duckdns, via browser connecting to local (or even public) IP (and ignoring the ssl certificate mismatch warning) just works all the time. Going via the duckdns url gives issues. Also noticed the issues with google assistant/google home, but that is logical since that needs the URL.

It is very odd, because it works so intermittently. It isn;t that it doesn;t work at all, once in a while it will actually be able to connect - very weird. Nothing appears in the duckdns or HA logs.

Oh well, I assume it will get resolved after the weekend …

3 Likes

I’m having the same issue, at first i tought it was my Home Assistant installation having issues but i can connect trough the local IP just fine. Hoping for a fix from DuckDNS soon.

2 Likes

Same issue, but on wifi not able to connect to local IP…

1 Like

Same problem here, duckdns is not working correctly.
In the duckdns page i see the correct ip address but if i try to use my duckdns address
I cannot reach my home assistant instance nor my ipcam. With IP address it works.

1 Like

Thanks all for replying! This makes me pretty confident the root cause of the issue is currently with the service provided by the DuckDNS website. I hope they resolve it soon.

Glad to find this and to know its not an error on my part, also hope they resolve soon

2 Likes

Same here, happened about 2 weeks ago for me as well, pulling my hair out trying to get google assistant to work to find out its actually just duckdns and figured out when I left the house and not using my hairpin nat.

1 Like

Same Issue here, most annoying google assistant is not working…
Easy to check that it’s duckdns, just do a remote nslookup e.g. here https://www.nslookup.io/
There is no name resolution anymore…

4 Likes

Thank you for providing this check, really useful!

Exact same issue here, from a working setup before with no changes. I assume they’re just having some trouble currently. Thanks all for posting here to confirm the issue.