No Supervisor Internet Connection, Error on Home Assistant Installation

Hi All,

I’m trying to set up Home Assistant on VirtualBox 7 on Windows 10. I’ve had a lot of trouble so far, initially with getting an IPv4 address, and now the Preparing Home Assistant gets stuck with the following errors:

23-01-24 01:09:37 WARNING (MainThread) [supervisor.jobs] ‘Updater.fetch_data’ blocked from execution, no supervisor internet connection
23-01-24 01:09:37 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

In order to get around the IPv4 issue, I used the following command (but with an interface name and a different IPv4 address and nameserver address).

ha net update (interface name goes here with no brackets) --ipv4-address 10.10.10.12/24 --ipv4-gateway 10.10.10.1 --ipv4-method static --ipv4-nameserver 8.8.8.8

With this I was able to establish a static IPv4 address, ping it from the command prompt, and get to the Preparing Home Assistant page, but have tried multiple browsers (Firefox and Chrome), waited over an hour, and can see these errors just repeating in the log.

Some info about my setup: my DHCP is set to Enabled, and in my modem the MAC Filtering Mode on my MAC Filter Setting is set to “Allow-All”. For the VirtualBox settings I have the OS set to Other Linux (64-bit), Base Memory 2048 MB, 2 Processors, EFI Enabled, 100 GB for Storage (controller SATA using the VDI file downloaded from this site haos_ova-9.4.vdi), Audio set to Intel HD Audio, Network set to Bridged Adapter, Realtek PCIe GBE Family Controller, Promiscuous Mode Deny, Cable Connected.

Here is a link to some pictures of my settings:
https://imgur.com/a/l1BXbzj

I’ve read that hanging on the Preparing Home Assistant Page can be a memory issue, but I’ve upped the base memory to 5049 and set the Storage to 100 GB. I’d appreciate any help in getting this working. Thank you all for your time in advance.

Promiscuous Mode should probably be allow, unless you have a network interface dedicated only to HA, which means not even the host OS can use it.
Promiscuous Mode allow a network interface to fake extra network interfaces, so other network devices, like routers and switches think it is another device than the original device connected to the network interface.

Thank you so much for your response. I changed Promiscuous Mode to allow, but I’m still getting stuck at the Preparing Home Assistant page, and getting the same error.

23-01-24 01:09:37 WARNING (MainThread) [supervisor.jobs] ‘Updater.fetch_data’ blocked from execution, no supervisor internet connection
23-01-24 01:09:37 WARNING (MainThread) [supervisor.homeassistant.core] Error on Home Assistant installation. Retry in 30sec

Looking at your pictures it looks like that Promiscuous Mode is actually for the driver in the Linux Guest OS and not on the Host OS.
Do you have a Promiscuous Mode enabled driver installed on the Host OS and if it must be enabled in the network interface setting that it then also have been done that.

Also try different emulations of network interfaces in the Guest OS.
There should be other emulations than Intel Pro/1000 MT Desktop.

Thanks again for your response.

Do you have a Promiscuous Mode enabled driver installed on the Host OS and if it must be enabled in the network interface setting that it then also have been done that.

How do I install a Promiscuous Mode enabled driver on the Host OS? I’ve looked around in all the settings I can’t seem to find that anywhere.

Some vendors have drivers that are not promiscuous mode enabled, so you need to download another driver for that device from the vendor.
Sometimes the vendors just mess up.

See this thread:

After some researching, I found out that if I do this:

bridge show adapter
netsh bridge set adapter 1 forcecompatmode=enable

And then check to see if Promiscuous Mode is enabled:

Get-NetAdapter | Format-List -Property ifAlias,PromiscuousMode

I get

ifAlias: Ethernet
PromiscuousMode: True

But all other items, vEthernet (WSL), VMware Network Adapter VMnet1, VMware Network Adapter VMnet8, and Ethernet 2, still all show Promiscuous Mode as false.

Of course I tried to see what happens to the Preparing Home Assistant page after this, and it still gets stuck on the same error.

It looks like you might have 2 physical network interfaces on your host OS, so may e you can dedicate on solely to the hypervisor.

Thank you kindly for the suggestion. Do you know how to do this?

Now I can’t even get anything to enable Promiscuous Mode. Following your link I installed WireShark and Ncap 1.60, and WireShark says Promiscuous Mode is enabled everywhere, but it’s not.

I do not know virtualbox thah well by do a Google search on “virtualbox dedicated nic”.