Node-red, can't change code in a function node

I have problem with Node-red and function nodes.
Can’t change/write code in a function node.
Nothing happens if I try to type anything in the code section.
Almost as the code is write protected!

Picture from old function node that I want to change.

Have tried to reboot the system but it doesn’t change anything.
And it’s the same if I start with a new function node and try to add code, nothing appends, can’t write any code.
Anybody else that have had the same problem?

Maybe that’s the case. But I don’t know how to get my function nodes to work again.
I suspect that it’s some general fault because even the new function nodes is not working.

Can’t get function node to work, or can’t edit/write function node?

If you can’t edit/write a function node, the answer is in the quoted message thread. Have you looked at ‘Mange Pallet’ and updated all your nodes?

Some contrib nodes don’t always stick to the ‘rules’, and some out of date ones are known to upset the new Node-RED editor (just by being there) which becomes read-only for everything. In read-only mode, the editor becomes ‘write-protected’.

Solution. Update all node sets. (Take a backup of all flows first…)

@Biscuit I have solved the problem :grinning:
I updated all the nodes and the problem disappeared
Thank you