Node Red Warning In System Logs [Resolved]

After applying the Node Red version 10 update, I’m noticing the following warnings in the System Logs;

21-08-11 09:09:56 WARNING (MainThread) [supervisor.addons.options] Option 'dark_mode' does not exist in the schema for Node-RED (a0d7b954_nodered)
21-08-11 09:09:56 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered)

Are these warnings something to be concerned about?

EDIT: Problem resolved. Removed the following options from the Add-On’s “Configuration” tab - not Node Red Settings.

Copy to clipboard

dark_mode: false
require_ssl: true
1 Like

Yes if you did read the update notes it says dark mode option does not exist anymore. You need to chose settings

1 Like

Problem resolved. Removed the following options from the Add-On’s “Configuration” tab - not Node Red Settings.

dark_mode: false
require_ssl: true
1 Like

I deleted the settings from the config text and opened up Node-Red Settings from the hamburger menu. I cannot find Dark Mode or Require SSL or Turning off the PWNED settings. Sorry if I am a bit slow, but did anyone find Dark Mode or the other settings within Node-Red?

I also did not find the dark mode settings. Before the upgrade to version 10, I had it in dark mode, and after it’s set to light. I poked around and saw a theme option to change from light to dark within the dashboard tab (next to debug console), but there isn’t a “save” or “apply” button.

Please read the release notes. dark_mode is not the only option that was removed.

1 Like

Dark mode removed - thanks for the tip mbonani. I turned off auto updates, I am getting a bit frustrated that every month a few more things break with homeassistant and I have to come back and redo things every month just to maintain old functionality.

Anyways, a workaround for the Dark Mode being removed (edit) Node-Red supports Dark Mode again. See the next post!

1 Like

You don’t need to use Dark Reader for that. We have the theme option now

See addon-node-red/DOCS.md at 2bbc8e2043ea555f63e6852f4524cc8813e1f93a · hassio-addons/addon-node-red · GitHub

2 Likes

I’m constantly seeing these same errors in the supervisor logs.
Why?
I can’t find any references to those settings anywhere.

Here’s my configuration.

{
  "theme": "default",
  "http_node": {
    "username": "",
    "password": ""
  },
  "http_static": {
    "username": "",
    "password": ""
  },
  "ssl": false,
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "system_packages": [],
  "npm_packages": [
    "node-red-newtifrypro",
    "node-red-contrib-bool-gate",
    "node-red-contrib-boolean-logic-ultimate",
    "node-red-contrib-presence-faker",
    "node-red-contrib-stoptimer"
  ],
  "init_commands": [],
  "credential_secret": "REDACTED"
}

That’s nice but unless you post the errors, we have no way of knowing where the problem is.

It’s the same errors as in the thread.
Here it is.

There’s lots of them.
I ran ag on in the folder, (took a lot of time) and couldn’t find hits on dark_mode aside from a match in frigate addon

24-02-27 18:33:10 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered)
24-02-27 18:33:10 WARNING (MainThread) [supervisor.addons.options] Option 'dark_mode' does not exist in the schema for Node-RED (a0d7b954_nodered)
24-02-27 18:33:10 WARNING (MainThread) [supervisor.addons.options] Option 'require_ssl' does not exist in the schema for Node-RED (a0d7b954_nodered)
24-02-27 18:33:10 WARNING (MainThread) [supervisor.addons.options] Option 'dark_mode' does not exist in the schema for Node-RED (a0d7b954_nodered)

Go to the config page of the addon, choose the 3 dots and edit in yaml. Does everything match what you posted?

Do you remember making any changes to settings.js? Take a look in that file for the 2 options it’s complaining about. If they’re uncommented, comment them out and restart.

1 Like

Thank you for your help and the prompt responses.
My SSD is giving me errors and Home Assistant is not starting.
Any way I can manually make a backup without Home Assistant from the files on disk and restore it on a new instance?

I know this has nothing to do with the thread issue, it just that I can’t access any of what you’re asking unless I get to it through the file system.

@Mikefila
Thank you.
Miracles do happen,
My SSD is showing some signs of life (I better migrate ASAP)

You were bang on, editing YAML showed that I had it there.

theme: default
http_node:
  username: ""
  password: ""
http_static:
  username: ""
  password: ""
ssl: false
certfile: fullchain.pem
keyfile: privkey.pem
system_packages: []
npm_packages:
  - node-red-newtifrypro
  - node-red-contrib-bool-gate
  - node-red-contrib-boolean-logic-ultimate
  - node-red-contrib-presence-faker
  - node-red-contrib-stoptimer
init_commands: []
credential_secret: REDACTED
require_ssl: false
dark_mode: false

I wonder how come I couldn’t find it on the file system.

1 Like

I’m guessing that you have been using node red for awhile. Those entries were probably added in yaml originally. Sometimes they persist through upgrades. You were looking at what the runtime config was. Those options were rejected and never loaded.

You just need to export all your flows. Right click anywhere on the workspace, choose export, there is an option in the dialog box to export all nodes.

1 Like

Thanks a bunch.
Indeed, I had set it up long time ago.
As for export, what I was trying to do is migrate Home Assistant not just Node-Red and was wondering if there was a way to do a backup (ie create the proper tar) from file system if Home Assistant was not running.
In any case, I managed to get it to run and create a backup and migrate it from running as docker in debian to haos in proxmox.
I still have to navigate loose ends, like easily accessing my hand coded yaml files through ssh and getting zigbee / BT working again, but that’s OT to this thread and I’ll probably manage to figure out or find helpful references.

Thanks for your help.