Not seeing 0.101.x update message in HASS.IO

I’m running version 0.100.3 and I’ve been expecting to see the message in my tab to update to version 0.101.x. But nothing has shown up.

I’ve checked my logs and I can see it checking the version URL (no warning or error):

19-11-04 16:55:38 INFO (MainThread) [hassio.updater] Fetch update data from

Which shows for my system (HASS.IO on rPi3B+) it should prompt for the new version. I’ve tried restarting HASS and I also checked the updater sensor, which reports:

entity: binary_sensor.updater
state: unavailable

Which looks like a clue.

EDIT: I see that the docs say this sensor will show unavailable for 1 hour following a restart but I’ve checked many hours (days) after a restart and it never changes.

EDIT 2: Last restart shows it did change from unavailable after an hour (thought I’d checked this before last restart but maybe I imagined it). I now see:

entity: binary_sensor.updater
state: off
attributes: release_notes:
newest_version: 0.100.3
friendly_name: Updater

Can see in logs:

19-11-04 20:55:38 INFO (MainThread) [hassio.updater] Fetch update data from 19-11-04 20:55:43 WARNING (MainThread) [hassio.updater] Can't fetch versions from Cannot connect to host ssl:None [Try again]

I can resolve the host on my Pi via the “terminal” add-on, as well as being able to wget the JSON file via

Is “ssl:None” the problem, maybe?

I think this is similar to the issue reported here: Can't update hassio (same error message quoted Can't fetch versions from Cannot connect to host ssl:None). Not clear from that thread what the fix was though. Will try power cycling my Pi when I get home.

EDIT: Did a full host reboot and problem is solved. The Update message is now appearing in my window.