Not update posible toomanyrequests

Tags: #<Tag:0x00007f3274348db8>

I not possible update the HA appear these error in sustem:

20-11-21 21:14:53 ERROR (SyncWorker_2) [supervisor.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:0.118.2 -> 500 Server Error: Internal Server Error (“toomanyrequests: You have reached your pull rate limit. You may increase the limit by authenticating and upgrading: https://www.docker.com/increase-rate-limit”).
20-11-21 21:14:53 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

My current version is 0.118.1 and upgrade to 0.118.2

How to solved this?

According to the link you posted, you have probably downloaded over 100 container images in 6 hours.

I’m having the same issue.

If you have a docker hub account you should be able to add the credentials on the supervisor page, which would increase the rate limit from 100 to 200 pulls in six hours.

The instructions seem to be go to Supervisor tab | Menu | Add repository. I’ve done that using (“hub.docker.com”), but still seem to be running into the rate limit.

Posting, in the hope someone else chimes in.

Where is this menu? In HA’s interface I click on Supervisor and there is no menu in any of the tabs.

That will only work starting with SU version 2020.11.1

How too update to 1020.11.1 ?

Join the beta channel in the Supervisor system tab

1 Like

FYI users affected can join the beta channel but cannot update their supervisor, the same restriction applies to getting the beta supervisor image…
Time for a :coffee:

Same error here and and i haven’t downloaded anything in the last 4-5 days …

Can update checks also consume this limit?

Do you use watchower? That’s what was using all my calls

As i understand, watchtower is an update agent for Docker?

But i don’t use Docker, i have a standard installation on RPi4, so it probably won’t be this problem.

What do you mean ‘standard’

i’ve got the same problem and i use the Hassio system on rp3

How many add-ons do you all have? Have you set them all up to auto update?

You may not realise, but hassio runs on docker containers, as do the add-ons. When hassio checks if an update is available, it most likely does count towards the 100 pulls / 6 hours limit
I’ve not checked the underlying code, but if the supervisor uses something similar to WatchTower, it checks each add-on (+ supervisor, OS and HA Software) every 30 sec.

For now I’d suggest disabling auto-update on all your add-ons, give it 4-6 hours and try again.

thx, i’ll try but i have just a few addons (- with only 4 activated).

sorry but where i could check the auto update ?

Maj :
it worked after few time.
Now, i have the same issue with the 0.118.4 update.
I never had the problem before.
Should i do something ?

Thank you

It does not, the Supervisor uses git to check that for add-ons, and the version files like https://version.home-assistant.io/stable.json for everything else

Thanks @ludeeus. That’s helpful to know but then doens’t explain how toomanyrequests: You have reached your pull rate limit. shows up, especially for users that do not run any other containers and do not use something like WatchTower on their system…
I know this is a different issue, but it shows that checks are being counted towards the number of pulls limit when technically it should not (as believed by the docs). Just wondering if something similar is taking place with hassio?
Happy to take this offline (discord? lolouk44#7180) to not clutter this thread

There is not, dockerhub is only reached when doing installations/updates.

Docker Hub, bases the ratelimit on the IP address, so any client behind that IP will affect the limit.

1 Like

You’re right, I really didn’t realize that hassio also runs in a docker container …

I still have a docker installed on my network on Synology NAS, but it’s probably not causing a problem - even if it was turned off for 24 hours, no change has occurred.

The only thing that will really allow me to perform updates is to disconnect HA from the network for some time (i tried 8 hours), then the updates will go to install, but of course this is not the solution.

Is there any way to find out what requests are being sent to the docker server? I admit that i am not exactly an expert on Linux …

However, i definitely did not perform any updates, or installation (it is not possible) by my own, and i have automatic updates disabled for both the system and add-ons.