NSPanel Pro - Custom android apps (working)

Thank you seaky.
I’ve send it back to Sonoff cause they were interesting about what happens. A new one is just arrived.

1 Like

I really appreciated your articles they saved me a lot of time so thank you for that. One thing that would be helpful is they have changed things a bit since 1.5 and it took me a while to get around it. ADB is available but is not on by default. Now you need to connect the device to Sonoff (you mention this), go into the device info and tap the device id 8 times. It will then make you agree to developer mode. You then need to go into developer settings and check the adb button and sign your rights away.

Maybe if I moved a little slower I would have noticed this but I wouldn’t describe myself as a patient man…

I hope this will help someone else who can’t seem to connect via adb.

Thank you for this information! I have 2 panels that are on Version 1.5 and not changed. My 3rd one ist still on 1.33 and I played arround with developpermode and adb. Since then it is not possible to install newer firmware anymore. Its not even recognised. Even a complete recovery did not help.
Is there any way getting back to default mode, to be able to upgrade to the latest version?

They make it pretty clear when you check that button that once you turn it on you aren’t going back.

I Just got the new Pro, with V1.5.0 OS Version
But tapping 8 times does not activate developer.
Wifi ADB and USB OTG is also disabled.
Anybody got a solution to connect ADB on these?

Did you tab on the Device-ID in the eWeLink app? (So not on the panel)
I have 2 panels on V1.5 and it worked perfectly.
Some inspiration?

My two panels arrived yesterday.
Both are version 1.4.0 and I managed to turn on ADB via the ewelink app.
Also on the app I needed to navigate to “Developer Mode” and turn on USB debugging.

I had issues with the browser last night so I decided to pick it up this morning.
When checking on it this morning, I found the all connections were refused.

Looking at the ewerlink app this morning, I can see “Developer Mode” is no longer a menu I can access as it states my warranty is terminated.

It seems like ADB access is limited to something like 12 hours before locking out.

Has anyone else seen this, and if so what can I do?

Received my NSpanel Pro yesterday. First updated firmware and OS to 1.5.0.
Than opened ewelink app and added NSpanel Pro as new device.
After that, in ewelink app thicked “Device ID” 8 times, and “yessed” the question if I wanted to acces developer mode (or something like that).
In the ewelink app I could not find another option “Developer mode” to turn on USB debugging.
Could not get WiFi ADB connected with my laptop.
Should it be possible to ADB connect by USB? Or will this also be unavailable?

Edit: After re-adding Ewelink via QR-code, and accessing developer mode by 8 times thicking “Device ID” in the Ewelink app, suddenly the “Developer mode” menu option appeared, which could be accessed and accepted the waranty void.

I tried to enable developer mode today in the ewelink app. I have the impression this no longer works. Can anyone confirm this?

I have also tried to get my nspanel pro to developer mode. I have tried versions 1.4(my original version) and 1.5. I have tried reverting ewelink app to older version. I have tried ADB connection with usb cable and wifi. I have tapped device ID on ewelink like crazy today.

Do anyone know how to get developer mode in versions 1.4 or 1.5?

I can confirm, the app doesn’t do anything if i tap 8 times on Device ID.
(Panel Version 1.4.0)

I ran into this too, however I found a solution:

  1. I connected the panel via USB
  2. Started panel recovery by turning off the power 4 times when the animated logo appears.
  3. After restoring the panel, I continuously gave the adb devices -l command in the command line, and as soon as the panel appeared in the list, I immediately launched the launcher installation. adb install ultra-small-launcher.apk
  4. After the reboot, I selected the launcher as the default application and through Go to Settings → System → About tablet → Build Number and tap the “Build Number” option 7 times to enable developer options enabled USB debugging

Thanks you so much!!!

That worked!!!

I have tried your guide and I get this:

PS C:\adb> dir
    Directory: C:\adb
Mode                 LastWriteTime         Length Name
----                 -------------         ------ ----
-a----          1/1/2008  12:00 πμ        6021632 adb.exe
-a----          1/1/2008  12:00 πμ          97792 AdbWinApi.dll
-a----          1/1/2008  12:00 πμ          62976 AdbWinUsbApi.dll
-a----          1/1/2008  12:00 πμ         241664 dmtracedump.exe
-a----          1/1/2008  12:00 πμ         432640 etc1tool.exe
-a----          1/1/2008  12:00 πμ        1849856 fastboot.exe
-a----          1/1/2008  12:00 πμ          44032 hprof-conv.exe
-a----         15/2/2023   4:21 μμ        2116163 launcher.apk

PS C:\adb> .\adb devices -l
List of devices attached
rockchipplatform       recovery product:px30_evb model:px30_evb device:px30_evb transport_id:3

PS C:\adb> .\adb install launcher.apk
Performing Streamed Install
adb: failed to install launcher.apk: /system/bin/sh: cmd: not found

do you have something in mind?

You are trying to install the launcher during the panel recovery process. You need to wait for the recovery process end and try during the panel loading process.

1 Like

You have to wait that device is not in recovery mode and shows in the list.

I think it was after reboot.

So first it shows in recovery mode then it changes to normal mode. That is the spot you hit install laucher.

This worked perfectly for me. THank you so much.

I got the exact same thing to start with.
Keep pushing the installation after the recovery process has completed.

That first reboot after the recovery is when to push the launcher.
I found mine took after the spinning Sonoff graphic and just as CAST comes up on the screen and it was too late once the eWelink log comes up.
I hope this narrows the timing for you.
Once pushed I completed the eWelink setup with the QR code and went to About and selected Reboot.
On the next load it gave me the option to choose launcher. I selected Always.

Once loaded in, I went to About and activated Dev mode (blah blah, you get this bit).
In the Dev Mode menu, I enabled USB debugging.

I then turned it off and put it all back together.
Now it is back together, I can continue with the great doc from blakadder using the connect command.
This allows you to continue the setup over the air and has no need for USB cables.

In summary, spam it, it will take I promise as it worked for me last night.
Spent hours on making this work, and thanks to Filya75, I had this nailed in an hour.


I found a second way to enable adb. You need an Otg USB adapter and a USB keyboard for this. This is connected to the USB port of the Nspanel. When the Nspanel is started and you press the “Windows”+“N” key on the keyboard, you get see the Quick Settings display. Here you can access the settings. There you can activate the USB in the developer options. Now the lauchner.apk can be installed via adb.


So do I understand correctly that after enabling ADB, there’s no way, to (even manually) upgrade the firmware?
That’s the only thing holding me back right now.
I don’t care about warranty or loosing support. I can live with that.

But I’m a little worried, since without updates, the risk of it getting dropped out of the App, due too old firmware or about hidden bugs in the installed firmware, never to be fixed, is something more concernable…
On the other side, in stock configuration, I would assume, that it needs to talk home/to the cloud to work as expected?

I don’t have issues playing with adb or weird shenanigans, like faking stuff in it’s network,…

I didn’t play with the thing itself so far, besides only powering it up once.
It’s planned to use 2 of them in the lower floor, where the electrical wiring gets a complete overhaul right now.

So there’s some time till they get put into use.

Main use case is to eaisly set different parameters, like for the automated blinds, LED lighting, ZigBee TRV actors, rotolock (with axis door controller), …
Maybe also displaying CCTV feed, if it can handle that.

Maybe someone can give me some heads up regarding the update situation?

Side note:
I noticed there’s more stuff on the power supply connector, it seems like it’s designed to be able to controll directly an output (probably with a different base, that got an relay on it)
Anyone played with that so far?

Also there’s some flat connector labeled HT, seems like there was some intentions about temperature and humidity…