NSPanel Pro - Custom android apps (working)

you found a way? any news on this?

and guys? anyone found a way of being able to send notifications to nspanel pro with hass companion?

also any ideas of how i could use the zigbee coordinator in NSPanel Pro with HASS?

Yeah I’m just received mine, updated to 1.56, enabled dev mode, and then enabled adb, connected via adb tcp, followed the latest black adder nspanel pro home assistant instructions; voila! took about 30 minutes.

This doesn’t appear to work for me with 1.5.6.

After tapping 8 times, what happened? Did the screen display a message or something?

Oh I see, you have to tap developer ID 8 times in the eWeLink app on your phone.
OK, ADB is now connected.

Thanks guys.

Also very interested in this, since I rooted it at a lower version, and V1.5.4(Feb 14th, 2023 has some promising features.

Tried factory resetting it in the eWelink phone app, in NSPanel app, but still have adb and a void warranty. :confused:

If anyone has 1.5.4 with root, can they perhaps please upload the apk? This should work:

adb shell pm path com.eWeLinkControlPanel
adb pull /data/app/com.eWeLinkControlPanel.apk /download

I had buttons to switch between apps in Lovelace as needed:

      action: call-service
      service: androidtv.adb_command
        command: >-
          adb shell monkey -p com.eWeLinkControlPanel -c
          android.intent.category.LAUNCHER 1
        entity_id: media_player.nspanel_pro

      action: call-service
      service: androidtv.adb_command
        command: >-
          adb shell monkey -p io.homeassistant.companion.android -c
          android.intent.category.LAUNCHER 1
        entity_id: media_player.nspanel_pro
1 Like

IM a little confused if honest, so here goes.

Got my NSPanelPro setup…working well apart from two aspects.

  1. The MOtion detection via FKB isn’t working as expected. It thinks something else is controlling the camera…but I have no idea what…the panel itself only allows HASS to use the camera…and my two FireTablets running FKB for HASS seem to have identical settings and work as expected without issue

So not sure what I am missing here,…but its seriously bugging me

Secondly, on my existing wall tabs, I use Browser mod to switch between screens when a doorbell rings…to show who is at the front door…works perfectly on the existing tabs again but when I try to pick the device the new Browser mod instance isnt even registering …so really not sure what is wrong there either

That said, have noticed a lot of light bleed on this one on bottom right-hand corner of the screen so returning it (as from Amazon) so will work on the replacement when it arrives…hopefully, some sort of fix for my issue by then

It’s probably a case of “woods for the trees” as I’ve been tinkering for hours tonight if honest


Started from fresh in case Ive done something wrong but after fully setting things up again I am still getting this warning…so now im a little stuck

I do not think the nspanel pro really has a camera. It does have a proximity sensor that can be used.
This is what I got together:

1 Like

ah that actually makes a bit more sense now…just misleading as the UI states it has access to the camera…

I’m having a problem. I rooted my device with eWelink app.

Everything worked fine, I had however some trouble with WebView. Decided to install official update and was able to do so.

However, now my launcher is back to original Sonoff one, and adb is disabled and cannot be enabled from the eWelink app as it still thinks it is already on. Ie. Developer mode is claimed to be in use in the app, so I cannot go there to disable and then enable ADB or try something else.

Is my device doomed to be rooted and with no possibility of adb connect?

Managed to fix this with @Filya75’s tips!

I managed to install android with the procedure
But I have a big problem with the proximity sensor

if I understand correctly, the value must be higher than the current value? in the picture the correct value is 6500?
it doesn’t work for me
it works in automagic, when I pass my hand it turns red then blue.
But once on the home screen android as soon as the standby is on when I pass the hand nothing happens.

it works 1 time out of 10
when it works, it wakes up the screen but it makes an automatic restart…

Do you know what could be the problem?
or is it possible to wake up the screen by touching it?

My Proximity sensor is not working at all, only values of 8 or 9 but no change when hovering my hand in front.

Thats why i’m now using the NSPanel Pro Tools, this one also is capable of using the Proximity Sensor, but also when touching the screen to activate it. Might be usefull to try this app.


Thanks Bramus,
i will test

edit : thanks it wirking fine

another question, which application do you use for HA?
I have installed HA Companion

when i select my local adress HA crash

That´s exactly my problem. I allready testet wallpanel and , wallpanel crashed and starts every 2-3 second ( and crashed again).
HA Companion full and minimal apk crashed when select my local adress.
Anybody an idee ?
i can use Chromium, but that didn´t looks very nice…

Maybe have a look at my post some lines obove? I use Fully Kiosk Browser and I am quite happy with that.

for me, i test Fully Kiosk browser but i have issue.
My local adress doesnt work, fully remains blocked on the loading page
i will test to install again app
Which version are you using?

I am using the latest version from the web page: I think: 1.49.1

got a solution :slight_smile: I followed the blakadder instructions completely. Including the last step ( update WebWiev). And nothing worked (no fully kiosk either…). Now I simply put the selection back to the old choice in the developer mode. Reboot = everything works :slight_smile:

1 Like

Had the same issue, switch back to the old Webview that was installed on the 1.5.0 firmware. The new updated webview also crashed my app. When switching back to the default one it is working.

i’ve found solution
i have change parameters here
i select chromium and now HA companion working fine.