Nuki Smart Lock and Matter (or mqtt)

Thread, as basic Nuki 4 has no Wifi.

The Nuki 4 can connect to MQTT over Matter/Thread.

1 Like

In the Nuki app, you have to choose something like “Knob odr Door Bar” as the lock’s mode. (In German: “Knauf oder Stange”). I’ve also reconeccted the lock to HA. Now it works as supposed.

Yip can confirm, after repairing it works nicely (and actually more stable than with the old version). Thanks!

1 Like

Hi there,

I have Nuki Pro 4.0 (Firmware 4.2.8) and integrated via MQTT (directly over wifi, no Bridge) to my HomeAssistant (Core 24.4.4, Supervisor 2024.04.0, OS 12.2), however I am seeing far fewer entities that some users on this forum,

I can open and close the lock for instance, but cannot know the state of the lock (open or locked).

Any ideas about what I am missing? Thanks in advance.

That’s strange,

I am using the very same configuration (lock, FW, same HA, / OS) without bridge on MQTT and get this:

Did you try to listen to the topic state?
See Nuki MQTT API here:
[MQTT API Specification v1.4 - Nuki APIs / MQTT API - Nuki Developers]
(MQTT API Specification v1.4 - MQTT API - Nuki Developers)

and how to here:
How to listen to MQTT topic under Dev Tools? - Configuration - Home Assistant Community (

Maybe deleting the lock from HA and re-discover it helps?

Hi NCO3,

Thanks for trying to help, I keep struggling with this.

So I went ahead and deleted the nuki lock from Home Assistant and and deleted the MQTT connection from the Nuki Lock App to start everything from scratch.

Still the problem persists. Somehow home assistant identifies my lock as a “battery”

and I have no information about the lock state:

went ahead and tryied to see what was happenning with MQTT Explorer and this is the result


where apparently the state is being identified.

Anyone has any tips? tThey will be greatly appreciated

Ok, I was finally able to find a workaround to the entity issue I encountered as explained in the thread above.

Since I could not get the lock state to show up with the autodiscovered MQTT integration of the Nuki (discovered as a battery above), I ended up creating, manually, an MQTT sensor in the configuration.yaml file that monitors the various lock states (which I identified using MQTT explorer and seeing how they changed based on what the lock was doing).

This is the final configuration of the manual sensor I created:


With this sensor I was then able to obtain the information I wanted in a lovelace Entities Card:


Giving me information not only when the nuki in locked/unlocked but also when it is unlocking, locking, unlatching, etc…




As for the lock/unlock/unlatch button I also ended up solving it manually and creating 3 separate buttons for which I also post the code bellow:

1 Like

Great to hear, you’ve made it.
My state also returns theses states since the beginning (half a year ago, when I started this thread).

I also included one MQTT info manually (last lock user).

Interesting… does your MQTT Explorer show the “last lock user” information? I don’t think mine does…


Yes, I read this from this topic:


Hi guys, I am getting a bit of an issue when setting this up using MQTT. Can I just check what hostname you guys are putting in the nuki app? I have tried just the IP address, ip address + port but I seem to be getting “This action could not be executed”. Nothing shows in my MQTT log so I can only assume that the message isn’t getting sent through?

Im using the ip address of my homeassistant, its where my mqtt broker is.
hope this helps


How exactly did you manage to do this? I have a Nuki 4 Pro on firmware 4.2.8 version connected to HA via Matter, and the Unlatch control does not show. I’ve tried deleting/reconnecting the lock, as well as factory resetting it - all to no avail.

Another weird thing is that the Firmware version is shown as 4.1.0 in HA, while the app states it’s 4.2.8

I’m hitting this problem, too. How did you “reconnect” the lock?

Same here. Also no change after the update to Matter 1.3 of the matter server or reinterviewing. No way to unlatch. Mqtt does support it, so it shouldn’t be the operating mode of the lock. The device was paired initially through a Nest hub 2, could that be a factor?

But something else: I just noticed this. Battery level started dropping at an alarming rate all of a sudden. Is anybody else seeing effects like this? Im thinking what did I do at that point? I experimented with an ESP border router but that was a couple of days ago. This seems to be just a regular morning, unlocking at 7:00.

I noticed that there now is no dedicated open/unlatch control, but rather I need to click on the lock symbol or name to open the control modal. The button to open/unlatch is shown there below the lock/unlock slider control.

Yes, it is for MQTT, but not for Matter. Also the corresponding service to open the door will not allow you to pick the matter entity. I even removed the device and paired it anew yesterday, but still it isn’t there.

Using mqtt forces me to configure either Matter (actually Thread, but Nuki isn’t mentioning that) or wifi. So it seems like a waste to turn on mqtt as well as matter, since wifi is more power hungry.

Same lock (mqtt is disabled for now):

Does anyone know if there’s a way to manage key codes on the Nuki Keypad 2.0 from home assistant?

Hi there,
i just setup up my Nuki lock via mqtt.

It is working fine but i do not see the “last lock user”.

How exactly do i get that info?

Thank you in advance

Not 100% sure but usually, if you use home assistant to lock/unlock the nuki, then the user identified as performing the lock/unlock will be MQTT and not the actual user.

Good luck!