Number of decimals with values from KNX?

I’m having an issue with some values that I read from my KNX (which also has modbus on it, so it works as a modbus gateway to my HA installation).

But, I have way to many decimals on some of the values.
From the KNX, i have 4 decimals, for example 2,3024kw

But in HA it could show 2,3024351849

Is it possible to configure that in the yaml file where I enter all the datapoints/tags that I want to read from the KNX?
Or do I have to do it in “lovelace” for each sensor/graph etc that I put in? I prefer directly in the config file.

Some idea how to solve this easy would be appreciated.


The KNX integration provides the data as it is received from the bus. If you want to calculate on it / round it etc you may use a template entity.

Maybe you can use a different value encoding than 4byte float on the KNX side?

Oh, and what HA version are you using? There have been changes to sanitize this a little back in May 2021 round DPT 14 values (#667) · XKNX/xknx@43f6116 · GitHub

I’m using version 7.1

I tried different value encoding as you mention, but then I wouldn’t get any value at all.
So this one is the only one working.
Picture from KNX

So, I can’t do it directly were I specify all my data tags? I need to use some kind of template entity as you mention?

Sorry, that doesn’t tell my anything. HA core versions have a Schema like 2021.9.x

Right. You can only use keys mentioned in the HA knx documentation. There is no support for direct templating or something alike.

I don’t know what I’m seeing in that picture - doesn’t look like ETS. You’d have to change the setting everywhere: your Gateway, ETS (probably) and HA.

Ahh… sorry… I was to quick… i was looking at the OS… and it said 7.1
The core version is 2021.12.10

The picture is not from ETS software, but from my KNX IP Gateway (Schneider HomeLynk, LSS100100, that now has the name Wiser i think).
All the values from my modbus doesn’t have anything to do with the ETS, since all of that is configured in the HomeLynk directly.

Thank you for helping!
I will se if I can fix it with the template entity you mentioned.


1 Like