Numpy errors for LG TV after updating to 104.2 and migrating to webostv

I’ve upgrade to 104.2. I’ve changed my LG tv configuration to:

    name: TV
        - livetv
        - youtube
        - netflix
        - BBC iPlayer
        - Amazon Prime Video

however on validating the config I get the following message:

Component error: webostv - 


Importing the numpy c-extensions failed.
- Try uninstalling and reinstalling numpy.
- If you have already done that, then:
  1. Check that you expected to use Python3.7 from "/home/pi/homeassistant/bin/python3",
     and that you have no directories in your PATH or PYTHONPATH that can
     interfere with the Python and numpy version "1.18.1" you're trying to use.
  2. If (1) looks fine, you can open a new issue at  Please include details on:
     - how you installed Python
     - how you installed numpy
     - your operating system
     - whether or not you have multiple versions of Python installed
     - if you built from source, your compiler versions and ideally a build log

- If you're working with a numpy git repository, try `git clean -xdf`
  (removes all files not under version control) and rebuild numpy.

Note: this error has many possible causes, so please don't comment on
an existing issue about this - open a new one instead.

Original error was: cannot open shared object file: No such file or directory

I’ve followed the advice and uninstalled // reinstalled numpy - showing as 1.18.1

HA running on Raspberry Pi 4; Python 3.7.3 in a virtual environment.

Additional note:

When in python in the venv it would seem that numpy isn’t working there - import numpy results in the same message. Anybody got a clue what the issue may be?

(Also I only have numpy in my venv - trying to import numpy in python from outside the venv then numpy isn’t found).

1 Like

Hi everyone, I have exactly the same issues, only difference e is HA running on Pi 3 | Buster image| venv Python 3.7.3. Tried installing / reinstalling, numpy will not work.

Looks like one needs this:

$ sudo apt install libatlas-base-dev


Thank you - that sorted it

Awesome, that did it. Thank you.

Does this integration not support multiple hosts anymore? It only cares about the first entry in the config…

I have the same problem above but your line of code didn’t do the trick. Still showing the text from the first post. Can you suggest what can it be?

By the way, I have another HA for testing purposes (hassio), then it the new config for the webostv works, but I also can’t get another LGTV. Interesting that it choose to configure the second entry in the config.

I found the solution for multiple hosts:

  - host:
    name: LGTV1
  - host:
    name: LGTV2

About the error, I could not found a solution yet…

HI. I also use HA ina VENV and having the same issue. I tryed the command informed bt “ktpx” but it didn’t work. By the way how did you uninstalled and installed numpy?

Before using the above command, my error was the same as yours (Original error was:, but after it has changed to:

Original error was: /lib/arm-linux-gnueabihf/ version `GLIBC_2.27' not found (required by /srv/homeassistant/lib/python3.7/site-packages/numpy/core/

Do you have any clue how to solve it?

I got it solved running the following command inside the VENV:

pip3 install numpy --no-cache-dir --force-reinstall --no-binary :all:

Solved in the meaning that I no longer get the error when checking config.
But after restarting HA, there is no entity to pair the WEBOSTV, so there is still something missing that now is hard to find since it is beyond my knowledge. Thanks to anyone that could help.

I also know that my configuration is correct, since I could pair the TV to another instance of HA (hassio) for testing purposes, but it is not used for production…

You can remove the old pairing by removing the webostv.conf file in your config directory, then when you restart, the pairing notification will show up again.

1 Like

Thanks for the tip. It worked. You started in the forum doing great. Congratulations!

I’m having the same issue:
lost my hass system and I rebuild it all.
I had the numpy error and installded libatlas-base-dev.
I removed the webostv.config file.
I reinstalled numpy.
The error:

Traceback (most recent call last):
  File "/home/pi/homeassistant/lib/python3.7/site-packages/homeassistant/", line 170, in _async_setup_component
    hass, processed_config
  File "/home/pi/homeassistant/lib/python3.7/site-packages/homeassistant/components/webostv/", line 97, in async_setup
    tasks = [async_setup_tv(hass, config, conf) for conf in config[DOMAIN]]
KeyError: 'webostv'

Still no change. Any ideas?

@yelti_be, I have the same error. Did you find out something about it? I am on latest 0.107.6 with python 3.8