ODROID N2+ - No USB devices are recognised

Hey Guys,

It seems that the USB stopped working on my Odroid N2+ (HA Blue).

Right now a cc2652r (zzh stick), a known good flash drive and a Wemos D1 with blink fw plugged into the USB. None of these devices seem to be powered. The dmesg log is attached after everything was plugged in.

Why is the USB power not reenabled?

HAOS: 7.1
Core: 2021.12.8
Supervisor: 2021.12.2

Any suggestions?

Thanks.

Anyone?
Thanks.

Same here, seems to have happened after a HA core update recently.

Although there is also seems to be a general ODROID N2+ USB issue

If they have worked before then this may not be useful but do attach USB devices via a USB extension cable of 1m or so. Directly plugged in devices sometimes don’t seat correctly as the case openings are narrow and also more importantly can suffer from RF interference which the cable distancing fixes.

My Blue USB devices are working still…

So, it seems that this is not a unique case.
Interesting, my suspicion was the same, that it happened after a Core/HAOS update, but I was just not sure whether I could tie the issue to it.

Today I reflashed the Odroid with an older release (HAOS 6.6) but it unfortunately automatically updated the Core version to the most recent during the first boot. So, I need to figure out how to downgrade manually.

I only had an old zigbee stick (cc2531) inserted in the USB port, when it stopped working. For a couple of days I thought that the stick died and ordered a new one (zzh stick). When I was setting up the new stick I realized that he problem is not with the stick, but with the USB port(s).

I tried with the extension cable, also without the housing of the Blue. Nothing helped.
To be honest, I dont think it is an interference issue, as the USB devices seem to not getting power. When I power on the board while the flash drive and an ESP with blink fw are connected, I can see that they are blinking for a couple of seconds, then they stop. They dont show up in the kernel log (same as above).

I can’t really can support with your problem. But I also have ODROID N2+ HW running. SSD and JeeLink using USB is running fine. BUT: I can’t finde a bluetooth dongle. Any recommendations for a known working device? Right now I do have a LogiLink BT0015.

I’m also surpiced, my dmesg doesn#t seem s to finde my 5V regulator:

There seems to be a know USB problem with die Odroid:

My main concern in the kernel log is this line:

[   31.710563] USB_PWR_EN: disabling

Would you mind using grep with the -i switch to make it case insensitive? I’m curious whether it is normal to have this log entry. (Probably not, as what I’m seeing is that the USB devices are not powered.)

I cant recommend any bluetooth devices. I use an ESP32 running ESPHome with ble tracker for my sensors.

Thank you for pointing to the reddit thread. It seems that I have exactly the same issue! pff

Hello,
ok I also tried ESPHome but only have the MiFlora sensors (sending Data every 20min or so…) the scanner findes MAC adresses. But I don’t receive data… therefore I touhgt using a BT dongle. But maybe my setup is not correct…

The USB problem of the ODROID also makes me worry about. right at the moment mine seems so working fine… but for the futhure… We will see.

Did anyone solve this? My usb-ports stopped working some time ago too and Ive been living in a dumb house since :cry:

The USB ports on my N2+ died too yesterday - any news on how to fix it?

I read that it’s just the USB power that’s not working - so I already tried to connect a powered hub - still nothing.
Tried to grab 5V from the pins (they work fine) and “inject” them into the USB plugs - not working…

so it seems to not be just a power issue - any ideas?!

USB ports still don’t work on N2+. :frowning:
Same EMMC module in an N2: USB works.
Unfortunately none of my wifi usb supported by the kernel.

How is this possible that this problem exists forever without any chance to fix it? I just bought the new SkyConnect-Stick, attached it with the included USB extension cable and: nothing.

The website says the Skyconnect stick to be plug & play. Home Assistant SkyConnect - Home Assistant No way. And there is no manual or other help available. Nowhere on the web.

Same issue here.
No USB at all at Odroid C2

Home Assistant 2023.1.7 Supervisor 2022.12.1 Operating System 9.4 Frontend 20230110.0 - latest

Obviously not working with damn extension cable :unamused: