Onvif setup trouble

I am trying to setup the new ONVIF integration in 0.110. I deleted my old camera config from config.yaml and added ffmpeg: the camera has username/password and onvif is enabled (works in Synology Surveillance station).

When I add the integration the camera is found but then I get “Could not configure unique ID for ONVIF device”.

Any ideas ?

This is a core integration, not third party. Moved.

Any luck? I’m getting the same message when adding the ONVIF integration. It sees the cameras but it either aborts or I get a Could not configure unique ID for ONVIF device message.

I get the same message. I don’t know if it’s my cameras or the software.

Mine are cheap $40 cameras…iSmartViewPro. They worked until the 0.110.0 update.

Getting the same error for cheap Wansview camera…

same error here

Mine is a Wansview too… Seems we have all the same problem. No solution yet I guess.

I have 3 onvif compatible cameras. All of them work (tested it using an iOS app). Two of my cameras are recognized by HA but one of them is throwing this error

This camera is not using a standard rtsp port (554) and the stream name/path is also a bit peculiar too. Any idea how one can further refine setup parameters?

Now working in HA version 0.110.4
They are the Shieldeye cameras from NewEgg
thank you!