OpenTherm Gateway (OTGW) stability issues

I’m using HomeAssistant with an OpenTherm gateway (classic version with Ser2USB-cable). It’s directly connected to my Raspy (I tried direct USB connection or via powered hub) and I’m facing stability issues.
Sometimes, the interface just stops working, the different monitor values are no longer updated. Sometimes I find some otgw-related Python-Errors in the Log, sometimes it just stops. Happens at least once a day.

Sometimes it helps to restart HomeAssistant, Sometimes I have to reboot the Raspy. The USB Port for the OTGW has been assigned a fixed name.

Is anybody facing similar issues? I had the OTGW running in Domoticz for ~3 years and never faced such problems…

I’m using the LAN version of OTGW:

I have a NodeMCU flashed with ESPEasy and configured Serial Server on it. I configured OTGW in HA as

device: socket://
name: Thermostaat
precision: 0.5
- room_temp

default: warn
homeassistant.components.opentherm_gw: debug

I find similar issues, it works for about an hour and I see frequent updates in the debug log. Changing the temp (room_setpoint_ovrd) sometimes works, other times it just switches back to the current temp. After an hour the updates stop, sensors don’t get updated and changing the temp results in a weird crash so that the option to change it is just removed. Restarting HA solves this.

I was in the imagination that using terminal over LAN wasn’t stable enough, though this works fine in Domoticz.

I’m having similar issues and filed an issue here.

Although not entirely consistent it seems I’m having best results using the dev version of homeassistant.

When the opentherm_gw component is succesfully running I’m having the additional issue that not all values are sent to influxdb although I did configure that. It seems as if the integers and boolean values are sent, but the floats not. Do you see the same?

UPDATE: I now see that I do get floats also influxdb. I don’t have the full overview, but temperatures are written under measurement name °C, i.e, not under their real name. Hence, it appears that naming is somehow mixed when sending it to influxdb. Seems that this worthy to create another issue. Does anybody have more insight?

Replying to myself: the entities are still easy to find in e.g. grafana, by first selecting the measurement with the appropriate unit, e.g. C and then adding a where clause to narrow down to the correct entity_id.

Same issues here.
New install, new OpenMCU, new OTGW.
Works at first, but then stops.
However: sometimes data is received.

I use the NodeShop version with a NodeMCU and ESPEasy R147 firmware.

I’ve had connectivity issues using the opentherm_gw integration too but using the otmonitor tool worked fine.

Therefore, I have created a Supervisor (formerly HassIO) add-on with Ingress support.

See this repository on GitHub.

Hi Bas

Was wondering how this is working as I have the same connectivity issues. What is wrong then with the open therm gateway from HA

I had the same problems like everyone else here. I figured it out.

  • Close otmonitor on your computer (if still running)
  • After enabling or disabling sensors, restart HA. Every time!

It works for me just fine with the HA integration, with this in mind.

Your tip worked for me. Thanks for that!

After enabling entities and adding them to a dashboard, I saw them being populated and a second later the values became unavailable or disappeared. Then a second later the values got a value again.
The issue disappeared after restarting Home Assistant.

Hi there,
I’m also experiencing troubles with OTGW some times but most of them were related to WiFi signal. My NodeMCU was connecting to the AP downstairs and this caused a lot of troubles. This can be a first diagnostic step for anyone.

I ended up developing a more reliable solution based on the fact the ESP8266 is much more than a serial bridge component.

My firmware for the MCU includes: native home assistant integration over MQTT, a REST API for all your needs, a stand alone WebUI in case you want that and most of all since v0.9.0 release it’s been extremely stable.

Hope you enjoy it like I do myself, any questions or ideas are always welcomed,


You can find my solution here:


Hi Robert,
That’s very interesting. I saw other projects doing the same ESP stuff but I was afraid that in case of a broken circuit I will end up with a broken line to the boiler. OTGW reference schematics offer some safety measures to pass the thermostat signal to the boiler as if OTGW didn’t exist (I think it’s a feature of the PIC chip as it’s normally open). so I can be sure I will have some of the heating in my house even if electronics go dead. Can you say anything about your solution?