Options for running HA OS as a VM

I’m pretty sure running a full VM of an entire OS is a lot heavier than running a docker container, that’s able to use the existing kernel, etc. That’s why Docker has taken off in popularity, it’s “lighter” than spinning up full VMs all the time.

it is a bit heavier ofcourse but in my experience its neglectable on the performance part, it just uses some more diskspace. Using a VM is easier for backup and restore or migration purposes than running docker with homeassistant on the physical host.

The VM in this case is so minimal however with less bloat than even Raspberry OS. Its main function is to host docker and talk to hardware. There’s nothing else there.


Thanks for the responses smootje / cogneato. Would running the VM under VirtualBox on Ubuntu 18.04 LTS be a decent option? I would imagine it would be much easier to configure than something that’s command line only.

Well if you like to have a GUI i would prefer proxmox VE for my setup because it’s stable, has good usb passtrough and is opensource but ESXi would be good too. I personally dont like virtualbox that much. I think we are getting a bit off topic sorry mods :slight_smile:

1 Like

I moved this chunk here because I did take the post off topic. :grimacing:

As many users seem to already have Ubuntu, I tried a KVM install for myself as a test. While you could use virtualbox, I was interested in trying something more “native” (not sure that’s correct).

Normally you would use the command line and virt/virsh but there is a GUI for this which is fairly similar to virtualbox called “virtual machine manager”. I installed it and gave that a try.

But before that, you want to create a bridge adapter which your VM will use for networking, and I followed the section from this page called “Creating a Network Bridge Using Nmcli in Ubuntu” for doing that with the nmcli commands: https://www.tecmint.com/create-network-bridge-in-ubuntu/.

I then deleted all of what I had configured and tried the “Creating a Network Bridge Using nm-connection-editor Tool” which is just a UI for the same thing and that worked fine too.


Thanks for writing this up, it’s greatly appreciated. This is probably the route I will be taking, as I can tell the Devs really don’t want to support Ubuntu, and at some point I anticipate my install will break.

Yes, we all know that, they told us months ago. And explained the reasons.

Not much of a write up…I mainly wanted to show that it isn’t too difficult. I could try something more substantial.

It’s not about want…The project is a system that has all the right parts to get the job done from the OS up, and Ubuntu does what’s best for Ubuntu.

This isn’t like developing an app for another OS which simply gets installed and uninstalled. There are many parts to keep in check. The original intent was to create a system that makes use of docker and gets flashed to specific SoC’s. That you could kind of copy the whole environment by installing it on other OS’s was more accident than plan. That was fine for a while, but then as different OS’s make different choices about what they include, and what versions of packages they use, it gets more chaotic.

And this recent docker issue had nothing to do with any of that. Debian, Ubuntu, whatever…every “supervised” user who updated docker to 20 did so because they could. That’s part of the risk of this install. It didn’t get updated in HA OS because it’s all one controlled system.


Yeah, I would imagine even people running the supported Buster probably had problems it they let their normal APT update routine include docker-ce. I totally get what you’re saying, it’s a lot to manage considering what all of the add-ons are capable of doing.

I have been running HA as a VM under Proxmox for a while now ( a couple years, I think) and it works great. I can take a snapshot prior to any updates and roll it back in seconds if something is badly broken. I recently noticed the “Unsupported version” message. I hope we see a HASSOS VM image soon. I tried Debian 10 and the " supervised-installer" script and most of the docker images go missing after reboot. I guess I stick with my VM running ubuntu for now.

There was a bug with docker 20.10 not fixed with 20.10.1 but you need to be running the beta supervisor.

Thanks David, where would I find the beta? I checked the git branches and did not see it.


In HA Select the Supervisor panel
Where mine says leave beta channel yours will say join beta channel
Then you will be able to update the supervisor

The HA OS images for VMs have been available for over a year? Maybe I am misunderstanding.