Orbit B-hyve component: Tap only runs for 5min

I have installed Orbit B-hyve component.

I have the following card:

type: horizontal-stack
cards:
  - type: vertical-stack
    cards:
      - show_name: true
        show_icon: true
        type: button
        tap_action:
          action: toggle
        entity: switch.smart_tap_1_zone
        name: 'Hydrangeas '
        show_state: false
      - type: gauge
        entity: sensor.smart_tap_1_battery_level
        name: Tap 1 battery level
  - type: vertical-stack
    cards:
      - show_name: true
        show_icon: true
        type: button
        tap_action:
          action: toggle
        entity: switch.smart_tap_2_zone
        name: Tap 2
      - type: gauge
        entity: sensor.smart_tap_2_battery_level
        name: Tap 2 battery level

When I toggle the taps on, they only stay on for 5min. They should stay on until I toggle them off. The other point I need to make is that the button automatically toggles off i.e. the tap does not just stop running but rather the button switches off.

I have no other automations running on the Orbit B-hyve taps so not sure how to troubleshoot.

Settings in the Bhyve app will override everything. Look in there to see if there is a 5 minute limit set.

I don’t use the APP but will install it now and check

Installed and logged on to the App and nothing is set there i.e. no programmes and the only limit was 10min. I have however disabled any setting that had the option of AUTO in and now when I tired it seems to run just fine.

In the app, when you select “Water Manually” it brings up a screen to set the amount of time. Whatever that is set to, it will use that when you activate in Home Assistant.

1 Like

I have this problem as well and have not been able to fix it. Any suggestions would be much appreciated.

What I’ve done so far:

  1. Changed the mode inside the B-hyve app from “auto” to “off”
  2. Set the manual watering program time in the app to 10 minutes.
  3. When I look at the “manual_preset_runtime” attribute inside home assistant, it is set for 300 seconds (5 minutes) - see screenshot.

Hi, for me it was that the App was overriding Homeassistant i.e. Home Assistant would not run longer than the manual time set there. I changed it to a time longer than any Home Assistant automations, and it worked.

I have the Orbit B-hyve Smart Indoor/Outdoor Irrigation Controller
The only way I could get this to bypass the 5 minute issue was to create in the B-Hyve App Watering Programs (A, B etc.) Dont worry about the time but do set a time, set up for each zone you want to run as part of the program and the duration.
In the App Goto My B-hyve > Devices > ‘Your Irrigation Controller’ > Set ‘Timer Run Mode’ = Off
In HA use a Service Call: Orbit B-hyve: Start program and ‘Select your Program’
This will then run the program in its entirety.