Our Google Assistant skill is live!


#21

Excellent work and congratulations to all


#22

Fun stuff!

Interesting that the command for my garage door is “turn on the garage door”, not “open the garage door”

I look forward to watching these skills develop.


#23

Just define a shortcut in Google Assistant for ‘open the garage door’ and make that call ‘turn on the garage door’


#24

Having a strange issue linking my hass.io account. It worked on initial setup, then I realized I wanted to hide groups and a few other entities so I edited my config restarted Hass.io and then unlinked the hass.io skill from my Google Home app - I did this because the changes in my config didnt seem to make a change to the amount of devices shown… immediately.
Now when I try to relink, it gives a toast message saying that it successfully linked but none of my devices show up and if I go to the manage accounts tab nothing shows under linked accounts…


#25


it seems there’s a separate config for the “google actions”


#26

Great work on this, works great!

Is there currently a way to resync the changes or do we simply unlink/relink?


#27

0.68 will bring a sync button to the cloud config panel. For now, you can trigger a sync by making a POST to /api/cloud/google_actions/sync.


#28

or… Hey Google Sync My Devices


#29

Thank you so much.


#30

Hello,
is there any way to specify “expose_by_default: false” like it is possible with ‘old’ Google Assistant?
Thank you.


#31

I’ve been running the Google Assistant config without the Home Assistant Cloud before (with all the Google API settings and the port forwarding and whatnot), and tried to add the hass.io skill in Google Home now, but it just says “Couldn’t update the setting. Check your connection” when I try and add it.

I’ve activated and logged into the Home Assistant Cloud, but I’ve made no changes to the HASS config otherwise, which means that the “old” config for Google Assistant is still in the configuration.yaml.


#32

I’m in NL, the hass.io skill only appears in my Google Home app on my phone. The link in the blogpost is a 404.


#33

That is correct, it was mentioned in the blog post:

Install our skill for Google Assistant. As of this writing, the link is not live yet: you can find it by opening the Google Home app


#34

I removed all of the config I did and waited overnight to try to re-add… still doesn’t work. Ideas? No errors in Hassio and Cloud states its connected.

Edit: it started working after removing cloud in my config and restarting then re-adding.


#35

Overr, I had the same problem as you.
So I commented out all the google assistant code, rebooted and tried everything again - it works now.

I have 2 Echo Dot units and 1 Google Home Mini & still haven’t figured out how to get both operating & limited to certain devices using configuration. Also can’t yet see how to have Google turn off everything in my office though my Alexa can do it with groups.


#36

I’m able to search for HASS.io but when I click on it, it opens a page with no data on it. I’m assuming geo-restriction?


#37

I did the same thing, and can’t relink. I posted about it, but I have yet to find anyone who can assist.


#38

@DPB61 So, I tried that before, even though I didn’t reboot, just restarted HASS.

So, as I understand it, you don’t need any google_assistant configuration in the yaml before creating/linking the skill in the Google Home app?


#39

That did the trick!! Thanks!!


#40

238 device found,…cool… shame the google home app is very cluncky to edit the rooms