Our Google Assistant skill is live!


#41

Is there a way to expose sensor data to google assistant? For example a temperature or humidity sensor.


#42

Changes to the config (which entities to include/exclude) require a reboot in order to translate to Google Assistant?


#43

In the include/exclude_domains, what is the order of precedence? If you use include, does it automatically assume exclude everything else? The current docs and examples are not helpful in this regard.


#44

Not yet, at least not so easily, as there are no Google skills supporting that for now.


#45

You can define the rooms in the yaml file now.eg:

  scene.bedtime:
    room: bedroom
  scene.dining_daylight:
    room: dining room
  scene.dining_normal:
    room: dining room
  scene.dining_warm:
    room: dining room


#46

I’m getting the same thing. I’ve removed the cloud config from HASS, removed the .cloud folder, restarted, stopped, added the cloud config, restarted again, logged in successfully via the configuration panel, restarted HASS again, still getting the error.

Surely somebody must be able to help fix this?


#47

Well, if you get rid of the previous configuration, that gets rid of the error we were having & allows you to link the skill.

Once that is done then I am hoping the configuration can get put back - I didn’t have time to test that last night.


#49

I tried removing all the cloud config, all the google_assistant config, restarting HASS and then trying to add the skill in the app again, no success… :frowning:

I’m stomped about this one. I just can’t get it to work. Are there any logs or diagnostics that can be looked at?


#50

So, I created a topic in the forums about this, since it seems that several others have similar issues.


#51

Initially the blog post referenced Home Assistant 0.65 as the minimum version. This should have been 0.65.6. Make sure you run at least this version.


#52

I’m wondering the same thing.

balloob says:

POST to /api/cloud/google_actions/sync

But I can’t get the POST to work, keeps saying “405: Method Not Allowed”


#53

Hmmm… I used to have the custom component working before, but after installing this skill as soon as I tell Google Home “turn on kitchen” it replies with “Sorry power controls is not yet supported”…

Any idea how to solve this?


#54

For those who can’t find the Google Home option for Google Assistant, check this https://youtu.be/Bnpb5auA5uI


#55

unfortunetly I unlink the manual one, I was able to link to hassio but when I give a command it takes ages to reply and simply does nothing. Anything else I should´ve done?


#56

and adding to this all my switches stopped working don´t know why


#57

What did you add? Did you run a configuration check?


#58

just added cloud as instructed, made an account, linked and everything went down


#59

That does not appear to work with the new Google Assistant skill.


#60

Hmm It seems from https://www.home-assistant.io/cloud/google_assistant/ that it’s not an option there yet… Coming soon is my guess.


#61

Its Working smoother than dialogflow :sunglasses: