Our Google Assistant skill is live!


#62

hi, i’m getting “Couldn’t update the setting. Check your connection” error.
I’ve in HASS the google cloud connected, but when i try to add device from my android smartphone hass.io, and click allow access always says that error.
I’ve tried to clear cloud config, restart, add cloud config again and restart, and get same error.

Update: i make it, i think i’ve created 2 users because cloud register form is case sensitive in user email field.


#63

Looks like some one is on it!


#64

Just my 2 cents worth about the “Couldn’t update the setting. Check your connection” issue, I experienced the same problem when I just had the “cloud:” in my config but once I added these I could link so I suspect exposing too many domains was my issue (I’ve got lots of things going on in my HASS), I’m just manually adding the switches/lamps/scripts etc that I want to use with the Google Home now.

  google_actions:
    filter:
      include_entities:
        - switch.example_here

#65

I’had same problem. Check if you have created two users in cloud, thats was my problem because is case sensitive and in hass i was using lowercase user and in my phone i was using capitalized one, both users with the same emai address. I figured out changing the password in lowercase account and in the capitalized one still login with the old password.


#66

Great!!! I Just bought 2 wink relays for my new home and a ring doorbell 2. This Will save me some money!!!


#67

That did it. I had a capital at the start of the address in Google Home. Changed it to lower to match my hass setup and it worked. Nice catch!


#68

Awesome work guys, great job. I do notcie that HomeAssistant is not passing device icons through to Google Home app, is this a known issue or just me?

@jcollie you mention that you can add room names to included entities, where is this configured, in the cloud section or the devices config?


#69

Hi!
Is anyone outside the Google Home speakers officially supported countries being able to get the Hass.io skill to work?
I’m trying from my Android phone; first the Home Automation category didn’t even show up, I’ve had to change my phone language to English US to be able to see this category in the app settings.
Now I am able to search for the Hass.io skill but when I get inside I cannot see the ususal “set up” button, in fact most of the content is missing.

Am I doing something wrong or is there a general problem with it?


#70

@BodgeIT in fact I mentioned that it is not currently possible with the cloud component. It will be possible in the near future when the pull request that I linked to has been merged and released.


#71

I don’t see hass.io too. Even in anonymous tab with US VPN up, https://assistant.google.com/explore/search?q=hass.io&hl=en doesn’t return anything.


#72

I’m living in an unsupported area but it works fine for me.


#73

The link isn’t live yet. You need to do it in Google Home on your phone. Go to the Home Control settings and press the + button and click on hass.io in that list.
And when you sign in make sure the email address starts with a lower case.


#74

Has anyone linked up their vacuum to it yet? Can you say pause vacuum or stop vacuum? Google home just replies with ‘an unspecified error has occurred with 2 scenes.’

Also, is there a way to see what ‘traits’/available commands get sent to Google for each device?
eg. https://developers.google.com/actions/smarthome/guides/


#75

Thanks a lot! Works perfectly. Added hass.io using Google account from a non-supported country.


#76

Can you create a custom command? I can get my Sonos media player to turn on/off but I cant get it to change the “Source” (Station)… or I want to tell my google assistant to tell Home Assistant to Arm my alarm that I already have linked to my home assistant.


#77

How to control Volumio playback? Name for my Volumio is “media player”, turn on media player doesn’t work. Should I write a script to call a media_player.play_media service and than tell google to fire that script?


#78

But don’t you need to tell the commands in English?


#80

thanks, Just managed to link Hass.io, finally! I have to say that the Google assistant menu structure is not the most intuitive one…And yes, you have to talk to it in English, I have not found a way around that yet for home automation stuff…


#81

Just an FYI:

Maybe I am doing it wrong but a note anyway.

I had an old botched integration of "google assistant “old version config” aka: https://www.home-assistant.io/components/google_assistant/

Now I started from scratch deleted all my projects from that part. But here is the thing.

After I connect with my “Home-assistant cloud account” it sees my chromecasts (and responds to it) but not the rest. I cannot link the new skill. And it keeps telling me it cannot reach my home-assistant install.

The pointer here is what google assistant on my phone keeps telling me. Him / / Her / It refers to that botched install / project name.

After some investigation it turn out it takes 30 days to delete old projects but apparently it keeps it (semi) active.

I do not know if I explained this right happy to answer any questions you might have. I guess I have to wait 30 days and try again damn it :wink:


All of the above is mute!

This does NOT I repeat NOT work with the “google service” app if you are signed up for th so called beta program in google play store

Here is where you need to go if you are: https://developers.google.com/android/guides/beta-program


#82

I am unable to get my Automations to show in the Home Control settings for GA.

I’ve added two automatons under included_entities and restarted Hass.io and they dont appear, is this by design?

heres my code:
cloud:
google_actions:
filter:
  exclude_domains:
    - media_player
    - binary_sensor
    - input_boolean
    - group
  exclude_entities:
    - group.all_devices
    - group.custom_group_for_lights
    - group.all_switches
    - group.all_scripts
    - group.bedroom_view
    - group.bedroom
    - group.kitchen
    - group.kitchen_view
    - group.loft
    - group.loft_view
    - group.default_view
    - group.living_room
    - group.living_view
    - group.ring
    - group.main
    - group.harmony
    - group.front_door
  include_entities:
    - automation.445am
    - automation.7am

Thanks!