Owlet Setup?

Does anyone have Owlet setup properly? I set my config per the docs, with my email as the username and my password, but I am getting a authentication failure on startup.

I’m having the same issue. Have you made any lead way?

No, I have tried every combination I can think of (with quotes, without quotes, single quote). Seems like the component doesn’t work, which is strange given how new it is

Did you chaps get anywhere with this? Just got mine and tried setting it up and receive authentication error. Annoying since the compatibility was a key driver for the purchase!

No, I was chatting with the develop of the component and he said that he thinks that owlet broke the unofficial api that he was using, and he hasn’t had time to look into it. I tried running pyowlet, which the component appears to be based on, and I got an authentication error regarding an access token. So not sure if there is an additional parameter that needs to be added. That said, in general, I’m none plussed about owlet in general. I would return it, but my wife wants the tech (now that’s a change of pace! haha)

Please move discussion to https://github.com/home-assistant/home-assistant/issues/25962 - thanks :slight_smile:

I emailed the owner of pyowlet to ask them to bump it to 1.0.3 and include the updates URLs.
Assuming that is the least amount of work to change?

great news the developer is responsive and has updated the github repo to the new URLs

and pypi is now 1.0.3 https://pypi.org/project/pyowlet/#history

UPDATE – just tested with PyOwlet==1.0.3 and have pushed an update to the version in HA.

Not sure when it will get added to HA, but if you want it to work now edit the file manifest.json. Just need to change 1.0.2 to 1.0.3 as below:

  "domain": "owlet",
  "name": "Owlet",
  "documentation": "https://www.home-assistant.io/components/owlet",
  "requirements": [
  "dependencies": [],
  "codeowners": [

Where did you get the manifest.json from?

if you dont have system access youll want to copy the entire directory that this file is in owlet and run it as a custom component after you update the manifest accordingly

1 Like

Thanks! I’ll give it a go

Could you check on the HA repo code changes? I’m not 100% I completed the process properly?

you did not commit the second file actually, its only a merge it seems. You can try opening/closing the PR but if the CI still fails you’ll want to resubmit a new PR following the instructions on the dev site.

https://developers.home-assistant.io/docs/en/development_checklist.html (second bullet point)

1 Like

I have to set up a complete dev environment just to generate requirements_all.txt

Its only 1 line that has changed? I went in to ammend the requirements_all.txt - so what’s happening here? is it down to the all_requirements.txt wasnt changed first? Or they are not somehow linked together in a single dependant change (this devops process is quite new to me, but found a fix to a broken component so wanted to help out)

oh, it seems i can do that manually, BUT I had to commit the change to the all_requirements.txt to the same PR.

Is there still an authentication error? I just tried setting up my Owlet today and found this thread when I was unable to get the integration working.

I think it was updated and was working, but they may have changed the API…not sure. We stopped using the owlet a month or so ago

I am still having issues setting up the integration:
i have tried resetting my password several times, I am able to login to the ios app without any issues but still getting errors in HA
Setup failed for owlet: Integration failed to initialize: (see below)

11:55 AM setup.py (ERROR)

Owlet authentication failed. Please verify your credentials are correct

11:55 AM components/owlet/init.py (ERROR)

2020-02-03 11:55:19 ERROR (SyncWorker_4) [homeassistant.components.owlet] Owlet authentication failed. Please verify your credentials are correct 2020-02-03 11:55:19 ERROR (MainThread) [homeassistant.setup] Setup failed for owlet: Integration failed to initialize.

The API was removed by Owlet, thus this no longer works. Looks like the component was removed in 0.105