Owntracks position not showing on home assistant map

ok. i actually had this working before i had to rebuild my installation from scratch because of being locked out of access. i have managed to get owntracks up and running fine on my iphone. Using httpni can not seem to get my map on home assistant to show my iphone location other then by mobile appi have copies the url from the ha intergration but still no update heck no initial
i have a entry for owntracks in configuration.yaml

max_gps: 200
waypoints : true
waypoints _whitelist:

i have no other device trackers in configuration.yaml

any thoughts?

Does Owntracks have to be included in known devices to work?? Just a thougfht

i see that know devices are deprecated…Been at this a week with no luck.

I know I am pretty much talking to myself. but…
the guides all appear to deprecated by HA “updates”. (for example the discussion on incline ownmtracks in know_devices.yaml
I have deleted the owntracks app and the integration the reinstalled both. The iOS app works great. appears to talk to HA (not sure which. log is supposed to record that). but nothing shows on HA map

no idea I keep muddling on

i am facing a similar issue with devices reporting in the app via the hooks, but not showing up in the map or as entities. Bumping this in case anyone else sees this.

Stil see issue I jm pretty much ignoring HA map. OT map is fine nd the other features make it great I have other thing to play with before I worry about the HA map

still the same

been a month still no luck.

Ok got it. http://iot.bluecomtech.com/archives/45. One of the many older tutorials but if you to the discussion on regions it actually works… I am using the HTTP push. and a couple of things are important in its… First and foremost… (well actually its pure logic). You have the to publish the regions manually from Own Trackis in the settings… I kind of understood this. The more important part is that this inflation is. volatile. If you restart HA the regions it learned go away… oooops. That was what was happening to me. You have publish the regions/waypoint from Own Tracks to HA AGAIN… Did this and all is good.

Those were the days. for some reason I am back to start (which is not unusual for me an HA). OT works great … Publish my little heart out and nothing shows on HA Map. I even created a view just for it.

I think this issue could be because I have no device trackers associated with Owntracks, for example in

  • device_tracker.niclas_iphone is shown.

I have nothing like that so I presume owntracks and HA aren’t communicating

(BTW. HA OS 10.5. Core 2023.10.0 runing on Linux VM)

OK. back to basic I told removed Owntracks from Home assistant and my iPhone. I reinstalled and using text editors made sure I copy the exact web hook and secret code and owntracks is now showing on map. Too bad I had to lose all my saved OT wevepoints but hey its back!! (still no assoicated device trackers )

ok I broke its and had to fix it an this worked again. twice is pretty darn good