Partial no internet on HASS proxmox after HASS OS update

Hi guys, i did the update of hass OS and after that no internet connection.

supervisor_internet = true
host_internet = false

I did nothing else, no config change or whatever, just updated both of my homeassistant OS to the last version.
Now i cant do any updates anymore, but the supervisor internet just works fine.

There has been changed nothing, just happened after that specific update.

Can anyone tell me what to do?


On the host try: systemctl restart networking

Just did, still no effect.

just kinda weird, i only updated both systems to last HASS OS version.

Did you try rebooting the Proxmox host? The problem still might be unrelated to the HA upgrade even though it seems so.

Not yet, i will do that in a bit.

Im now shutdown the container and restarting, after i did the systemctl restart networking on the proxmox shell command.

if that doesnt work, i will restart the host fully and see.

But just weird that this happens just after a update of HASS OS, that should not be happening.

I can just connect homeassistant from outside my network etc, and i can just ping for example
just not updating any updates.

I did update to 10.5 before that everything worked normal

The proxmox whole server just rebooted, still not working
supervisor_internet = true
host_internet = false

Do you have a snapshot or backup of the HA VM? I usually do a snapshot before upgrading so that I could convert back to the previous version.

BTW: I have HA OS 10.5 running fine on Promox 8.

I’m not a fan of restoring.
i will lose a lot of data.

as it only backups at 0:00

maybe there is a way to downgrade hass os ?
i did open a case on github homeassistant OS, maybe agners can help me out without using a backup.
as really everything works, except doing updates, but also new updates showing up too.

well if u have HA OS running on proxmox 8 than its maybe something else…

Its still weird,

what i can do:

  • hass cli i can just ping normal
  • connect to homeassistant from outside
  • all plugins working and connected to internet

What i cant:

  • updating any pugin or download

Maybe its a firewall problem?

not at all,

i did try a test and it works, but its a temp fix

ha jobs options --ignore-conditions internet_host

and it updates now :slight_smile:
but still whats the problem ?

any particular reason why your ipv4 only shows -10 and your gateway 10. , you do know it’s local addresses so we all have them, and hardly noone can do anything knowing which one you Chooses , meaning no point in hiding them ( if tha’s what you did) it only cause a question/thoughts like this, because obviously it’s not suppose to look like that.
And another thing, your ipv4 name-server, i know some people, for some reason like google and cloudflare , im doing fine with my Router, for internal name-resolving, and rely on my IP-Provider for external resolving.
How does your HA dns settings look like ?, if “fallback: true”, try set “false” AND if locals is maybe try to point it to your Routers lan IP
Again, i know many people for some reason using external nameservers for local addresse ( For some unknown reason, in my head) As one can set in the Routers which External NS one want to use, if not using the defaults the IP-provider serves you with ( Fore external traffic)
Why go “outside” for internal traffic/resolving ?, that’s just asking for problems/latency/etc

Thanks for your reply

I use my local ip and not my external ip, i did hide it just because i want it.

I did do none with my router nor did i update anything, besides to 10.5
Im running pfsense and all dns is handled normal and when no dns is resolved it falls back to another one.

I did double check all dns servers are all online and working.
The dns servers i use are ssl, never had problems with it.

I also checked if my system was healthy and it is, i posted it here

My ha uses a static ip, but does not run over the dns i just mentioned, just the isp dns or or if it fails.

I could understand if i did work on my router or my isp did an update or my routers or whatever did a restart that it could fail, but none of that happened, it started after the update.

So when this all happened i did restarts pfsense, did restart the proxmox host and did restart the container, all nothing.

for now i did the above step to update home assistant, and it worked.

try “net reload” just to check if if change to host-internet true, othervice it sounds like you maybe have a “ban” in “Some” of your DNS’s (or maybe in Proxmox OS)

yep did that too, also i even did create a new entry in my firewall to specifically use hass system dns and still doesnt work.

here the rest of my config

this setup has been there for about 6 months, never had problems at all

i would look for “ban” of 172.30.30.x

where can i look that up ?