Pausing/Resuming Rachio Irrigation Controller due to low water pressure

Hello to all. Been reading a lot on home assistant and have finally installed and started adding devices I have around my home. One particular area where I would greatly appreciate some assistance would be with my limited well water and irrigating my lawn with my Rachio controller. Our neighborhood has a limited supply of well water, especially this time of year in Texas, and I’m hoping to find a way to pause or delay the irrigation schedule until a certain water well pressure level is obtained/restored. I was looking at a few posts which talked about the Rachio and a few others which talked about the Flo by Moen system. In the Rachio integration, I only saw documentation about binary sensors and switching of schedules. Frankly, I’m at an intellectual dead end on how best to implement what I’m trying to accomplish. I was at a dead end with Rachio support as they kept pushing me toward IFTT, but that didn’t seem to help either. Any and all thoughts or guidance is appreciated, I’m happy to continue researching on my own, but was hoping those in the forum that were much smarter than me could point me in the right direction. Thanks to all in advance for any and all guidance.

I can really only speak to the Rachio side of your problem, hopefully someone else chimes in with some advice on the pressure switch. It seems do-able just not sure the best way to implement.

Right now the Rachio HA integration doesn’t support zone pause or resume, but it is part of their API so it would be something that we could look at adding in the future. I think that would be what your looking for once you find a pressure switch solution to integrate. Again sorry I’m not much help on that front.

1 Like

That would be wonderful! I did see some documentation from the CTO regarding it being in the API. If there would be anyway in the future it could be added, it would certainly make my watering schedule much more simple that what it is currently, appreciate it!!

Just to make sure, your talking about wanting to pause a currently running schedule and later resume, not delay or skip a schedule, correct?

Yes, that is absolutely correct. My well cannot sustain more than about 15 minutes or so of watering time. This is even variable due to the fact that I have other neighbors who may be watering at the same time and/or dependent on the amount of rain we have had and how charged our aquifer is. In a perfect world, my Rachio would know exactly how much water needs to be put down, but currently there is no way to send a command to it to “pause” its currently running schedule until water pressure returns. Example: Through the RACHIO Flex Daily schedule, it knows how much water I need to lay down. Let’s say a zone needs 45 minutes of watering on a particular day, however my well can only support 15 minutes of run time without recharging. With the appropriate sensor running in tandem it would “detect” low well pressure and pause the schedule either for a fixed amount of time (say 30 minutes) or it would resume when the pressure had returned to a certain level which would again support watering. The 15 minute runtime could vary greatly depending on time of year and how much water my neighbors are using at the time the Rachio is time to water. Ultimately, the Rachio flex daily amount of water would be laid down, but over a period of time as determined by available water in the well. Talking with Rachio support on this initially, we looked at several options, but the primary assumption that Rachio makes in their programming is that you have an unlimited supply of water with no need to recharge a well. They have the ability to do a manual cycle/soak, but this limits what you can do on a schedule and practically forced a user to use the fixed schedule. The way I am getting around this currently is I am using 16 schedules, 1 per zone with a manual cycle soak time of 15 minute watering with a 30 minute recharge. This is a very conservative schedule and take much longer (I water about 12 hours per day every day of the week, 2-3 zones per day), but it also better ensures I have the water availability to do so. A more efficient solution would be as I’m hoping, which is to run a flex daily schedule which is dynamic in its application based on water availability. Probably way more of an explanation than needed, but the short answer is YES, I would like the ability to pause and resume and running schedule based on water availability (in this case measured by water pressure in my well tank).

Hope that all makes sense and thanks again for your assistance!

Yeah I think it would be doable, assuming you don’t have a gen 1 controller, which I just learned doesn’t support pause (which is what I have)…When I get around to working on adding it to HA I might need some help with the testing.

gotcha, I am more than happy to assist in any way that I can. I have two Gen 3’s. Sounds like time to upgrade!

I think I’ve got something that works for pause/resume, but I’m waiting on the dependency to be upgraded to support it. Hopefully that’ll be soon.

thank you sir! Looking forward to assisting in testing… Let me know how I can help.

This should be good to test if you’d like. Couple options to install:

If you don’t have one already, create a custom_components folder in your config folder and place the rachio folder inside that and restart.

Other option would be find the current rachio folder in the hass installation and replace it with the new rachio folder.

Once you get it installed you should have a couple new services under the rachio domain. The instructions should show up on that page as well. Let me know if you have questions.

awesome, I’ll give it a try and report back results.


ok, need a little guidance. Here is what I’ve done.

  1. Create custom_components folder in my root home assistant folder (the one with configuration.yaml in it)
  2. Downloaded rachio folder from the above GitHub link.
  3. Restarted HomeAssistant (via Docker command)

HA reboots successfully, but I don’t see any addtional items.

Where am I going wrong?


Do you have a warning in your logs about using the rachio custom component? You might need to view the full log, but it should be at or near the top.

yup, see below from log upon restart.

2020-09-10 12:50:18 WARNING (MainThread) [homeassistant.loader] You are using a custom integration for rachio which has not been tested by Home Assistant. This component might cause stability problems, be sure to disable it if you experience issues with Home Assistant.

Good deal.

Nothing under Developer Tools>Services>rachio.pause_watering and rachio.resume_watering?

not that I am seeing, here is a screen shot of what I do see at that location.

Interesting…Do you use any Flex daily schedules? Not really related but if you do there should be a couple other services in this new version as well, but they wouldn’t be there if you dont use flex daily.

I added a new repo with just the rachio folder and added some extra logging to see if we can tell whats going on. If you want to try loading this new version and see what happens…

wonderful, will download and report back. I do NOT currently use flex daily, but if I’m successful in getting this to work, my plan is to switch to flex daily in lieu of manual schedules ( this is currently the only way I can keep my well from over-drawing water).

thanks again for your persistence in helping me with my issue.

Now getting this when restarting HA.


However, on a positive note, I am now seeing rachio.pause_watering and rachio-resume_watering.

I’ll take that as progress!