Person tracking no longer working

My Person tracking for myself and partner had been working perfectly fine for a long time but sometime late last year it stopped.

Now I have a supposed location at home (despite HA saying I’m ‘not_home’) as well as a geo-located position at work, where I actually am. Previously my ‘Person’ entity showed me at my work location on the map whereas now I have both the normal ‘Person’ shown at home (but again, listed as not_home) and he geo Person at the work location.

My girlfriend shows as not_home and here Person entity is in a location she was at back in December. We both use the Android HA app with location services enabled. Her geo location is correct, just not the Person entity and I can’t see how to add the geo-location as a tracker to her Person entity. Since her phone is already added this should just work.

Any ideas?

Do they react on a command message to update position?

Do you mean this:

service: homeassistant.update_entity
data: {}
  entity_id: person.dave

… no change to the map. It still shows my Person entity in the home location, albeit not_home and my geo-location in the work location… and we are talking thousands of kilometers apart!

I’ve been in that work location for 3 days now.

think It in the Phone

have you turn on/off the location sensor ??

No, as I stated in the first post, location settings are on for both phones. This all worked fine until late last year. My geo-located position (from my phone via the HA app) is accurate to my current location.

Are you sure that you don’t have a person defined elsewhere that has gotten latched into the home location for some reason?

Maybe there is an old yaml configured person entity still hanging around?

Nope, there are only two person entities:

Have you tried deleting all “person” entities and add them back in after a reboot?

I’ll give it a try

Deleted the ‘Person’ entities, rebooted, re-created the ‘Person’ entities with the corresponding devices for tracking (each persons phone as tracked from the HA app)… same result

I’m away:

Yet my ‘Person’ is in the home location on the map (same location it has been stuck on for months):

Then there is also a ‘Dave geo-location’ at my work location some thousands of kilometers from home (where I have been for days):

My girlfriends map location is also still stuck on a location she was in months ago.

Also of note: I can’t re-sselect the option for each ‘Person’ to login as it was previously:

…because it gives me the error that the user already exists, which it does on the ‘users’ page. Seems a bit backwards that it can’t just link the two together. Ie: create a ‘Person’ from a ‘user’.


You send a notification to the phone and it should enable GPS and update the position.
Sometimes I have to send a few for it to work.

That’s only an iOS service call. I’m on Android.

I’m pretty sure it’s both.

But you said that the location as reported by both phones via apps are correct?

If so I’m not sure it will help.

The companion docs only say iOS and the service call doesn’t exist in my dev panel.

Strangely my Person location has just updated to a location I was in an hour ago, geo-location has current (different) location, but my girlfriends is still months old.

the icons below indicate android too


the service call is “service: notify.mobile_app_<your_device_id_here>”. I’m surprised that you wouldn’t have that since it gets setup for every mobile app automatically as far as I know.

Did you try asking in the discord # android? That were very helpful to me there.

Hmm, that’s weird. On my work PC I couldn’t see the Android icon but now on my laptop it’s certainly there :man_shrugging:

Ok, it’s been a long day. I misread the instructions. I’ll try now

Discord has rarely been good for me due to the timezone I’m in. There’s generally very little activity and then if my question is answered, it’s a pain to hunt through hours of conversation to find it

it’s the first option: “notify.mobile_app_dave_s20”

edit: just noticed your edit…

Yep, I just edited the above as I realised my 12 hour work day has fried my ability to read the instructions.

1 Like

I sent the request but the location of the person entity hasn’t changed. As before, the geo-location is correct