Phillips Hue Lamp randomly turns on and off (deconz-Integration)


I am using a ConBee II to control a Philips Hue White E27 and other things.

Approx. once a day there is a time-frame from 5-15 minutes where the light turns off and on without any reason. The time between the on and off-cyclus jitters and is between 2 and 30 seconds.

I double checked my configuration. There is no automation or manually user action involved.

Beside the Phillips Hue bulb there are several Xiaomi Aqara sensors, a OSRAM Smart Plug adapter and a Phillips Hue Dimmer connected to the zigbee network. As far as I can say there are no issues with them so far. And no, I didn’t sat on the Phillips Hue Dimmer by accident ;-).

The behaviour stops without any further action and reappears after hours or days.

  • Listening to “deconz_event” in the developer section during that time-frame shows no results.
  • Disconnecting the ConBee II during that time-frame stops the behaviour immediately.
  • There is nothing shown in the history in Home Assistant (e.g. Home Assisant opionion is that the state of the light never changed).
  • I read of a effect where the Phillips Hue bulbs are flashing very quicky if their self-diagnostics failed but the flashing behaviour in my case is different.

Anyone maybe has a point in the right direction how to troubleshoot that error?

Home Assistant Core 2020.12.2
deconz Integration: 6.6.2
Phoscon: 2.07.01 / 8.12.2020
Gateway: 26660700

Hope I will get that problem sorted out very soon.


First thing I’d do is update the ConBee II firmware (0x26680700) and the deconz software (2.09) and then see if the problem persists.

Not exactly your problem, but I tried Ikea and Cree bulbs on a Hue 2 hub with other Hue lights and at random times the Ikea and Cree bulbs would flash for a second or two. I made sure all devices were at latest firmware. I never solved, ended up removing all non-Hue stuff from Hue network.

Thanks for your answers. In my opinion all modules are on the lastest version? I use the deconz-Integration of Home Assistant. The Phoscon module says the firmware is on the latest version as well.

As I didn’t had the effect a couple of weeks ago with the same hardware setup I wonder if there is a way to downgrade…

No they are not,the lates deconz version is 2.09. Are you using the add-on?

Deconz is currently running under the supervisor and I installed it via the Add-On Store. There is no update available. Latest version seems to be 6.6.2.

I noticed you can run Deconz via the “Integrations” and it seems like it’s running natively on the system in this case. Installing it via the add-on store means it’s running as a docker container being maintained by the community and there is always a delay after the manufacturer published updates.

  • What’s the best practice over here? Using the “integration” or the “add-on”?
  • Maybe downgrading the deconz add-on will solve the issue for now. Is it possible to downgrade to an old version of the add-on?

You mixed it up a bit. The deconz integration is used to connect Home Assistant and deconz.

Deconz can either be run:

  1. As a “normal” software package on linux
  2. As a docker container
  3. As an add-on (actually add-ons are also docker containers, just configured in a special way to fit into the HA ecosystem).

Number 1 is like the base software and it’s where the development happens. Number 2 just “dockerizes” the application, and is mostly up-to-date pretty fast (few hours after a new version has been released). Number 3 is always lagging, because when a new version is available there may be some things that need to be changed in order that it works smooth again with the HA ecosystem.

Problem is you can only run number 3 with Home Assistant OS, unless you run deconz and the stick on a separate machine.
Personally I run number 2 on a separate machine.
I don’t know anything about downgradinf add-ons unfortunately.

Ah, thank you. I know understand the architecture better.

Regarding my flashing I will observe the effect a bit longer to gather more information.

Why it is not possible to run 2) on the same machine? I installed HomeAssitant via ssh and I could run a deconz-container in parallel? Is there any showstopper waiting for me here?

Thank you so far.

Are you running it on top of linux? If you installed thr image, you can’t run other docker containers apart from add-ons without any hack/workaround.

Yes I installed it on top of Raspberry Pi OS Lite with the provided installer script. So I think it will work and if the problem persists I will try it.

1 Like

I have a similar annoyance so thought I’d post.

I’ve had HA and deCONZ setup for some time and never really had any issues. Until recently I only used Philips Hue bulbs (although recently I added some Tradfri bulbs to my setup but this problem started before I added the Tradfri when I was in a hue only configuration).

Any way, a few months back I noticed that randomly the odd bulb would flash off then on. It might flash off/on once or a few times. There didn’t seem to be a pattern. Also sometimes multiple lights would flash sometimes simultaneously other times one after the other.

I’m fairly sure this starts to happen just after a light gets turned on from a wall switch as sometimes they get switched off. I’m wondering if as my zigbee configuration has grown a point that when a light gets turned on the zigbee mesh does some sort of reconfiguration and causes the bulbs to flash to acknowledge there has been some sort of change.

Can anyone explain why this may happen or what causes Hue bulbs to flash (off/on)?

Is there someway to troubleshoot communications in the mesh or can the deCONZ log file be set to capture this ?

My setup
Home Assistant docker 2020.12.0
deconz docker 2.09.00 / 23/12/2020
Conbee II - 264A0700
I have hue bulbs, hue motion sensors, tradfri bulbs and a couple of Xiaomi sensors.

Gotta tell ya… there is nothing worse for a ‘significant other’ to experience than one or more light bulbs to randomly flash in the middle of the night! Your Home Automation experiment will end up in the trash bin faster than the light bulb flashed. Such is why I do not mix Hue with anything…

I never had this issue and I have now almost 70 devices in my ZigBee mesh from Philips, Xiaomi, Ikea and Osram. Not even once did I see a light randomly flash!

This firmware is from May 2019… Upgrade it and see if your issues persist.

In my case I also turn on the Phillips Hue bulb via a wall-switch. And I think it happens mostly if the bulb was offline for several hours.

Example configuration for a very verbose output would be:

device: >-
dbg_info: 2
dbg_aps: 1
dbg_otau: 1
dbg_zcl: 1
dbg_zdp: 1

It outputs a signifant amount of log entries. Last time the effect happened there were so many log entries that I could not read it. Maybe the amount of logs is too heavy to write permanently to a sd card, so be aware of that.

Thanks for the replies so far.
Yes as soon as I posted my setup versions I noticed my Conbee II needs updating so will try that first before enabling logging and report back any findings.

Got to agree with you there…

I was pure Hue originally but have a large number of GU10 bulbs and the IKEA Tradfri are half the price of the Hue so thought I’d give them a try. Unfortunately though they also seem to come with additional headache so wondering if it was worth the hassle now.

See Tradfri lights wrong status?

So last night I updated me Conbee II stick to the latest firmware as as far as I know all my software/firmware is now up to date and running the latest available.

This morning I switched on a light that had been turned off (via the wall switch) all night then after about 10secs it flashed off/on. about 5 secs after that another light (which was already on) flashed off/on.

Here’s an extract from the log (log has the default settings currently) for that time
09:00:32:422 DeviceAnnce of LightNode: 0x0017880106a25766 Permit Join: 0,
09:00:32:574 ZDP discovery done in 153 ms09:00:34:034 0x0017880104C9EB61 error APSDE-DATA.confirm: 0xE9 on task,
09:00:34:036 max transmit errors for node 0x0017880104C9EB61, last seen by neighbors 2 s,
09:00:39:764 verified group capacity: 24 and group count: 1 of LightNode 0x00178801061f9d82,
09:00:39:766 0x00178801061f9d82 found group 0xFFF0,
09:00:41:934 reuse dead link (dead link container size now 63),
09:00:42:017 0x0017880104C9EB61 error APSDE-DATA.confirm: 0xE9 on task,
09:00:42:024 max transmit errors for node 0x0017880104C9EB61, last seen by neighbors 10 s,
09:00:42:768 [INFO] - No button map for: SML001 endpoint: 0x02 cluster: 0x0400 command: 0x0A payload[0]: 000,
09:00:42:771 ZCL attribute report 0x001788010866BF70 for cluster: 0x0400, ep: 0x02, frame control: 0x08, mfcode: 0x0000 ,
09:00:43:551 [INFO] - No button map for: SML001 endpoint: 0x02 cluster: 0x0406 command: 0x0A payload[0]: 000,
09:00:43:554 ZCL attribute report 0x0017880106F7F097 for cluster: 0x0406, ep: 0x02, frame control: 0x18, mfcode: 0x0000 ,
09:00:44:191 delay sending request 57 dt 0 ms to 0x0017880106A25766, ep: 0x0B cluster: 0x0004 onAir: 1,
09:00:44:245 verified group capacity: 24 and group count: 1 of LightNode 0x0017880106a25766,
09:00:44:248 0x0017880106a25766 found group 0xFFF0,
09:00:45:467 DeviceAnnce of SensorNode: 0x0017880106F7F097 [1],
09:00:45:469 DeviceAnnce of SensorNode: 0x0017880106F7F097 [1],
09:00:45:472 DeviceAnnce of SensorNode: 0x0017880106F7F097 [1],
09:00:45:773 reuse dead link (dead link container size now 62),
09:00:47:819 [INFO] - No button map for: SML001 endpoint: 0x02 cluster: 0x0400 command: 0x0A payload[0]: 000,
09:00:47:822 ZCL attribute report 0x001788010866BF70 for cluster: 0x0400, ep: 0x02, frame control: 0x08, mfcode: 0x0000 ,
09:00:48:184 DeviceAnnce of LightNode: 0x00178801061f9d82 Permit Join: 0,
09:00:48:334 ZDP discovery done in 150 ms09:00:48:746 verified group capacity: 24 and group count: 1 of LightNode 0x00178801061f9d82,
09:00:48:748 0x00178801061f9d82 found group 0xFFF0,
09:00:51:183 skip binding for attribute reporting of ep: 0x00 cluster 0x1000 (end-device might sleep),
09:00:51:234 0x0017880104C9EB61 error APSDE-DATA.confirm: 0xE9 on task,
09:00:51:237 max transmit errors for node 0x0017880104C9EB61, last seen by neighbors 19 s,
09:00:52:974 reuse dead link (dead link container size now 61),

Also what is SML001 ?
I don’t think I have a device called this.

I still havent found out a way to fix this.

A couple of minutes ago I setup up a second Zigbee network (with a CC2531-Stick) and moved the light bulb into this new network. I hope this will fix the issue.

Moving the bulb to a dedicated zigbee network helped. However it’s nothing but a silly workaround.