PI4 - panic:runtime error: invalid memory address or nil pointer deference

signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0x3f08ec
Has anyone seen this?

I got the same error, above
I just booted fresh instalation on my Pi 3B+ 1GB RAM.




when I type

ha core check

I get the ‘help’ section, no actual check.,same with

ha core restart
ha core restart

Web UI is not working on port 8123
ping doesnt respond, no network etc…

Same here. Anyone managed to solve this?

I am also experiencing the same thing on a fresh install of Home Assistant on an SD card

I got it to work now. I had done a fresh install on a Raspberry Pi 4 8GB booted from an SSD, and started it up and got this error. And no matter which command I tried to write in the HA command prompt, I got an error message: “Error: System is not ready with state: setup”.

I had to pull the power to the Rpi to get it to reboot.

Anyway, for me it turned out to be a bad network connection. Once I connected the Rpi properly, everything started up smoothly, and I could finish the setup through homeassistant.local:8123.

Best regards,

Same symptom here - but not on a fresh install. On a machine that has been working for quite a long time. Any clue on how to get out of it? I don’t understand what to do…