Picture Elements - image elements transparent?

I am trying to use a xbox one remote picture, and overlay transparent images over the buttons to use with a IR remote, The transparent images shows as checker blocks (Made them with Gimp) Can this be done? Is there another way to do this? Is my only option to cut the buttons out and use those images as the elements?
Image below is transparent?

Got it working by setting the opacity to 0.

You must be exporting them wrong from gimp. Transparent layers shouldn’t show up at all. What are you exporting as? Some media types do not handle transparency. I usually create all my gimp stuff as pngs.

Could be, but do not think so. I also use png’s and in all other applications they are transparent…
The white block below my first post is the actual transparent image…

@petro @Caz Can you guys please help me with my floorplan? I am using gimp and have got my floorplan to be transparent by adding alpha channel under transparency which removes the white background from my gimp. See image below.

However when I export it as a png with the “save color values from transparent pixels” the resulting png file still contains the white background. See image below.

Can you guys please help me out? Its driving me mad.

does your layer have an alpha channel? Also, are you saving background color and does that background have an alpha channel?

so this is my image and background layer:


whats the setting in the box when you export?

these are the default settings:

Save background color, check it. Background color is transparent. Without that checked, it will save it as white.

I checked it but I still have the white background. I put the image on word to check if the white background is gone but no luck.

yeah just checked it on home assistant as well the white background is still there :frowning:

Not sure what to tell you, I’ve been doing this for years now with the current export settings. You only have 1 layer, and it appears as if it has an alpha channel. With those export settings it should work. To check, the thumbnail image on the desktop should show it transparent.

I have started fresh on gimp. how do I change the background to an alpha channel?

right click layer

doesnt work for me :frowning: is it possible if you could have a go and try ?

You have to add the alpha channel, then delete the background manually by selecting all and deleting. It’s a pain.

I can try not sure if it will translate properly when posted to sites.

I would be grateful if you could try please.

Did u save it as jpeg? Or would it not be better if you could share the gimp file?and then i can export it?

Sorry man, all these image sharing sites are removing the alpha layer.