Platinum Weather Card support

Yeah I can see why its confusing…what the warning means to say is “entity_pop”=value. Value here is a sensor with name sensor.xxxxx, so what it is really trying to say is that xxxx has to have a number in its name.

1 Like

I think I know why… PWC has a list of weather conditions it tries to match: “sunny”, “cloudy”, “raining”, etc. and then picks an icon. This list however doesn’t include “Partly cloudy, light rain”, so it doesn’t find a match and thus can’t pick an icon.

1 Like

I understand thanks for pointing in the right direction.
See where it is in the code now.
Also see there is no new code for 2 years to bad.
Not so platinum after all.

I went to Weather Chart Card now. Got also possibility to add some custom entry’s.

HI Andrew / All
I too am using BOM (Australia) Integration for Sensor data along with my Personal Weather Station for some sensors - all works well but for one thing. I just have NOT got the 5 day forecast ICONS to display. (screenshot below)
In the Platinum card Config I have:
‘entity_forecast_icon_1: sensor.bangalow_mdi_icon_1’

and the HA state sensor for the BOM Integration shows that sensor state as ‘mdi:weather-rainy’ ie to me that looks correct? but nothing shows.

would you mind sharing your Platinum Weather Card Yaml settings for the weather icons please - Im sure its something obvious my end that im missing. i had it working but somewhere along the way I or it busted.
Thanks.

for entity_forecast_icon_1, PWC actually wants the sensor state to be “sunny”, “rainy”, etc. and PWC will come up with the icon.

1 Like

These are from BOM integration…
entity_forecast_icon: sensor.turramurra_icon_descriptor_0
entity_forecast_icon_1: sensor.turramurra_icon_descriptor_1

1 Like

Thanks for your replies. I’ve checked and as I have the BOM setup I don’t have the necessary sensor states exposed to HA, I’ll delve back in to the integration and hopefully now that I know what the issue is can set it up to produce these states for the Icons. Appreciate the guidance. I actually have Two BOM services configured (was experimenting) one the full forecast and another with Hourly forecast. I’m not sure the latter is necessary now but I’ll leave it for now, unless anyone advises this is not a good idea or unnecessary? Cheers

I’m having the same warnings on the forked versions.

'entity_pop=sensor.openweathermap_forecast_precipitation_probability' value needs to have a number
'entity_forecast_min=sensor.openweathermap_forecast_temperature_low' value needs to have a number
'entity_forecast_max=sensor.openweathermap_forecast_temperature' value needs to have a number

I’m not sure i follow what the fix is. I need to create a new entity that is just the value of these without the units?

@madasus1 Try swapping out each of those entities in your cards configuration for the weather.openweathermap entity instead, as you shouldn’t need to use those sensor entities, so change your entities section like this:

entity_forecast_max: weather.openweathermap
entity_forecast_max_1: weather.openweathermap
entity_forecast_min: weather.openweathermap
entity_forecast_min_1: weather.openweathermap
entity_humidity: weather.openweathermap
entity_pop_1: weather.openweathermap
entity_pos: weather.openweathermap

and see if that resolves the warnings

Thanks - it did resolve!

Hi Team,

First time poster so thanks for the work on this. Revised card works a treat (was having problems displaying the icons in the BOM and generic cards).

Just wanted to ask a question on card optics; was wondering if this behaviors is seen elsewhere by anyone else. One of the entity sections (I think it could be wind) seems not to resize text which causes the 2 column split to go into 1. Is there anyway that this could adjusted to resize so it stays in the pretty 2 column view?

When adjustment doesn’t happen

Can’t post the normal photo but suffice to say looks like all the other screenshots.

This is what I was hoping the standard view would look like…

So sorry if this has been addressed but I sure looked. Recently the weather service I used stopped reporting, so I switched to Accuweather. I cannot get the Daly Forecast icons working.

Under “Forecast Entity Icon 1” I have:

sensor.accuweather_condition_day_1

The issue I suspect is that it reports in such a format, “Patchy low clouds and fog early, then mostly sunny; breezy in the afternoon,” so it doesn’t align with the naming of PWC icons.

Is there a workaround?

Have you change the default font size on your phone? If you have set it was a larger font size it could cause this.

Nope. It would appear that if the direction character length > 2 then it happens. I.e. NNW, CALM, etc. Will also happen if gust/speed are going to be too high as well. I might just move it to the 11th cell and see what happens!

What is the list of sensors that accuweather provide? Is there not a short text version rather then the expanded condition one?

Not sure if a pdf is the best way to share all the 129 Accuweather sensors and what they are reporting at the moment, but here you go.

thanks.

Thanks your reply enabled me to track down and fix - as always the fix was easy once I figured out cause. Sharing here incase others ever hit this. I found when configuring BOM integration there are two forecast user selectable options that specifically relate to icons (and of course I found I’d ticked the WRONG one - possibly accidentally when configuring something else).
One wants the ‘Icon Descriptor’ NOT ‘mdi_icon’.
Cheers