Please help me configure a Sonoff Zigbee dongle with my Raspy 4 (Solved)

Hi, I’m new, and I have a problem with zigbee devices, it doesn’t recognize them, I have these errors and I don’t know how to fix it.
Can somebody help me?
I’m sorry I can’t explain myself better, I don’t speak English, I’m Spanish

  1. You have flagged this thread as related to MQTT, however I see messages related to ZHA in your log. Do you know which one you are really trying to use?

  2. Have you connected the Zigbee dongle to one of the USB ports of your device running Home Assistant?

  3. How are you running Home Assistant? Is this a virtual machine, or in a Raspberry Pi, etc?

By the way, don’t worry about not speaking the perfect English here… that is also the case for me, and I believe the majority of people here don’t have English as their first language.
And welcome to the Home Assistant community. People is usually friendly over here. :wink:

Thank you for answering, and sorry for not having explained myself well, I have installed it on a Raspy 4 with 8 mb, on a 120gb SDD connected to a usb 3.0, the Sonoff Dongle is connected to all usb ports, I bought an extension cable from usb in case there was interference (arrives today) and on mqtt I put a capture neither does it detect any device.

Hi there, welcome to HA… That USB 3.0 can cause a problem too, use a USB 2.0 if you can.


Ok, looks like you have ZHA and Zigbee2MQTT running at the same time. They both are good and have pros and cons, so pick one and uninstall the other one, then restart your HA and take a look again for your error messages.

What do you mean by that? Have you tried all the different ports and got always the same error?
Do you know which port you have tried first? If so, put it back to that one and focus your tests in other settings without moving the dongle until you can get it working.
If you don’t know which port to use, I would suggest to just pick one of the USB 2.0 ports on your RPi and go for that.

As I understood the USB 3.0 is used for the SDD and he tried the Zigbee dongle in all the ports…

One more thing, I would suggest you to change the topic from “Help me i’m new” to something like: “Help-me setting up a Sonoff Zigbee dongle with my Raspy 4”, so you will be better attracting the right people to the discussion… :wink:

Also, when you have a chance take a look on the nice material about Zigbee that @Hedda has shared:

Generic best practice tips on improving Zigbee network range and general stability · zigpy/zigpy Wiki (


Fair point, it does sound like he has done exactly what I did and over installed stuff.

This is interesting.
I have had my Sonoff USB in a USB 3.0 port assuming that the later spec was better. Do you know why 2.0 is better in this case? I do have the occasional problem but not with Z2M-HA (using the 3.0 port).

Read and follow these best practice guidelines which apply to all Zigbee implementations → Generic best practice tips on improving Zigbee network range and general stability · zigpy/zigpy Wiki · GitHub

Summery; Zigbee has poor range/penetration/reception + is very sensitive to EMF/EMI/RMI interference and the most common interference source is EMF generated by USB 3.0 ports/devices/peripherals.

Tip is to use a USB 2.0 port if your computer does not have one then buy a powered USB 2.0 hub which in practice will convert a USB 3.0 port into USB 2.0 ports which you can then use for the adapter.

Regardless always also use a long USB extension cable to the Zigbee Coordinator USB adapter, and there you should consider buying a USB 3.0 cable because they generally have better EMF shielding.

Obviously, the USB 3.0 cable itself do not generate interference unless it is connected to a USB 3.0 port.

1 Like

Yes, it is correct, I have tried all the ports with the coordinator, but I always get the same configuration in the hardware
Ruta del dispositivo:/dev/ttyUSB0


I don’t know how to uninstall ZHA

Thanks, I’ve tried all the ports.

Thanks, it’s a Raspy 4, it has 2 USB 2.0 ports, and 2 USB 3.0 ports, I bought a 2 meter USB 3.0 extension cable. Right now the SDD is connected to a USB 3.0 and the Dongle to a USB 2.0

Under “Devices & Services” you should find the “Zigbee Home Automation” integration and if you select its overflow menu (…) you will there be able to choose "Delete (or “Disable”) at the bottom of that list.

Your picture does not show Zigbee Coordinator USB adapter connected via long USB extension cable.

Connect the to the long shielded USB extension cable and then the USB extension cable to the USB 2.0 port on the Raspberry Pi.

Understand that the whole purpose of using a long shielded USB extension cable is to get the Zigbee Coordinator USB adapter as far away from both the Raspberry Pi and the SSD harddrive (as well as any other sources of electromagnetic fields, which includes Wi-Fi Access Points / WiFi Routers and power-supplies) as the goal is to avoid the electromagnetic interference that electrical devices and appliances generate which cause signal reception problem for Zigbee and other low-power radios.

ok, thanks, ZHA is already uninstalled and I’m waiting for Amazon to bring me the cable today, I bought 2 cables of 1 meter each that can be joined to two meters

So, after unstalling ZHA and restarting your Home Assistant you probably will get a new message saying HA discovered ZHA. You can click in “Ignore”, so it won’t get installed again.
Then try to look on Zigbee2MQTT, let us know if you still having issues. Share log messages if you can.

1 Like

It still doesn’t work, these are the logs that come out:

Info 2022-11-22 14:16:39Zigbee: allowing new devices to join.

Info 2022-11-22 14:16:39MQTT publish: topic 'zigbee2mqtt/bridge/response/permit_join', payload '{"data":{"time":254,"value":true},"status":"ok","transaction":"kltmu-1"}'

Very new to the world of HA. Far too many hours spent watching YouTube videos to be productive.

I had a very similar issue. I had a Conbee 2 stick and it would not work. I then tried a Sonoff device which was recognised straight away and configured. I tried to pair a Aqara sensor which would not show on the dashboard. The solution was that I uninstalled deCONZ and this resolved the pairing issue. I’m nit sure if this helps much.

Hello, thanks for answering, the problem is that I don’t know what it is
deCONZ .

deCONZ, ZHA and Zigbee2MQTT (Z2M) are all competing solutions for the same thing… all have advantages and disadvantages, so you will have to pick one and go for that.
If I can make super short, I would say Z2M is still the most advanced and mature, with support for more devices (take a look on this compatibility matrix) and will allow you to install your Zigbee controller in another RPi in a different location than your HA. But ZHA (the one I’m currently using) is easier to use. I’ve used deconz a long time ago and I’m sure I’m not going back to that direction.

Switch between one to other will require some work depending on the number of devices you will have to re-pair, but it’s not impossible, so pick one of the solutions now and you change later if you think it worth the effort. Any of those solutions will be good for a beginner, unless you already know you have devices that are not compatible to some of the solutions (take a look at the compatibility matrix).

All those solutions are proven to work, so I believe if you try to change the solution now you will have the same chance to solve the problem as you would have but just starting over and trying again to install the same solution you tried before (Z2M).

My suggestion to you is:

  1. Remove everything you have installed related to Zigbee, like ZHA integration, deconz, Z2M, etc…
  2. Restart Home Assistant
  3. Install again just the option you want to use. If that is not ZHA, you will have to click “Ignore” when it is automatically detected by your system. If you are going to Z2M, don’t forget to install MQTT support first (if not already installed). You will find it between the add-ons.

Then share your logs here again is you still having issues