Plotly interactive Graph Card

Sorry, found my mistake…

The solution to the weather forecast question: Weather forecast plot (`meta` and nested attributes) · Discussion #213 · dbuezas/lovelace-plotly-graph-card · GitHub

1 Like

It worked fine, thanks!!!


Hi Edward, can you share the yaml for this :slightly_smiling_face:

With a post in Show&Tell, not here please! :slight_smile:


There is (including versions for Tibber and NordPool):


I just hit the upgrade button and get this on all my MACOS browsers. Safari and Brave
my ipad IOS is fine. Home assistant on iOS is also fine.

the other browsers are likely showing the cached version. The errors you see are the braking changes stated in the release version notes. But don’t panik, the error messages tell you how to fix them! :slight_smile:

I just noticed the repo has pretty much one closed issue per star. If this wasn’t open source, the cost per star would be absolutely outrageous! :laughing:


A quick question I could not find (maybe I cannot search well): how can I set the color of a bar? For a line color (and fill color) I know how to do it, but I cannot find the way to set the (fill) color of a bar?

I’m not sure if this is the best way, but the marker worked fine for me to set the color:

  - entity: sensor.total_energy_utility_meter
    name: Energy consumption
    type: bar
      color: rgba(165,165,0,0.6)

I am also not sure if it is the best way, but the most important thing is that it works :slight_smile:

1 Like

Hey, trying to figure out the new $fn for using theme colors and I’m missing something.

  - entity: sensor.motion_sensor_1_temperature
    connectgaps: true
      width: 3
      color: $fn ({css_vars}) => css_vars.primary_color

It isn’t throwing any visible errors (like when using the wrong variable), but it also isn’t setting the color of the line. I’ve cleared the cache and hard refresh, so I’m pretty sure the updated code is active.

primary-color in the theme is: primary-color: "#aa3151", but the line is the default blue.

Thoughts on what I’m missing?



Yes, that’s an oversight on my side

Ich try to set modebar orientation to vertical like in default config, but when raw_plotly_config enabled. But I cannot find a way or position in yaml which is working. Neither on entity, not under config not in root, … Do you have a hint?

And secondly. Are there parameters to adjust position of the modebar in terms of margin, etc. as well? Was noch able to find something related in plotly doc.

Here’s the lead:

This files contains the defaults. The “optional” ones are disabled in raw_plotly_config mode.

Ofc I searched there and saw this before, but it is not working in yaml until now. Therefor my question

It goes inside layout

1 Like

It’s better if you post your screenshot and yaml in github. Inside discussion/q&a

omg. Most probably the only place, where I missed to put it. Skipped it because of the notation in your code

    // modebar is missing from the Layout Typings

It is working. Thank you. Any ide on styling this one (position, …) as well?