Port forward on raspberry pi


I’m asking if you can help me port forward my HA to my domain. I’m using raspberry pi 4 and my DuckDns is all set up (I hope it is correct). I port forward with HA IP from 443 to 8123 and there is no ping on my duckdns domain site. I tried almost everything and nothing helped. I would really appreciate your help.

Thank you for your time.

My config at the moment.

Have a look at this guide and work through it.

You also have to add a second rule, for external port 8123 to go to internal port 8123 as well.

Did it but still can’t access it with duckdns domain

Keep both rules there. Go through this video, you might find whaty was not done correctly -

No, it didn’t work. Also, ports 443 and 8123 are open and duckdns.org is the same as my IP. But still can’t access the domain.

Can you be more specific with what the error message is? Can you reach it internally?

Internally yes. I can reach it via https://homeassistant.local:8123/ or via https://HA IP:8123/. As I stated before ports are open, and I have SSL and domain. But with the domain, I can’t reach HA.
I hope it helps.

I am experiencing the same issue since I installed HA last week.
I wrote this post, but haven’t find a solution yet.
May it be some new version issue?

You only need to forward one port to access HA via DuckDNS. In my case I use http locally and https remotely. In HA Settings - Network these are my URL’s:

Internet: https://mydomain.duckdns.org:306424
Local Network:

In the IOS Settings - Companion App - Home I use the following:

Internal URL:
External URL: https://mydomain.duckdns.org:306424

In my router I have a single port forward rule:
Port: 306424
Forward IP:
Forward Port: 306424

You can use any port number (including the standard 8123) as long as it’s not being used by other processes.

If you ping https://mydomain.duckdns.org it should reply with your current IP address provided by your ISP. You can test access with a cell phone from home by turning off WiFi and entering https://mydomain.duckdns.org:306424 into a browser on the phone.

1 Like

Okay, It magically started working now. Still thank you to all that helped me. Much apprised.

Excellent. I learned networking the hard way - through alot of trial and error! One of the most annoying things was, when you make a change - and made the right change - but it still doesn’t work - sometimes but not always (depending upon what it is) - is because very often you have to do a full reboot for certain devices for the changes to actually go into effect. So sometimes to play it safe to be certain, you are stuck with “make a change”, reboot, wait. Make a change, reboot, wait. Ok that didn’t work, I’ll change it back - make the change, reboot, wait… (and many times there are several different things you need to all reboot - so if your router is rebooting so you have to also wait for everything to then reconnect to it…) ugh!