Power plug with power usage monitoring but without a relay


I am looking for a power plug that can measure power use, but does not have the ability to cut power to the connected device.

I don’t mean a device that has it, and just not use it.
No I am looking for a device that measures power utilization but does not have the physical capability to disconnect power to the connected device (You can call me paranoid if you want).

EU power plug, with ground.

Ive never seen an off the shelf item like that. Figure the demand for it vs a switchable one wouldn’t be enough to justify production.
Not a plug but: How to Build a DIY Household Energy Monitor Using ESP8266

I get your ask though since for a freezer I was scared to put a zen15 on it for the same reason. Best option employed by many here is to create an automation if off that escalates the longer it remains off.

Hack one to bypass the relay. Just short the normally-open contacts with a piece of #14 wire.

1 Like

I am considering doing this to some TP-Link/Kasa smart plugs, but would sure prefer to buy something off the shelf. I doubt an off the shelf product like this exists, but I’ll keep an eye on this thread for a bit before chopping one of my Kasa plugs open in case someone finds something.

Some sockets (not plugs) that report energy have a software option to disable switching via the buttons , would that do ?

That would work for me! Can you supply some examples?

I forgot to check where you are. I’m in the UK and here’s such a socket although I believe the manufacturer (Aurora) may be in administration. Also WiFi , ZigBee, ZWave ?

Aurora AOne Zigbee Double Plug Socket (Switched 13A) - Smart & Secure Centre
Aurora AU-A1ZBDSS Aone Smart 13a Double Socket - Edwardes

I’m in the US and prefer Wi-Fi (but would make do with any protocol).

The OP, on the other hand, said they wanted an “EU power plug with ground”, by which I suppose they mean type E/F.

I have this exact same requirement… My garage freezer has been turned off somehow one more than one occasion and so I’m looking for something small that could be hard wired into the freezer just to report energy use… No relay at all!
I could use this kind of device on a few items around the house and without a relay the device could in theory be very small…

for this one I use the shelly plug S flased with tasmota and use PowerOnState4
which makes it impossible to disable the relay.
only when using over 2500W this one kicks out(I think hardware) because of security reasons but it doesn’t brake, it comes back after a while.

you might could accomplish the same using ESPHome, but haven’t tried that. have some bad XP with ESPHome on deviced without a pinout.

Edit, sorry I see you are in US,
but still this poweronstate might work for you.


This is my exact use-case and before reading the forums, I got some poor Eve plug which is great if you want to integrate with Apple Home and run some automatization… but in my case, it was a complete waste of money…

So, can you please confirm

  • Does this shelly plug S works with HA Power dashboard
  • with the custom fw the switch can be disabled

Thank you

Using the default firmware I don’t know, Using custom/tasmota: yes. Using ESPHome probably also

all of these are shelly plug S.

either for tosmota use “poweronstate”
for esphome, do just not configure the button.

You could take a look at this project

however I can’t find the youtube video anymore and the project is discontinued. Still you would be able to use it, you only need it once, after that you can just update tasmota.


It seems the mentioned URL for Tasmota no longer working

So, any other alternate way to disable on/off button for ShellyPlugS, so I can avoid accidental turn-off the connected device?

Thank you

How about TPlink P115? I have this and I cannot see it can be switched on or off physically.

You can turn it on or off via app. And for that you can create monitoring script in HA, and turn it on automatically if it’s off.

Or, I miss something about your question/requirements?

files are available in the tasmota repos now

What does this button do on your version?
Could be an option but they don’t seem to have an equivalent model for AU/NZ…

You right, that’s the power button. I have never touched that tbh. Even though I moved it from time to time to measure power consumption :sweat_smile:


When I try to flash Tasmota OTA with the new URL, I got only this


But nothing else. What can be wrong here?

The URL I use is this


Thank you

I actually don’t know,
what device do you have? a plugS or a shelly2?
the link you are referring to is for a shelly2
where earlier you were asking about the plugS.

I don’t know if there is any validation on this or not, haven’t tried to upload the wrong file.

next to that, your shelly should have internet access. And I read about people not being able to flash the new PlugS with RGB colors, but I don’t own that one, so I can’t test this.

You were right :slight_smile: After I used the correct firmware it flashed to Tasmota, but I’m a bit confused and sorry for being so dumb, but this is my first trip into this world

So, I have this minimalistic Web UI which is quite different from the one from Shelly. I suppose I have to use some configuration, so it will work again.

I even tried the config template from here

But, even with this the ON/OFF switch isn’t working neither any power measurement

What do I miss here?

Thank you