Presence detection, BLE, mi flora, RF gateway with ESP32, OpenMQTTGateway is now compatible

No need, you should be able to use the v0.9.11 which use already your BBQ sensor format

Thanks put but you do not think it works I am attaching an image.

I can see the temperatures of the 2 probes. Is it not what you are expecting?

oh yes thank you i had a problem with mosquitto that did not see my ibqq now it’s fine thank you

1 Like

v0.9.12 is out!

@h2zero integrated natively SwitchBot S1 BLE control to this release, the switch is auto-discovered into HASS like all the other BLE sensors with OMG.


What’s Changed

New Contributors

Full Changelog: v0.9.11…v0.9.12


This sensor is supported Out of the Box by Theengs and OpenMQTTGateway, both use auto discovery.
If you have the MQTT addon and a user configured for it you should retrieve the sensor data in less than 5 minutes in both cases.
No YAML configuration required.

1 Like

do you need both or can you just use openmqttgateway on an esp32?

You can do:
-openmqttgateway only or,
-theengs gateway only

But there is also added options to fit every need;
-openmqttgateway + theengs gateway to have 2 BLE readers
-several esp32 with openmqttgateway or several pi zero with theengs gateway to increase your coverage

And if you want to offload the esp32:
-openmqttgateway to theengs gateway so as to use OMG only as a pass through of BLE messages and have the decoding done by Theengs

In all these cases only one device/sensor will be created, and this device will be feed by the multiple readers.

My inkbird will be delivered tomorrow I hope
I installed OMG and connected and configured but I can not tell if i is working
I see no new mqtt settings
I tried listening to and mqtt packet when pluging it in
something like home/openmqttgateway_esp32_ble/version but got nothing.
how do I tell if it is there or just wait for the inkbird to automagicaly see something?

I would suggest to connect MQTT explorer, this will give you a comprehensive view of all the packets coming.

At least you should see the gateway into the devices section of Home Assistant if you have activated auto discovery for the MQTT integration:

got it chaned home/ to homeassistant/

  username: xxxx
  password: xxxx
  discovery: true
  discovery_prefix: homeassistant
    topic: 'hass/status'
    payload: 'online'
    qos: 0
    retain: false


Great work!!!

I’ve successfully linked the code to my maverick thermometers which feed through rtl_sdr into MQTT so it was an easy change. When I get a chance (or maybe someone else will contribute), I’m going to add some buttons on the lovelace panel to set the gauge colors and ranges for “low and slow” (225F) and “Poultry”(350F). Of course, in the meantime, I’ll just create two lovelace views, one for low and slow, the other for poultry…but having it all on one is more elegant.

Then, I’m going to try to add “time til done” estimation. If I know how long it takes for the temperature of my probe to raise the termperature 1 degree…and I know how far I am from the target temperature, then it’s simple arithmetic. It’s a general projection, but close enough to warn folks when dinner might be ready.

You should not need yaml configuration, here is the option to activate on your broker integration:

I am not sure if that yaml is leftover from the ring integration and no longer needed or needed :slight_smile:
Guess I could remark it out or look at ring again, but it is working.I do have that enabled for new entities but this OMG did not show up until I changed home/

Just none of my business, but 2271 devices? Do you have each pixel on an led strip connected ? grin> Am I missing out on something exciting?


BTW, so sad. Amazon failed again. Maybe I will get the inkbird tomorrow

Lol, I got the Ibeacon detected and they have random mac address. This now filtered with the last OMG version.
So now you can see the device corresponding to OMG?

sorry I have company and was away. Yes I get the OMG entry ‘BT’
I never did get the INKBIRD. Reordered, maybe tomorrow
Happy Fathers Day !

1 Like

I have OpenMQTTGateway running on a esp32. Have the inkbird IBT-2x white-listed to only show that. HA is discovering sensors. But still not showing any temperature values at all. Not seeing anything in devices or entities. Had similar issues with esphome as well.

First any app need to be disconnected from the sensor.

If you are disconnected, could you access your mqtt broker with mqtt explorer to check the messages that you have?

Also as an alternative you can install Theengs Gateway as an add on

If you don’t see the sensor in mqtt explorer and with Theengs gateway we will take a look to the advertizement messages with a scan from Nrf connect.

Same issue here, i’ve had to change iBBQ to xBBQ to get it discovered by ESPhome. Both probes are showing 0.

if (x.get_name() != "xBBQ") return;
[23:04:09][I][ble_adv:048]: New BLE device
[23:04:09][I][ble_adv:049]:   address: D4:79:00:00:03:A4
[23:04:09][I][ble_adv:050]:   name: xBBQ
[23:04:09][I][ble_adv:051]:   Advertised service UUIDs:
[23:04:09][I][ble_adv:054]:     - 0xFFF0
[23:04:09][I][ble_adv:057]:   Advertised service data:
[23:04:09][I][ble_adv:063]:   Advertised manufacturer data:
[23:04:09][I][ble_adv:066]:     - 0x0001: (00.08.A4. (12))
[23:04:15][D][sensor:125]: 'iBBQ Temperature Probe 1': Sending state 0.00000 °C with 0 decimals of accuracy
[23:04:28][D][sensor:125]: 'iBBQ Temperature Probe 2': Sending state 0.00000 °C with 0 decimals of accuracy

my nrf scanner shows xBBQ also
so where do you change frfm iBBq to xBBQ to get it in HA?