Problem Getting Device Tracker Working For Orbi

I’ve been trying to get device tracker up and running so I can track when one of us leaves the house and not having any success.

In the docs it mentions that known_devices.yaml is depreciated but then goes on to say that the Netgear devices should auto populate into that file. I’m not sure if it is still used or not but I know that after setting up my Orbi that the known_devices.yaml does not appear in my config directory.

As per the instructions regarding Orbi, I set up the accesspoints and even used a few posts on the forums to really make sure I’m trying to configure this the way I should, but I don’t see any devices in my HA (not sure what to look for, I just looked for devices that didn’t yet have an area) and no known_devices.yaml makes me assume that it’s not working.

My config is thus:

  - platform: netgear
    port: 80
    username: !secret orbi_username
    password: !secret orbi_password
    interval_seconds: 10
    consider_home: 360
      track_new_devices: false
     - CC:40:D0:40:29:83 # Router
     - CC:40:D0:4E:41:79 # Satellite_1
     - 18:55:E3:67:79:7F # My Apple Watch
     - 5A:C9:D7:Fb:A7:C8 # Her Apple Watch

I have a similar config but without the ‘devices:’ config and for me it’s working.

What happens it you remove those (or comment them out)?

Another tip is to surround all MAC addresses in double quotes just to be sure. Same for password.

And to troubleshoot you could also disable the ‘accesspoints:’ config and see what happens.

Have you looked at the logfile for any error or warning?

If you’re tracking apple watches, do you have the right mac address? Apple watches, iPhones and iPads don’t report their actual mac address by default. They create a mac address per wifi network they connect to for privacy reasons, they want to make it more difficult to track you across networks.

The mac address they generate doesn’t change once they make it for a particular network unless you have it forget that network and reconnect. But you have to go into the wifi settings to see what mac address the device is reporting for the particular network. Or you can turn off that capability just for your home network (but let it keep protecting your privacy on other networks)

If you have track_new_devices as false and also don’t specify devices, what are you tracking?

Did that, still doesn’t work for me. I get constant 2021-02-07 13:40:37 WARNING (MainThread) [homeassistant.components.device_tracker] Updating device list from legacy took longer than the scheduled scan interval 0:00:10

I am able to scan my network and see these the current MAC’s for the watch and match the watch information as well.

Have you tried setting track_new_devices to true? Since you’re looking only for specific devices by mac address I don’t think it’s possible for it to pick up any new devices anyway. I haven’t tried that option with netgear personally, maybe it has to be true to allow it to create the trackers and then can be set back to false after that?

I don’t want to automatically create a device tracker for each new device on the network. Like a PC or my mom’s phone. I only track the phones from family members by setting those to true explicitly.

The false setting creates entries in known devices without creating device tracker entities.

Have you tried to increase the interval to 30 seconds to see if this makes a difference?

I wanted to refresh this thread - because as of the latest versions of Device_tracker integration with netgear (aka orbi) the mac address tracking is GONE. This has broken a lot of things…
When adding the netgear now via UI (you cannot use the yaml anymore) it adds all the entities and devices, but they are UNKNOWNS - no way to see mac address anymore.

This is important for those devices where the DHCP is handled via another device and Orbi is nothing more than Access Point only… not a router.

Does anyone have a workaround for this? I am going to submit a bug on this otherwise.

1 Like

No workaround…but I see this too, and it’s pretty annoying. My Orbi’s are in AP mode with OpenWRT handing out IPs. I’ve given up on the Netgear integration for tracking for now. :frowning: