Problem ipv6/ ipv4 German ISP Unitymedia

My german ISP “Unitymedia” only provides ipv6. Since i want to access my pi3 HA from the Internet it does not work because it only runs on ipv4. What can i do?

You can configure PI3 to use IPV6.
Your ISP provider router/modem must have possibilities to configure IPV6 to IPV4 tunnel and vise versa.
Duckdns supports IPV6. Create and use FQDN and you will not dealing with IPV6.

I guess the problem is that Unitymedia uses DS-Lite also known as carrier NAT. So your connection with IPv6 is “hidden” behind the public IPv4 of the provider.

The problem may not be solved using IPv6 on the RPI3. If you want to access the RPI3 from an outside IPv4 only network (like german mobile networks) you have to use an 4to6 tunnel broker.


i guess i have the same problem. i upgraded to another product from unitymedia and now i have only ipv6.
DuckDNS isn’t working anymore :frowning:
did anyone found a working solution?
Did you get it working? And are you from Münster? I’m also living in Münster :slight_smile:

You can try to switch to a business product from unitymedia to get your IPv4 back.

Alternatively you have to use a tunnel broker like

1 Like

I have the same problem im Munich with M-Net and DSL-Lite.

Does someone know a walk-through to set up remote access via IPv6?
I tried this ( but it does not work with DSL-Lite…obviously…

I’ve managed to use IPv6 now, so HASSIO is accessable through the IPv6 Adress.

My mobile provider (T-mobile germany) supports IPv6 so I am able to acces my HASSIO remotely.

You may have to ask M-NET to change your account from DS-Lite to full Dual Stack.

M-Net offers an option for Dual Stack for 5€ per month. That is a bit steep for me.
I was looking for a guide to setup with a tunnel provider as but could not find one which is simple enough for my very limited knowledge ein this area.

Hi Lokus,
did you find a solution? I am still stuck with no external access. :frowning:
If you want we can also discuss this in German via PM.


unfortunately, i didn’t find a solution for ipv6. but i called unitymedia after they switched to ipv6 and i could convince them to change back to ipv4. maybe you can give them a call…

Thanks for the feedback. I tried, but they stick to charging 5€ per month. Thanks anyway

Do you have a real IPv6 address? You can access HA via IPv6… my HA is ONLY accessible via IPv6.

This is possible to make work quite easily.

(I do have dual stack but duckdns is set to only use the IPv6 address)

Hi, thanks for your response. I am trying to set up the IPv6 access
( over IPv6)
Unfortunately without success so far.

So it’s possible… do you have a public IPv6 address for your device? You need to open port 8123 for that device then it should work

You are right. I know that it is possible. I just don’t understand what I am doing wrong.
I have the public IPv6 of my RPi. Every month or so there is a change in the 3rd and 4th block but the last 4 blocks remain always the same.
Still, I am not able to access my over this address.

I appreciate your help. But since I am discussing this issue already in another thread ( over IPv6 Thread) and this is deviating somewhat from the topic of this thread. I will focus on the over IPv6 Thread.

Hey here are the Settings I used, seems to work as far as I can tell - I used a custom port (8123, yours might be different - 7123, 80, 443, …).

You can find out what the IPv6 address of your hassio is by looking at the Connected devices page.

(I made more Screenshots but I am not allowed to upload them, if you need more, let me know)